Permanent Wacom configuration systemd udev service not running at start

perhaps start over - it seems this is now a mess …
I had no problem following the wiki - but I detail here where and why I amended it.

first create the udev rule:

sudo nano /etc/udev/rules.d/99-wacom.rules

put the contents in

(you need sudo for this because you want this file to be in /etc/…
this is the only command that needs sudo/root rights - all of the rest should not be run as root!)

create the directory because it initially does not exist

mkdir -p ~/.config/systemd/user

then you can save the wacom.service unit file to it:

nano ~/.config/systemd/user/wacom.service

put the contents in and save
(I did not amend the
I just copy pasted and left it as it was - this you should fix)

once again create a directory which does not exist by default (perhaps you already have it though)

mkdir -p ~/.local/bin

Because this directory is in your default $PATH
echo $PATH
will show you

create the in that location:

nano ~/.local/bin/

put the content in and save

then, make that script executable:

chmod +x ~/.local/bin/

Now you can enable the service:

systemctl --user enable wacom.service

I did all that in exactly that way and got no error.


Thank you very much for your help, really appreciate it, but the script still doesn’t run at logon.
@Nachlese I started again from scratch and followed all of your steps scrupulously. I got no error indeed but the script just doesn’t run when I start my session.

Again, a simple solution that I found is to add the script in the “Session and Startup” → Application autostart list. Could you explain how that solution might not be correct, aside from not matching the title of the topic ?

If it works, if it does what it is supposed to do - I’ll not explain why it is not correct, no. :slightly_smiling_face:
It may not be “lege artis”, but it is not incorrect.

I understand, makes sense.
Well, thanks a lot for your help @TriMoon and @Nachlese .
I’ll create another topic without systemd and udev in its title with a solution for the sake of helping the community.
For who landed on this topic to configure a wacom device on XFCE :

Hope that helps others