Perl package stability



Hi folks,

I started using Manjaro (i3) over 2 years ago. I’m very happy with the stability, but in the last 3 months the perl packages, especially:

  • shutter
  • gscan2pdf

broke 2 times. It’s critical to me to be able to scan documents / make screenshots on every business day of the year, without spending ours reinstalling packages.

$ shutter
Can't locate Gtk2/ in @INC (you may need to install the Gtk2::ImageView module) (@INC contains: /usr/lib/perl5/5.26/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.26/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.26/core_perl /usr/share/perl5/core_perl) at /usr/bin/shutter line 47.
BEGIN failed--compilation aborted at /usr/bin/shutter line 47.

$ gscan2pdf
Can't locate Data/ in @INC (you may need to install the Data::UUID module) (@INC contains: /usr/lib/perl5/5.26/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.26/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.26/core_perl /usr/share/perl5/core_perl) at /usr/share/perl5/vendor_perl/Gscan2pdf/ line 17.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Gscan2pdf/ line 17.
Compilation failed in require at /usr/share/perl5/vendor_perl/Gscan2pdf/ line 13.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Gscan2pdf/ line 13.
Compilation failed in require at /usr/bin/gscan2pdf line 47.
BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 47.

My understanding of the problem is that it occurs because the aur packages are built against an older perl version and the aur package maintainer needs to push a newer version built against the latest perl version? (correct me, if I am wrong!). (Orig answer from @philm : [Stable Update] 2017-06-18 - Kernels, Plasma, KDE Apps, Firefox, Thunderbird, Mesa )

Last time I waited couple of days, tried reinstalling (and compiling) everything, which worked after a couple of days. Now it would be great to find a permant solution for this problem or at least write a script, that does it for me. I’m happy to help (testing)!

I’m using yaourt as a packagemanger!

I also found a couple of posts related to this problem, which all find a solution, but don’t find a permanent solution, which would be needed!


Place packages in IgnorePkgs in /etc/pacman.conf, you will have to place the dependencies also: e.g.:

 shutter dependencies:
 - xdg-utils (already installed)
 - imagemagick (already installed)
 - procps (already installed)
 - librsvg (already installed)
 - gtk2-perl (already installed)
 - desktop-file-utils (already installed)
 - perl-x11-protocol (already installed)
 - perl-net-dbus (already installed)
 - perl-json (already installed)
 - perl-json-xs (already installed)
 - perl-xml-simple (already installed)
 - perl-locale-gettext (already installed)
 - perl-file-basedir (already installed)
 - perl-xml-simple (already installed)
 - gnome-perl (building from AUR)
 - perl-gnome2-wnck (building from AUR)
 - perl-gtk2-imageview (building from AUR)
 - perl-gtk2-unique (building from AUR)
 - perl-proc-simple (package found)
 - perl-proc-processtable (package found)
 - perl-sort-naturally (package found)
 - perl-www-mechanize (package found)
 - perl-file-which (package found)
 - perl-file-copy-recursive (package found)


Hmm but wouldn’t it be better that manjaro holds back the Perl packages, until these 2 applications are updated?


I’m the maintainer of Shutter’s AUR package and can tell you what the problem is: It’s not about Shutter itself but about its Perl dependencies. They don’t have to be updated, just rebuilt. The problem is that new Perl versions first enter Arch testing and/or unstable, then Arch stable, then Manjaro testing, then Manjaro stable, etc. So, depending on the repos used, the time of the rebuild is different and I cannot bump the Perl packages such that it fits everybody. I asked for a feature to handle this problem, but got no useful replies yet: Automatic update of broken Perl packages from AUR


The fact Shutter is in aur says it is pretty much abandoned to the wild :smiley: ( sorry @photon )

Can you not replace these two programs with something better supported?

Shutter - try spectacle for a KDE program it has very few dependecies:

Name            : spectacle
Version         : 17.08.1-1
Description     : KDE screenshot capture utility
Architecture    : x86_64
URL             :
Licenses        : GPL
Groups          : kde-applications  kdegraphics
Provides        : None
Depends On      : xcb-util-cursor  libkipi  purpose
Optional Deps   : kipi-plugins: export to various online services
Required By     : None
Optional For    : None
Conflicts With  : kdegraphics-ksnapshot  kscreengenie
Replaces        : kdegraphics-ksnapshot  kscreengenie
Installed Size  : 1611.00 KiB
Packager        : Antonio Rojas <>
Build Date      : Tue 05 Sep 2017 23:40:51 BST
Install Date    : Fri 08 Sep 2017 08:03:11 BST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Gscan2pdf - xsane ???


I know, me and other members of the Launchpad Shutter team got access to the bzr repo to apply patches which have accumulated throughout the last few years, which we did, but unfortunately none of us can do further coding, so Shutter is basically as dead as it was for some years.


You shouldn’t be leaving business-critical applications to AUR packages.

I’d suggest you use a different distro for “mission critical” applications, e.g. CentOS or RHEL. Manjaro is great, but stability of application versions isn’t one of its features.

Manjaro doesn’t owe your business anything. If you’d like paid support, that’s another matter. :wink:


Can I rebuild them myself easily? If so, how? I would like to document it!

It totally understand your point, but maybe we can improve stability together - a lot of other users will benefit as well.

I know as well. But the reason I use Manjaro is that I believe in free and open software. So I rather create a forum thread, understand the problem and help finding a solution or at least document and explain a workaround than pay for M$ or other software.


Just reinstall the package from aur - that will rebuild it.


no - that doesn’t work


Works here - what errors do you get???


I just used yaourt -S --force shutter

now i removed the package yarem and installing it again yain. After all the rebuilds I still receive the same error …

edit oh-my-zsh shortcuts:


Eh? whats yarem and yain?? Post exeact errors please.


I updated the previous post about the shortcuts

the installation goes through on start i receive following errors:

 23:44:20  ~ 
$ gscan2pdf
Can't locate Gtk2/ in @INC (you may need to install the Gtk2::ImageView module) (@INC contains: /usr/lib/perl5/5.26/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.26/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.26/core_perl /usr/share/perl5/core_perl) at /usr/bin/gscan2pdf line 62.
BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 62.


I just needed to reinstall perl-gtk2-imageview. I will summarize everything in the next couple of days.


Beat me to it, just installed gscan2pdf to work that out :smiley:

After an uninstall:

sudo pacman -Rns $(pacman -Qtdq) 

Removes all extraneous packages - may help may not.

Uninstalling gscan2pdf.


You could say that about any other Linux distro. Jonathon has a point which summarizes to this “You are making your life hard and M$ has nothing to do with this” Using rolling release distros for business, isn’t smart especially when you are using yaourt and AUR which aren’t exactly supported by Manjaro.


Sorry, I’m a bit late, you already figured it out. But the directions are in a pinned comment (by Ralf_Mardorf) on Shutter’s AUR page:


I think you could use Pacman hook when the dependencies are updated to rebuild it or at least to inform user


I will try to research that, thanks for the hint!