Periodic CPU usage for no apparent reason

Hi there :smiley:.

Since yesterday I noticed that my system seem to be processing something periodically, even when idle. By processing I mean that the fan runs like when the CPU is processing something. I even tried to close all process and still the system started processing something periodically. When I try to open just the System Monitor it rarely goes above 2% of CPU and there is no peak of other processes during the strange processing.

Do you know what might be going on?

I’m running the latest stable release of Manjaro 21.1.5 and here it is my inix -F:

Show inix - F
  Host: espectro-estranho Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 
  Desktop: GNOME 40.5 Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 20KS0039PG v: ThinkPad E580 
  serial: <superuser required> 
  Mobo: LENOVO model: 20KS0039PG v: SDK0J40697 WIN 
  serial: <superuser required> UEFI: LENOVO v: R0PET47W (1.24 ) 
  date: 08/29/2018 
  ID-1: BAT0 charge: 40.2 Wh (99.0%) condition: 40.6/45.7 Wh (88.9%) 
  Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP cache: 
  L2: 8 MiB 
  Speed: 656 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 656 2: 751 
  3: 705 4: 737 5: 761 6: 675 7: 613 8: 650 
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
  Device-2: AMD Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X] 
  driver: amdgpu v: kernel 
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  Display: wayland server: 1.20.13 driver: loaded: amdgpu,ati,intel 
  unloaded: modesetting resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.2.3 
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.10.70-1-MANJARO running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp3s0 state: down mac: e8:6a:64:5d:67:6e 
  Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  IF: wlp5s0 state: up mac: 1c:1b:b5:90:55:a1 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb 
  Report: rfkill ID: hci0 state: up address: see --recommends 
  Local Storage: total: 1.14 TiB used: 142.33 GiB (12.2%) 
  ID-1: /dev/nvme0n1 vendor: Lenovo model: LENSE30256GMSP34MEAT3TA 
  size: 238.47 GiB 
  ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  ID-1: / size: 48.83 GiB used: 42.16 GiB (86.3%) fs: btrfs 
  dev: /dev/nvme0n1p3 
  ID-2: /boot/efi size: 511 MiB used: 568 KiB (0.1%) fs: vfat 
  dev: /dev/nvme0n1p1 
  ID-3: /home size: 184.16 GiB used: 100.17 GiB (54.4%) fs: btrfs 
  dev: /dev/nvme0n1p4 
  ID-4: /var/log size: 48.83 GiB used: 42.16 GiB (86.3%) fs: btrfs 
  dev: /dev/nvme0n1p3 
  ID-1: swap-1 type: partition size: 4.98 GiB used: 0 KiB (0.0%) 
  dev: /dev/nvme0n1p2 
  System Temperatures: cpu: 54.0 C mobo: 0.0 C gpu: amdgpu temp: 47.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 314 Uptime: 2h 37m Memory: 7.54 GiB used: 2.21 GiB (29.3%) 
  Shell: Zsh inxi: 3.3.06

Your post seems contradictory, you notice that system seems to be processing something periodically, but then you say there is no activity when monitoring, so maybe explain what you mean. What is “processing”?

1 Like

Sorry about that. What I meant is that the fan runs like when the CPU is processing something but I can’t pinpoint what is exactly making the fan run. I notice it because it runs for a few seconds every other minute.

Maybe it simply gets hot?

//EDIT: you can monitor it and see if you can spot temperature issue, install:

sudo pacman -S s-tui

then run s-tui from terminal, and monitor (don’t use the stress test, just monitor)

1 Like

It didn’t do this before. I started noticing this behavior yesterday or the day before. I even tried to boot Gnome and XFCE from a usb drive and it does the same thing. It’s really annoying to work like this. My system is not that old and the room temperature is 22.4 ºC.

I’ll try to boot a older version of Gnome to see what happens.

Thanks for the interest @omano.

The command s-tui shows that the temperature stays constant and the cores’ temperature is always bellow 50 ºC. The fan’s graph show activity equally spaced like I’ve said.

I’ve try booting Gnome Manjaro 20.2 from a usb drive and this issue doesn’t appear. I assume it could be a Kernel problem, so I tried booting other Linux kernels but it didn’t work. I don’t want to clean install a older version of Manjaro just to fix this problem.

Any thoughts?

What kernel is running on the ISO without the issue? Try this same kernel on your Manjaro then.

//EDIT: now that I read again your post, is it what you already try?

The ISO is running Linux 5.9.11-3, which is no longer on the current repositories.

I’m at a lost. Does anyone has some additional insight?

This might be a kernel thing then, related to your hardware, I don’t know. 5.9 is old yes and you can’t have it anymore from Manjaro. Try other kernels, it is easy to switch from Manjaro setting, probably one works better with your hardware (maybe 5.4).

In my system I used to have to add i915 to MODULES inside /etc/mkinitcpio.conf to load the integrated GPU drivers earlier to avoid a black screen. I notice that now with the latest Manjaro version, it boots normally without making this change.

Yesterday when I undid the change it didn’t do anything, but today when I booted the problem was gone. At least until now. I don’t know if this two things were related, but it was the only non-standard change that I make to my Manjaro installation.

I’ll wait a bit and mark this as solved if it stays this way.

It’s happening again :expressionless:. I tried again what @omano said and I ran just s-tui and left the system idle. Here’s a screen shot:

What do you think about these temperatures? I notice that Sensor1,0 is always larger than 50 ºC.

Maybe this is a fan configuration problem. Do you know how can I see my fan configuration?

Tried kernel 5.4?

Also you can zoom out with CTRL + - so you can see more of the program. We can see one core is at boosted frequency too.

Usually you see and tweak fans i the UEFI/Bios I think.

Yeah @omano, I tried the 5.4 and it still has this behavior. I think that peak appeared when I open Screenshot to take the screenshot. What bothers me is that periodic fan activation when I’m not doing anything.

I’ll take a look at the UEFI firmware. I was also thinking about using thinkfan but I don’t want to break my system.

I think I found the source of the problem at least. I’ve installed lm_sensors and this is my output of sensors:

Adapter: PCI adapter
vddgfx:      687.00 mV 
edge:         +47.0°C  (crit = +94.0°C, hyst = -273.1°C)
power1:        4.07 W  (cap =  25.00 W)

Adapter: ISA adapter
Package id 0:  +48.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +48.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +49.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +48.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +48.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: Virtual device
temp1:        +46.5°C  

Adapter: PCI adapter
Composite:    +40.9°C  (low  = +109.8°C, high = +109.8°C)
                       (crit = +79.8°C)
Sensor 1:     +51.9°C  (low  = +109.8°C, high = +109.8°C)
Sensor 2:     +40.9°C  (low  = +109.8°C, high = +109.8°C)

Adapter: ISA adapter
in0:           0.00 V  (min =  +5.00 V, max =  +5.00 V)
curr1:         3.25 A  (max =  +3.00 A)

Adapter: Virtual device
temp1:        +47.0°C  

Adapter: ISA adapter
fan1:        14080 RPM
temp1:        +49.0°C  
temp2:         +0.0°C  
temp3:         +0.0°C  
temp4:         +0.0°C  
temp5:         +0.0°C  
temp6:         +0.0°C  
temp7:         +0.0°C  
temp8:         +0.0°C  

Adapter: ACPI interface
in0:          12.41 V  

Adapter: ACPI interface
temp1:        +49.0°C  (crit = +127.0°C)

I’m not quite sure how to read this, but I noticed that when temp1 in thinkpad-isa-0000 and temp1 in acpitz-acpi-0 come near 50 ºC the fan kicks in. I even think that they are from the same sensor. I can’t figure out what they are measuring. It may be an hardware problem, but I have a feeling that it isn’t.

“Once upon a time” – it was dust in the cooler and fan of my cpu. So think of cleaning it once in a year. :sunglasses: (with a vacuum cleaner)
(Very seldom the problem is a separation of CPU and cooler. Then you have to remount the cooler to the CPU)

Something weird I noticed is your fan RPM, in s-tui it was showing near 9000 RPM, here it says 14000 RPM to me this is too high to be true.

But as I said in my second comment

If your fan starts to ramp up at 50° that makes sense.

Opening, and cleaning the cooling module insides after disassembling it itself (and cleaning/reapplying thermal paste if you completely remove the thermal module, but you probably can get away with that, if you can remove the thermal module cover to be able to clean inside and remove dust from the heatsink itself) is not really something everybody is willing to do.

You could blow some pressured air into it but that wouldn’t really clean it.

I’ve tried again booting Manjaro 20.2 and the same problem arose after all. I conclude that the laptop is simply getting hotter like @omano said :sweat_smile:, so it’s not a software problem. Because this started happening after an update, I thought both things were related. The problem of coincidence. Some component should be getting progressively hotter even when idle and when it reached 50 ºC it started the fan.

I’ve seen that use a cooling pad does the trick. I’ll go with that for now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.