Pendrive not detected after a failed format

Hi everyone!

I’m trying to do a dual boot with Win 10 and a i’ve had a problem formating my pendrive.
I doesn’t mount, I cant find it with Gparted.
Using he command lsblk I’ve found it like “SDC” but it hasn´t a partición

[sergio@sergio-notebook ~]$ lsblk
sda 8:0 0 698,6G 0 disk
├─sda1 8:1 0 40G 0 part /
├─sda2 8:2 0 4G 0 part [SWAP]
└─sda3 8:3 0 654,6G 0 part /home
sdc 8:32 1 14,4G 0 disk
sr0 11:0 1 1024M 0 rom

I tried with “dd if=/dev/zero of=/dev/sdc bs=446 count=1” and “sudo fsck.vfat -f -p /dev/sdc” and it didn´t work.
I’ve tried with different solutions I found with any luck.

Could someone give me some help, please?


can you returns

sudo parted -l
sudo fdisk -l 

Thank for the help mate.

[sergio@sergio-notebook ~]$ sudo parted -l
[sudo] password for sergio:
Model: ATA ST9750420AS (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Numero Inicio Fin Tamaño Typo Sistema de ficheros Banderas
1 1049kB 43,0GB 42,9GB primary ext4
2 43,0GB 47,2GB 4295MB primary linux-swap(v1)
3 47,2GB 750GB 703GB primary ext4

Error: /dev/sdc: unrecognised disk label
Model: Verbatim STORE N GO (scsi)
Disk /dev/sdc: 15,5GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags:

[sergio@sergio-notebook ~]$ sudo fdisk -l
Disco /dev/sda: 698,64 GiB, 750156374016 bytes, 1465149168 sectores
Modelo de disco: ST9750420AS
Unidades: sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico/físico): 512 bytes / 4096 bytes
Tamaño de E/S (mínimo/óptimo): 4096 bytes / 4096 bytes
Tipo de etiqueta de disco: dos
Identificador del disco: 0x00067004

Disposit. Inicio Comienzo Final Sectores Tamaño Id Tipo
/dev/sda1 2048 83888127 83886080 40G 83 Linux
/dev/sda2 83888128 92276735 8388608 4G 82 Linux swap / Solaris
/dev/sda3 92276736 1465126911 1372850176 654,6G 83 Linux

retry for your pendrive with win 10 & ventoy
copy iso manjaro after


I could fix it with Ventoy.
Thanks Stephane.

It made a 32 MB fat32 partition, then I could use Gpated to make a 15G partition.

When I try to put a file into it’s shows a error.
I used Ventoy again, I made a new partition and when I try to copy a .iso it shows an error.

The problem whe I try to write into it.

may be change pendrive

Yes, it would be a good solution.
It’s is not too old and I want to save it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.