PDFStudio scaling problem

I’m using Qoppa pdfstudio on my KDE Manjaro desktop machine, and my Gnome Manjaro laptop.

It’s fine on the desktop. The laptop is the machine I’m having the problem on. The laptop has a 17inch screen and it’s 4K resolution. Scaling is at the default 200% and everything scales and looks fine except for pdfstudio.

All the icons and the various cursors displayed in the app are so tiny that it’s pretty much useless.

Pdfstudio is java based and I do not believe it’s gtk or qt so it’s different from every other application I have installed.

I have been emailing back and forth with Qoppa for a few days now. They are going to look into the problem but for now I do not have a fix.

They said this,

Only thing I would say is that PDF Studio is Java based. So it could be something with the JVM that’s not able to get the DPI correctly from Manjaro.

On manjaro gnome the application is reporting a multiplier of 0.8. This means the icons in the application are tiny and I cannot edit pdfs or do anything really.

I just ran ubuntu from a live usb and installed pdfstudio on that and it worked perfectly on ubuntu. On Ubuntu pdfstudio reports a multiplier of 1.9333333333333333 so pdfstudio doubles the size of the icons and displays fine.

Does anyone know of anything I can do to fix this until Qoppa come up with a proper fix?

  • Wait until the Ubuntu fix gets deployed by the Gnome Team downstream
  • Find the Ubuntu bug fix in their repositories and change the Gnome code yourself and build Gnome from source yourself today…


Hi. I think some java options including scaling can be set as environment variable if you start java application from command line. I can’t remember details but I am sure you will find some information about that on the Internet.

I just tried that but failed. I did find some posts online, but beyond my knowledge level I think.

I have just spent ages trying to start pdfstudio from the terminal. I cannot find the command :slight_smile:

Just type pdfstudio in the terminal and press Enter :slight_smile:
Options can be set this way:
_JAVA_OPTIONS="some options here" pdfstudio
As for java options I’ve tried some suggestions from
but unfortunately none of them worked.

EDIT. Options also can be set in this global config file:
or in user config file:

Thanks for getting back to me.

That was the first thing I tried. This is what I get.

bash: pdfstudio: command not found

How did you install it? I installed pdfstudio-bin from AUR. That package has the command:

$ LC_ALL=C pacman -Qo /usr/bin/pdfstudio
/usr/bin/pdfstudio is owned by pdfstudio-bin 2021.0.1-2

I have always installed it directly from the quoppa website. Download and install. I did not even know it was in the aur.

For now I have fixed the problem by switching to popos, as it did not look like I was going to find an easy solution to this.