pCloud-drive stopped working.

I am using a cloud server for my backup data. Today it suddenly stopped working. The service is pCloud and the desktop client is pCloud-drive, which is in the AUR repo. I have used it for several years, and it has always worked perfectly. But now something has happen. I get this error message when I try to open my pCloud drive in Nautilus:

Screenshot%20from%202019-06-19%2018-02-13

My system:

[tomas@tomas-pc ~]$ inxi -F
System:
  Host: tomas-pc Kernel: 5.2.0-1-MANJARO x86_64 bits: 64 
  Desktop: Gnome 3.32.2 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: Z390 I AORUS PRO WIFI v: N/A 
  serial: <root required> 
  Mobo: Gigabyte model: Z390 I AORUS PRO WIFI-CF serial: <root required> 
  UEFI: American Megatrends v: F5d date: 01/16/2019 
CPU:
  Topology: 8-Core model: Intel Core i7-9700K bits: 64 type: MCP 
  L2 cache: 12.0 MiB 
  Speed: 800 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
  Display: x11 server: X.org 1.20.5 driver: i915 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 19.0.6 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
  Device-2: Z-Star Micro type: USB driver: snd-usb-audio,uvcvideo 
  Sound Server: ALSA v: k5.2.0-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  IF: wlo1 state: down mac: be:30:ad:a1:1a:da 
  Device-2: Intel Ethernet I219-V driver: e1000e 
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: e0:d5:5e:e3:d1:d3 
Drives:
  Local Storage: total: 1.15 TiB used: 120.51 GiB (10.2%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 250GB 
  size: 232.89 GiB 
  ID-2: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB 
  ID-3: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 
  size: 14.41 GiB 
Partition:
  ID-1: / size: 48.83 GiB used: 10.50 GiB (21.5%) fs: btrfs 
  dev: /dev/nvme0n1p5 
  ID-2: /home size: 48.83 GiB used: 10.50 GiB (21.5%) fs: btrfs 
  dev: /dev/nvme0n1p5 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 377 Uptime: 9h 26m Memory: 31.28 GiB used: 2.09 GiB (6.7%) 
  Shell: bash inxi: 3.0.34 

pcloud-drive version: 1.5.1-1

What is this error: "Transport endpoint is not connected"?
Need help to fix this, thanks.

Possibly:

Otherwise, the remote service is not allowing you to connect.

Also keep in mind that pCloud is a commercial service and so has its own support routes you can use.

I am getting this from this link: " Oops! That page doesn’t exist or is private." cant read it.

I used the service just a few days ago, without any problem. Also, I can log in to my account through my web browser.

Me too Johnaton :man_facepalming: I clicked on tnilzon quoted link

You can just use directly the appimage from their website (install appimagelauncher from Manjaro official repo), since the AUR pkgbuild repack the appimage

Try the link again. You've quoted a seconds older but mistyped version.

I have just installed pCloud and am now getting a weird message in my terminal:

ls: cannot access 'pCloudDrive': Transport endpoint is not connected

It logged in OK, going to reboot then investigate...

Appimage is working fine here

Tried a complete uninstall and a new reinstall: Did not work (same error).
Tried an appimage install: Did not work (same error).

The error started to appear after some of the latest manjaro (testing) update. I have another system on my laptop, manjaro (stable), and on that machine pCloud works without any error.

Seem to be the same issue that I am experiencing.
pCloud support advised a re-install, but that did not make any difference.

Any clue how to fix this?

Uninstall, reinstall, or download from their site. It appears to be working now.

I have done exactly what you are instructing. But the issue remains. See attached screen dump from Nautilus file manager.

Screenshot%20from%202019-06-27%2014-35-40

I think I have found what is related to pCloud-client not working for me. It seems to be related to what kernel version that is running. I had the kernel version 5.2rc6.d0623.g4 (which is experimental), and with that kernel the pCloud-client did not worked with the file manager (in my case Nautilus). I have now tried downgrading the kernel to version 5.1.15-1, and with that kernel pCloud works as expected (and integrates flawlessly with Nautilus).

So the cure for this problem is to not use a kernel version higher than 5.1.15-1.