PC won't recognise USB ports

So - I’ve been using KDE manjaro for about a year now, on my old DELL Inspiron 15 5567.
since I’ve installed it, about 50% of times I boot up the PC - it just doesn’t recognise any USB
I usually reboot the machine few more times after that, try disconecting and reconnecting USB’s, until it boots up with USB ports that work, and then it works fine for the entirety of that run.

The main way I diagnose this is that my wireless keyboard and mouse doesn’t work, and flash drive’s light doesn’t even light up (not to mention being recognised).

as far as what I know how to test - this is the result of lsusb, no matter what is plugged in:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Also - I believe it’s a fake alarm due to https://www.dell.com/community/Linux-General/DELL-Inspiron-5567-MCE-Errors-On-Boot-Linux-Kernel/td-p/5163980,
but I’m also getting this message right before the login screen every boot on a terminal-like black screen -

[ 0.114697] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee00000000
[ 0.114700] mce: [Hardware Error]: TSC 0 ADDR fef1cbc0 MISC 43880014086
[ 0.114704] mce: [Hardware Error]: PROCESSOR 0: 806e9 TIME 1606870285 SOCKET 0
APIC 0 microcode de
[ 0.114708] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 7: ee00000000
[ 0.114710] mce: [Hardware Error]: TSC 0 ADDR fef1ce40 MISC 7880014086
[ 0.114713] mce: [Hardware Error]: PROCESSOR 0: 806e9 TIME 1606870285 SOCKET 0
APIC 0 microcode de

(why couldn’t I place the pic here? had to type it…)
I usually get it for about a second, and then the pointer appears on it, and a second later the login screen.
On boots that the PC doesn’t recognize USB’s it stays on this screen much longer, and the error message is the same.

sorry for the long post, and also if it’s a known problem, I haven’t managed to find any solutions yet.

HDMI does work though.

This indicates a hardware error. :man_shrugging:

This much I understand, but is it relevant though? because it appears also when the usb ports work.
All I remember finding out about this Hardware Error message is that there is a bug with manjaro and that specific laptop model, and that there’s nothing to do about it, i’ll try to find that post…

It doesn’t have anything to do with Manjaro. :arrow_down:

oh, thanks for the info!
do you think this causes the problem?
because it seems to refer to a CPU error, not an I/O one…

EDIT: Just found the post at dell forums, about a fake mce error for this model -

The MCEs you’ve pasted pertain to different parts of the hardware, including but not limited to the CPU.

please check out the edit to my last comment

The thread at that link suggests that it may be a problem with the firmware on that machine. So I would first of all check whether there’s a firmware update available from Dell.

I’ve managed to update the BIOS, to a version from last month.
this didn’t fix the hardware error, although this post’s solution manages to hide it nicely for my taste,
I can’t tell of the bios update did something to help with the USB Ports problems (It worked fine the last few times I restarted, but it really comes and goes…)
There are other updates at dell’s website, regarding network, security and peripherals, but I’m not sure how to install them, if I even can, since those are just exe files. (are those just software drivers incompatible with linux?)

They are indeed drivers and possibly utilities ─ my French isn’t that good ─ and they are specifically for Windows 10. So, yes, they are useless.

So I guess I’ll update here if the problem was solved in the following days, although I doubt that the bios update could have helped since I’m pretty sure I also did one about a year ago.
(BTW - french? I see their site in english, you can select the language in the bottom right)

It appeared in French for me. :man_shrugging:

Update: problem persists :confused:

A post was split to a new topic: USB ports not working

A post was merged into an existing topic: USB Mouse stops working when laptop unplugged from AC power