PC not booting with latest kernel 5.9

I had just installed the linux 5.9 kernel and my pc is not booting since.When I changed my kernel back to 5.8 it is working fine can anybody pls tell me what is the problem.


Please boot into the kernel 5.8, then open a terminal and execute sudo mkinitcpio -P followed by sudo update-grub then reboot!

If it is not working, it might not be compatible, or missing a component.

Have a wonderful day, and welcome to this fabulous community! :smile:

1 Like

Thanks it is working now i actually just needed to wait for the stable version to come out. The time I had installed the kernel it was experimental

1 Like

The same thing happens to me, and I’m using the stable version. Have to revert back to 5.8.16 to get my system to boot again.

can you provide

inxi -Fza --no-host 

System: Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.8-x86_64 root=UUID=bbaf9adf-08db-4471-b3f1-21de28fd3c95 rw
rootflags=subvol=@ quiet apparmor=1 security=apparmor udev.log_priority=3
Desktop: Cinnamon 4.6.7 tk: GTK 3.24.23 wm: Muffin dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine: Type: Desktop Mobo: ASUSTeK model: Z170I PRO GAMING v: Rev X.0x serial: UEFI: American Megatrends v: 3805
date: 05/16/2018
CPU: Topology: Quad Core model: Intel Core i5-6500 socket: LGA1151 bits: 64 type: MCP arch: Skylake-S family: 6
model-id: 5E (94) stepping: 3 microcode: D6 L1 cache: 256 KiB L2 cache: 6144 KiB L3 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25610
Speed: 2517 MHz min/max: 800/3600 MHz base/boost: 3200/8300 volts: 1.0 V ext-clock: 100 MHz Core speeds (MHz):
1: 2257 2: 2300 3: 2170 4: 2271
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled
Graphics: Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ZOTAC driver: nvidia v: 440.100 alternate: nouveau,nvidia_drm
bus ID: 01:00.0 chip ID: 10de:1c03
Display: server: 1.20.9 driver: nvidia display ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.7x16.7") s-diag: 798mm (31.4")
Monitor-1: DP-0 res: 2560x1600 hz: 60 dpi: 101 size: 641x401mm (25.2x15.8") diag: 756mm (29.8")
OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 direct render: Yes
Audio: Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 00:1f.3 chip ID: 8086:a170
Device-2: NVIDIA GP106 High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 10de:10f1
Sound Server: ALSA v: k5.8.16-2-MANJARO
Network: Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6
chip ID: 8086:15b8
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 7.74 TiB used: 1.07 TiB (13.8%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW512HMJP-00000 size: 476.94 GiB block size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: rev: CXY7301Q scheme: GPT
ID-2: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB block size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s serial: rev: 2B6Q scheme: MBR
ID-3: /dev/sdb vendor: Seagate model: ST4000DX001-1CE168 size: 3.64 TiB block size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s rotation: 5900 rpm serial: rev: CC44 scheme: GPT
ID-4: /dev/sdc vendor: Seagate model: ST3750640AS size: 698.64 GiB block size: physical: 512 B logical: 512 B
speed: 3.0 Gb/s serial: rev: K scheme: MBR
ID-5: /dev/sdd type: USB vendor: Seagate model: ST33000651AS size: 2.00 TiB block size: physical: 512 B
logical: 512 B rotation: 7200 rpm serial: rev: 0000 scheme: MBR
ID-6: /dev/sde type: USB model: 51AS size: 746.52 GiB block size: physical: 512 B logical: 512 B rotation: 7200 rpm
serial: N/A rev: 0000 scheme: MBR
Partition: ID-1: / raw size: 476.44 GiB size: 476.44 GiB (100.00%) used: 48.18 GiB (10.1%) fs: btrfs block size: 4096 B
dev: /dev/nvme0n1p2
ID-2: /home raw size: 476.44 GiB size: 476.44 GiB (100.00%) used: 48.18 GiB (10.1%) fs: btrfs block size: 4096 B
dev: /dev/nvme0n1p2
Swap: Alert: No Swap data was found.
Sensors: System Temperatures: cpu: 29.0 C mobo: N/A gpu: nvidia temp: 30 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Info: Processes: 296 Uptime: 22h 09m Memory: 15.58 GiB used: 4.21 GiB (27.0%) Init: systemd v: 246 Compilers: gcc: 10.2.0
Packages: 1379 pacman: 1365 lib: 365 flatpak: 11 snap: 3 Shell: Bash (sudo) v: 5.0.18 running in: guake
inxi: 3.1.05

have you checked log in boot before ?

sudo journactl -b -1 -p4 ( b -2 boot before , etc ... )

Nope! Thanks, I will investigate further. This is the first time a new kernel won’t boot.

I also have this same problem with the 5.9.1 kernel. This is specific to Manjaro as the same version boots OpenSUSE Tumbleweed normally.

I read somewhere that Nvidia drivers won’t work with kernel 5.9. You’ll get a black screen at boot.Nvidia will come with new drivers mid-November. I guess that’s the issue for me at least. Just have to wait until Manjaro implement the new Nvidia drivers.