PC locks up after extended rest

This is kind of a weird issue that has been plaguing my desktop for a while, but seems to happen more frequently lately.

What happens is that after extended rest (almost always overnight), when I return no response is accepted by either mouse or keyboard. As if the PC has locked up. Only a hard reset seems to fix the issue.

Mouse and keyboard usb receivers are plugged in to a usb hub. Tried removing usb receivers and plugging them in directly to usb in back of PC but still no response.

I don’t think it is an issue with mouse or keyboards because I’ve switched them out and it still happens. Also, don’t think usb controller is going out because why would a hard reset fix it? And I would expect the input lock-up to happen randomly while I’m using it during the day. Not ruling it out completely, but seems unlikely.

This has happened across several kernels. So, I don’t think it is specific to kernel.

And the only applications I have running are a couple browsers most of the time.

Anyone experienced anything similar? Or suggestions on where to look?

I had something similar.
I used to lock the session every night and let the computer torrenting, and unlock it the next morning. A few times, it seemed to not react to any input, and i could only hard reboot. Until the day i upgraded my hardware, and my monitor decided not to switch on, forcing me to buy a new one on the spot.

Also, i just spotted that Xfce has an issue that any monitor that disconnects is removed, and cannot display anything until “reconfigured” or rebooting.

1 Like

i had exactly the same issue , it wasn’t distro related , it wasn’t even a linux problem , it happened on windows too
the problem was a bad network card , replaced it , and everything worked fine
your problem is mostly hardware-related , but anyway , you should try these steps
1- try live distro and see if the problem persist
2- hard-reset bios and check if it needs an update
3- try disabling hardware one at a time from bios (peripherals and PCIs)
journalctl might give you information on what happened (in my case it didn’t , but try it anyway)

Did the machine react to a simple power button press and shut down orderly by itself or did you press that button for a longer time to force the machine to power off? The latter variant could easily leave you with a broken system (it’s an unclean shutdown…) - the former indicates a still working machine (at least parts of it) and only problems with either input devices or output (not refreshing).

I have to flip the power switch in the back off and on. A normal press doesn’t do anything.

Excuse my ignorance if I get this wrong, but the monitors still have the power button on (white light). Which I’ve typically associated with the monitors still being “connected” to the PC. Whereas, when the monitor is on but the PC is turned off or otherwise there is no connection, the monitors power button turns red/orange.

Typically, at night, I’ll call xfce4-screensaver-command-a to “sleep” the display. And the power button will still remain white. Also, I’ve experimented with turning off xfce4-screensaver and just have the display remain fully on. After about a week, though, it “locked” up again when I tried to access one morning. The display was still fully on showing the desktop.

Unless there is some weird instability with one of my monitors where it connects/disconnects rapidly. But I never seen any flickering or other signs like that.

I might try to experiment using just one monitor for a while and then switch to using the just the other monitor for a while. Kind of sucks because this is my home/work machine.

Sometimes I can go a couple weeks without issue. Sometimes it happens several days in a row.

Looked at journalctl for this morning and nothing out of the ordinary. It was also logging up to a few minutes prior to the reboot. So, I have some evidence that the machine isn’t completely “dead” by the time I try to access it.

Hmm, the only peripherals that I have are mouse and keyboard and usb hub currently. Hmm, I’ll check out the usb hub.

Of course, it could always be the Nvidia card I have…