PC locks during v17.0.5 KDE install

kde

#1

Hello everyone,

Across multiple attempts to install Manjaro v17.0.5 KDE edition the PC locks up. I’ve tried:

  • multiple ISO downloads that all verified via SHA1
  • multiple blank DVDs burned with multiple burners (different PCs used as well)
  • multiple USB keys

The install environment behaves erratically during the partitioning. I have multiple drives but I’m attempting to partition and install to drive (/dev/sdd). This is a regular hard drive not a solid state drive. I already have a Manjaro v16.06 KDE install that is functional on the /dev/sdd drive but has not be updated or used since 5-13-2016. I want to wipe out the partition table on the (sdd), create different sized partitions, lay down formats, let the installer do its thing, and drop grub on drive (sdd). I have Win7 64-bit (bootable) on another drive and a few NTFS partition spreads around other drives. I should end up with clean separation between windows and Manjaro. Manjaro will be accessible via BIOS boot drive selection menu which will kick off GRUB.

The Erratic behavior:

When I get to the point where I select the /dev/sdd drive, or just after selecting the drive:

  • the bottom panel flickers rapidly
  • the installer window flickers rapidly
  • moving the mouse causes more flickering
  • a notification starts to be drawn on screen
  • the PC locks up but I can still move the mouse around on the screen
  • clicking on UI elements on the screen has no response
  • the PC is unresponsive to keyboard input

If the PC doesn’t lock up immediate after selecting the sdd drive, clicking the “Create New Partition Table” button definitely triggers the lock up. In this case the next dialog is partially drawn just before the lock up.

It seems the install environment has some fancy desktop effects enabled as well… like fade in/out.

I’m using a core i5-4670K (not overclocked), 16GB RAM, with UEFI BIOS. The /dev/sdd drive is a WD320GB hard drive. Is there any commands I should run to gather more detailed info.?


Installation issues on Macbook Air 7,1
Update/Upgrade old 16.06 KDE 64-bit or Install fresh 17.05 KDE?
#2

Be right back… going to try to run…

  • inxi -Fx
  • lsblk

Before clicking the installer icon to see if I can grab some info.


#3

[manjaro@manjaro ~]$ inxi -Fx

Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
System:    Host: manjaro Kernel: 4.9.50-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
           Desktop: KDE Plasma 5.10.5 (Qt 5.9.1) Distro: Manjaro Linux
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: MAXIMUS VI FORMULA v: Rev 1.xx serial: N/A
           UEFI: American Megatrends v: 1302 date: 12/23/2013
CPU:       Quad core Intel Core i5-4670K (-MCP-) arch: Haswell rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27208
           clock speeds: max: 3800 MHz 1: 1227 MHz 2: 1800 MHz 3: 1816 MHz 4: 1147 MHz
Graphics:  Card: NVIDIA GK106 [GeForce GTX 660] bus-ID: 01:00.0
           Display Server: N/A drivers: nouveau (unloaded: modesetting) tty size: 138x35
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK106 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-3 Logitech Headset H340 driver: USB Audio usb-ID: 003-007
           Sound: Advanced Linux Sound Architecture v: k4.9.50-1-MANJARO
Network:   Card-1: Intel Ethernet Connection I217-V driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: e0:3f:49:81:95:c8
           Card-2: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter
           driver: bcma-pci-bridge bus-ID: 03:00.0
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 5325.1GB (0.3% used)
           ID-1: /dev/sdb model: ST2000DM001 size: 2000.4GB
           ID-2: /dev/sdd model: WDC_WD3200AAKS size: 320.1GB                 
           ID-3: /dev/sdc model: ST31000528AS size: 1000.2GB                      
           ID-4: /dev/sda model: ST2000DM001 size: 2000.4GB                            
           ID-5: USB /dev/sde model: USB_Flash_Drive size: 4.0GB                            
Partition: ID-1: / size: 12G used: 112M (1%) fs: overlay dev: N/A                                
           ID-2: swap-1 size: 16.78GB used: 0.00GB (0%) fs: swap dev: /dev/sdd5                      
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 40.0                                           
           Fan Speeds (in rpm): cpu: 0                                                                          
Info:      Processes: 203 Uptime: 1 min Memory: 648.7/15989.0MB Init: systemd Gcc sys: 7.2.0                         
           Client: Shell (bash 4.4.121) inxi: 2.3.38

^^^ and ^^^

[manjaro@manjaro ~]$ lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0    7:0    0   6.4M  1 loop /run/miso/sfs/livefs
loop1    7:1    0   239M  1 loop /run/miso/sfs/mhwdfs
loop2    7:2    0   1.2G  1 loop /run/miso/sfs/desktopfs
loop3    7:3    0 399.4M  1 loop /run/miso/sfs/rootfs
sda      8:0    0   1.8T  0 disk 
├─sda1   8:1    0   293G  0 part 
├─sda2   8:2    0   293G  0 part 
├─sda3   8:3    0 244.1G  0 part 
├─sda4   8:4    0     1K  0 part 
└─sda5   8:5    0     1T  0 part 
sdb      8:16   0   1.8T  0 disk 
├─sdb1   8:17   0 244.1G  0 part /run/media/manjaro/2TB_Data_Drive
├─sdb2   8:18   0   293G  0 part 
├─sdb3   8:19   0   293G  0 part 
├─sdb4   8:20   0     1K  0 part 
├─sdb5   8:21   0 195.3G  0 part 
├─sdb6   8:22   0 634.8G  0 part 
└─sdb7   8:23   0 202.9G  0 part 
sdc      8:32   0 931.5G  0 disk 
└─sdc1   8:33   0 931.5G  0 part 
sdd      8:48   0 298.1G  0 disk 
├─sdd1   8:49   0  29.3G  0 part 
├─sdd2   8:50   0     1K  0 part 
├─sdd5   8:53   0  15.6G  0 part [SWAP]
└─sdd6   8:54   0  58.6G  0 part 
sde      8:64   1   3.7G  0 disk 
├─sde1   8:65   1   1.9G  0 part /run/miso/bootmnt
└─sde2   8:66   1     4M  0 part 
sr0     11:0    1  1024M  0 rom  
sr1     11:1    1  1024M  0 rom

^^^ the above was posted from within the install environment ^^^


#4

Boot using the nonfree drivers from the installer media. No more flickers after …
Once in the installer and to the partition tab, select the HDD you want the install to go too … New Partition table and select GPT. In the partition tab add new partition 300MB /boot/efi with the partition flag esp and from there should be as you want it …


#5

Wow, that switch to non-free has a big positive impact. Forward movement.


#6

And it failed to complete the install…


#7

Ok, because you will select that drive from Bios to boot from, leave the /boot/efi partition out.
Also the swap partition prefers to be at the end of the drive from what i know, but i might be wrong.


#8

Does the installer assume that GRUB will be installed into the /boot/efi marked partition?
or…
How/where do I specify where I want GRUB to be installed?
Shouldn’t I have a boot flag set on one of the partitions on the /dev/sdd drive to direct the BIOS to the correct place on that drive?


#9

I just saw the error … the /boot/efi must be fat32. You made it ext4 … the mount point must be /boot/efi and the boot flag esp as you did


#10

Ok so as long as the /dev/sdd drive has a LBA entry marked with “boot” “esp” and “/boot/efi” then the installer will install GRUB to that partition and my UEFI BIOS will know to load what ever OS loader that is located in the partition with the above quoted attributes?

EDIT: I just noticed that the installer has 17.0.2 within some of the strings instead of 17.0.5.
Partition changes…


#11

the boot must be /boot/efi … not only /boot … but i wonder if will work the way you made it. If not, be sure to follow this:
image


#12

The installer completed this time around with the changes I lasted posted… time to reboot.


#13

OK well I’m inside Manjaro now. However, the installer dumped grub on the /dev/sda partition so now I can’t access Win7 for work stuff. How do I get my Win7 boot-up back to the way it was and get GRUB on the /dev/sdd 300MB partition?


#14

My process when i do this kind of installations is to disable other drives (or from BIOS, or simply take the SATA connector cables out, so my installations don’t touch anything else).
You should boot the Windows install and fix the boot for your windows installation. There is an automatic fix and another one more advanced (i can’t recall right now, not using windows at all)
After that you can boot again from Manjaro install, try to boot from the HDD where Manjaro is installed and then update grub. Follow this instructions from the wiki, the part For UEFI Systems
That is why i mentioned the /boo/efi not just /boot … for the mount point. Grub installed on the first HDD i guess, so it messed up …
https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader

Also you can do another install for Manjaro :slight_smile:


#15

I had…
File System: = fat32
Mount Point: = /boot/efi
Flags: boot and esp were ticked

Is there no way to tell the installer where to install GRUB? I don’t believe that I was presented with any options for this.


#16

You just did that, but for some reasons didn’t went well, that is why (no matter what installers i use) i always remove the HDD that i don’t want touched during the install. Was the safest way for years …
And you only need the esp boot flag …


#17

I used the methods via google search to restore the windows 7 MBR. However, none of it worked. It had no effect. When I went looking around my UEFI BIOS I found that it was changed. The default boot option was pointing to
P1: Manjaro

The second option is pointing to my DVD burner.

P1 is my /dev/sda drive, but there are now 2 entries available:

  • P1 STA20000 (Seagate drive)
  • P1: Manjaro

I thought the change was to the MBR of /dev/sda but now I’m not sure if that was changed and my BIOS or if my BIOS is reading some reference to GRUB on the P1 drive.

There should not be any references in BIOS or on the /dev/sda drive to Manjaro/GRUB. I’m confused now, but I need to have absolutely zero connections/dependencies/references to GRUB/Manjaro in Windows 7, the drive that Widnows 7 is installed on, or BIOS since Win7 is for work stuff.

How does the installer know where to put GRUB? I do not remember seeing any options to tell it where or how to install GRUB.

Disconnecting certain drives from the motherboard certainly is an option to control the installer’s options or what it can see. I did not have to take such drastic measures with prior versions of Manjaro or any other Linux distro. I’ll keep that option in mind for future installs but as of right now I’m stuck.


#18

Slightly strange…

I re-ran the commands to restore the Win7 MBR but still no change. Next, I shutdown and disconnected the Western Digital (/dev/sdd) drive from the motherboard. I booted up again and there were no references in BIOS to Manjaro/GRUB. I exited BIOS and the PC booted straight to Windows 7. I shutdown, restarted and rechecked BIOS and still no references to Manjaro/GRUB.

Next, I shutdown and reconnected the Western Digital drive to the motherboard. I booted up, checked BIOS and there are no references to Manjaro/GRUB. I attempted to use the boot menu from BIOS to boot from the Western Digital drive and it failed as though there was no bootloader on the drive. BIOS chose to fall back to the Seagate drive that has Windows.

Next, I booted from my USB key but chose the non-UEFI option. After going through the usual steps I arrived at the following:

Notice that the summary shows where the boot loader is to be installed. Also while creating partitions in the current attempt, a drop-down list of GRUB install locations are presented to the user. While creating the partitions there was no /boot/efi option to select as well.


#19

The install completes successfully, but PC fails to load GRUB when selecting the Western Digital drive from the BIOS boot menu. Even if I change the BIOS to use the Western Digital as the default boot device it still fails to boot.


#20

Once you boot in legacy mode, that is what happens. But, once you install in Legacy mode, you will have to always change the boot option from uEFI to Legacy … WIndows will boot only in uEFI if was installed like that, and Manjaro will boot in Legacy if was installed like that … etc …
uEFI boot menu might work from your BIOS without installing Manjaro in Legacy, but uEFi as it was and add a new entry in uEFI options for the Manjaro.