PC does not boot from Linux USB disk, but from a Windows disk

manjaro32

#1

Good evening,

I was trying to install Linux Manjaro 32 bit on an older machine today, but whatever I tried it did not work. I have ruled out that it could be due to the BIOS settings. Furthermore, I have excluded any hardware complications and fooled with Mint to confirm that it is a Linux related issue. The attempt proved me right. Now I am at a loss and hope that one of you can help me.


#2

What hardware do you have?

What did you try?

How?

How?

What method are you using to create the boot medium?


#3

First of all thank you for accepting my problem.

The model is an AMILO Xi 1526 from a friend who wants to give the laptop a meaning. The device has an Intel Core 2 Duo (T5600) and a dedicated Nvidia graphics card that I can not read from the bios.

The BIOS is very simple. I have enabled and disabled the Execute Disable Bit function and tried it both times without success. All energy saving features are disabled. The boot order is limited to USB devices and I have already tried it via the boot menu. Other settings do not exist.

I tested the hardware occasionally with the UBCD and under Windows as at work. Furthermore, I checked the USB ports on the technical level and found no errors.

I copied the ISO of Manjaro under Windows 10 with the Win32DiskImager on the USB data carrier.


#4

Try Rufus (in “dd” mode) or Etcher instead.


#5

I find to be more reliable when creating bootable USB for Manjaro.


#6

Did you accidentally a word?


#7

Yes actually:
I find etcher to be more reliable when creating bootable USB for Manjaro


#8

I tried etcher it did not work either.


#9

What ISO did you download and does the checksum match?


#10

then have you tried rufus as suggested by @jonathon using the dd mode?


#11

I used the Manjaro-xfce-18.0.2-x32-stable-minimal-i686.iso. What do you mean by “checksum” I do not know this word #German I also tried rufus.


#12

Checksums are a way to check if the file is intact.
Download the checksum file from the same place as you did the ISO.
Open it in a text editor.
Now also open a terminal and run this command:
sha256sum /path/to/manjaro.iso

The string needs to be the same as the string in the file. Else your download got corrupted.


#13

The result fits. What should I try now? (The iso file worked last time)


#14

Does this laptop have Secure Boot? Have you disabled it?


#15

The laptop does not have Secure Boot. It is from 2007


#16

On a sidenote, your CPU supports 64-bit, so I think you would be better advised to use a 64-bit ISO.


#17

I already tried many ISOs


#18

If neither etcher nor rufus work for you, then you might give pure dd a try:

Can’t you press a specific key when your system boots up in order to make the boot menu show up? Sometimes it’s F12, F1 or F2.


#19

Did you read this Thread?


#20

Yes I did, you certainly mean this?
Did you read the dd tutorial?