PC boots into Windows despite setting up dual boot

I have installed manjaro deepin as a dual boot with windows 10. However, when i boot up my PC it goes straight to Windows 10 instead of showing a grub menu.
How can I fix this? Thank you.

Study and follow this tutorial to repair boot

If you still cannot repair, describe what you have already tried and provide info as advised in the tutorial.

1 Like

Followed the tutorial, problem persists, here is the terminal outputs:

[sami@sami-pc ~]$ efibootmgr -v
Timeout: 0 seconds
BootOrder: 0008,0000,0002,0007,9998,0003
Boot0000* Windows Boot Manager	HD(2,GPT,6dad6d55-b93e-4fa2-b60f-cd1e17b13891,0x145800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...-................
Boot0002* Internal Hard Disk	PciRoot(0x0)/Pci(0x11,0x0)/Sata(0,65535,0)/HD(2,GPT,6dad6d55-b93e-4fa2-b60f-cd1e17b13891,0x145800,0x82000)..BO
Boot0003* Internal CD/DVD ROM Drive(UEFI)	PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)....BO
Boot0007* Internal Hard Disk	PciRoot(0x0)/Pci(0x11,0x0)/Sata(0,65535,0)/HD(9,GPT,bf42ce11-4c95-401a-8a42-175608784225,0x337f2000,0x7d000)..BO
Boot0008* USB Drive (UEFI) - PNY USB 2.0 FD 1100	PciRoot(0x0)/Pci(0x12,0x0)/USB(1,0)/USB(1,0)/HD(2,MBR,0xbcdb9a74,0x44dc80,0x2000)..BO
Boot9998* Internal CD/DVD ROM Drive(UEFI)	PciRoot(0x0)/Pci(0x1d,0x0)/USB(16,0)....BO
[sami@sami-pc ~]$ sudo parted -l
[sudo] password for sami: 
Model: ATA HGST HTS541075A9 (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  683MB   682MB   ntfs            Basic data partition          hidden, diag
 2      683MB   955MB   273MB   fat32           EFI system partition          boot, esp
 3      955MB   1089MB  134MB                   Microsoft reserved partition  msftres
 4      1089MB  376GB   375GB   ntfs            Basic data partition          msftdata
 7      376GB   436GB   60.0GB  ext4
 8      436GB   442GB   6000MB  linux-swap(v1)
 9      442GB   443GB   262MB   fat32                                         msftdata
 5      722GB   724GB   1834MB  ntfs                                          hidden, diag
 6      724GB   750GB   26.5GB  ntfs            Basic data partition          hidden, msftdata


Model: PNY USB 2.0 FD (scsi)
Disk /dev/sdb: 32.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  2311MB  2311MB  primary               boot
 2      2311MB  2315MB  4194kB  primary               esp


[sami@sami-pc ~]$ sudo blkid
/dev/sda1: LABEL="WINRE" UUID="A6F22BAEF22B8223" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="a6525a80-e502-4c73-91fd-e143bad35248"
/dev/sda2: UUID="AEA7-E444" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="6dad6d55-b93e-4fa2-b60f-cd1e17b13891"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="827b3b82-f9fb-4aa5-9325-ef99c677934f"
/dev/sda4: LABEL="Windows" UUID="9AAEDC99AEDC6EEF" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="89988b85-0f51-4072-b87c-9faf6314be74"
/dev/sda5: UUID="A8C84FE3C84FADFE" TYPE="ntfs" PARTUUID="73b80110-c26c-44be-9ddf-c025f2bbd3e3"
/dev/sda6: LABEL="RECOVERY" UUID="10D830AFD83094C6" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="7aa932ae-3b6f-413b-a18d-9aa323648630"
/dev/sda7: UUID="fdf862e8-c0af-4c93-8af3-c906b6f63e49" TYPE="ext4" PARTUUID="99235bad-73ff-4aa2-a84d-5bd0c253e1a4"
/dev/sda8: UUID="b7dfa05d-2b41-4ea4-9604-c2ab0d06ef4e" TYPE="swap" PARTUUID="cd28ce71-1e8e-4e7c-88dc-91d9cd3a492b"
/dev/sda9: UUID="5EA7-1C1F" TYPE="vfat" PARTUUID="bf42ce11-4c95-401a-8a42-175608784225"
/dev/sdb1: UUID="2018-07-12-18-49-30-00" LABEL="MJRO1711" TYPE="iso9660" PARTUUID="bcdb9a74-01"
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="D712-E41E" TYPE="vfat" PARTUUID="bcdb9a74-02"
[sami@sami-pc ~]$ findmnt -s
TARGET    SOURCE                                    FSTYPE OPTIONS
/         UUID=fdf862e8-c0af-4c93-8af3-c906b6f63e49 ext4   defaults,noatime
swap      UUID=b7dfa05d-2b41-4ea4-9604-c2ab0d06ef4e swap   defaults,noatime
/boot/efi UUID=5EA7-1C1F                            vfat   defaults,noatime
[sami@sami-pc ~]$ findmnt /boot/efi
TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sda9 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,short
[sami@sami-pc ~]$ 

My PC is an hp pavilion 17 with a number of: 0974120000405F00000620180

Please help ;-;

Did you install Manjaro on same drive as Windows or on the second drive? With an UEFI install you will need to create a FAT32 partition and mount it as EFI.

My advice is to use the other drive for Linux and install grub on that one. When you want to boot in Linux use your motherboard’s boot menu to select with drive to from.

1 Like

You did not do the UEFI commands in the link.
Never mind, I’ll write it down again for you. here.

Boot into installed Manjaro.
At terminal, do the following.
And provide the output together with your input command.
First check at terminal that manjaro is in sda with command

findmnt /

That should give output of
TARGET SOURCE FSTYPE OPTIONS
/ /dev/sda7 ext2 rw,noatime,xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Note it says “/dev/sda7”
If it says “/dev/sdb7”, change all “sda” below to “sdb”

Proceed…

sudo parted /dev/sda set 9 boot on
sudo grub-install
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 9 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

2 Likes

I only have one drive, and I used the free space to create partitions for Manjaro on.
In one attempt I created a FAT32 partition and mounted it as EFI, no success.
In another attempt I used the already-existing FAT32 partition on my hard drive and made that EFI, again, no success.

Decide which esp to use and follow @gohlip 's advice to set the boot entry. Adjust the proposed commands appropriately depending your chosen esp partition.

not just a statement of “I followed the tutorial”. This can be interpreted in many different ways.

1 Like

The output when typing findmnt / is:

[sam@sam-pc ~]$ findmnt /
TARGET SOURCE    FSTYPE OPTIONS
/      /dev/sda7 ext4   rw,noatime,data=ordered



When I typed

sudo parted /dev/sda set 9 boot on

terminal said I may need to update /etc/fstab.
Should I continue with your directions or update that? If so, how would I update it?

which is probably not needed in your case. You could inspect it if the system partitions UUID match to what they should. If you don’t know what to look, you probably need some more reading, so you can master your system. Or post your fstab to get an advice.
I think you can proceed with the rest of the advice for now… :face_with_head_bandage:

1 Like

Ok, so I did everything in your directions, here are the outputs for those last 4 inputs:

[sudo] password for sam: 
Installing for x86_64-efi platform.
Installation finished. No error reported.
[sam@sam-pc ~]$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found Windows Boot Manager on /dev/sda2@/efi/Microsoft/Boot/bootmgfw.efi
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
[sam@sam-pc ~]$ sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
[sam@sam-pc ~]$ sudo efibootmgr -c -d /dev/sda -p 9 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
Timeout: 0 seconds
BootOrder: 0001,0000,0002,0004,9998,9999,0003
Boot0000* Windows Boot Manager
Boot0002* Internal Hard Disk
Boot0003* Internal CD/DVD ROM Drive(UEFI)
Boot0004* Internal Hard Disk
Boot9998* Internal CD/DVD ROM Drive(UEFI)
Boot9999* USB Drive (UEFI)
Boot0001* manjaro
[sam@sam-pc ~]$ 

Is there anything else I have to do in order to have the option to boot into manjaro without going straight to windows10?

I’ll try rebooting now to see if it works, I will update in a bit.

Still boots straight into Windows 10.
I’m not sure what I should tell you guys to help with troubleshooting, so I’m completely lost at this point, I’m sorry :frowning:

I think I’m just going to leave this problem be and just deal with the hassle of using f9 and manually navigate to manjaro os. Thanks for all your help, guys.

So now ‘manjaro’ is in the efibootentry and is first in bootorder.
Also you can boot manjaro by using F9.
That’s a big improvement.

Your computer is HP Pavillion and HP’s uefi firmware implementation is a bit flaky.
If you can update the bios firmware, it will be good.
Otherwise, see if the following 2 links below can help you get ‘manjaro’ entry into the bios so you don’t have to use F9 each time you want to boot Manjaro.

Good luck.

1 Like

Last reply, sorry, BUT I DID IT. I FREAKING DID IT! Here’s the solution!

  1. Boot into windows
  2. Open cmd as administrator
  3. Enter bcdedit /set "{bootmgr}" path \EFI\manjaro\shimx64.efi
  4. (Optional). Enter bcdedit /set "{bootmgr}" description "Manjaro"
    That simply makes it easier to identify.
    Done!
    My savior post which originally had this solution.
3 Likes

I’m not Likely to get a HP Laptop but if I do this will be helpful.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.