Password logs in, but fails to work elsewhere

I can log in via the GUI with my password, but I couldn’t run an update in octopi. It’s been quite a while since I logged into the linux partition of my dual boot rig, but windows broke on me just now, so I’m trying to save the data from the linux side, but I don’t have almost any perms. I know my password is correct as I logged in with it. I also typed it into the kate text editor, and it appears correctly there. Caps lock and num lock are both set correctly. It first failed in octopi(as I haven’t logged in for some time, the first thing I tried was syncing the data base) and that failed. I then opened a terminal and tried to update with both su, and sudo, but those also wouldn’t take my password. I believe the root and user password should be the same as the login password. Does anyone know how to fix this?

When you still have a live ISO, boot it and backup your data from there.

Well, ideally I would also like to get my linux install working too. It’s annoying enough that I’m going to have to backup, format, and re-install my windows partition.