Password in qwerty at startup


I checked the checkbox « create an encrypted partition » when I installed Manjaro. So my SSD is encrypted and it ask for password when I boot. But the keyboard is in qwerty and it switch to my layout when only once the system is launched.
How can I set the keyboard layout from boot ?


Start reading from here:

I remember reading a topic long time ago - a member using dvorak layout - and if I recall correct there is no way of setting a keyboard layout that early.

I put my search-fu at work and there is ways to achieve what you ask for but it is complicated and requires special initrd to accomplish the goal.

1 Like

Unfortunately, this file seems to already be well configured.

Arch wiki has some info on custom keymap in manual configuration of grub's core image:


Ok, it is theoretically possible, but really low-level configuration.
Thank for your answers.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.