Paru asks to update an already up-to-date package

Dear forum,

every time I want to update the AUR packages via paru, I am asked to update a package which is already up to date. Using yay, this does not happen. Do you have any ideas how this can be fixed?
Thanks in advance for answers.

Kind regards,

As it is a custom build script from AUR - you should raise the issue with the maintainer of the AUR (en) - paru build script.

Please do note if the package has been flagged out-of-date as this will indicate a new version has been made available - could be fixing your issue - but no guarantee.

But … as this is Manjaro - and many AUR maintainers are less positive supporting Arch derivatives your best option would be the upstream - the link can be found at the AUR script page.

One possible reason could be, you are using an argument to rebuild aur scripts and the script in question, or list of scripts, contains a -git package. The nature of -git scripts will always trigger a rebuild - no matter the version.

1 Like

Which package? It sounds like it might be a VCS package (i.e., something-git) possibly with submodules. Either let it “update” to allow Paru to catch up it’s cache or regenerate it with paru --gendb.

1 Like

@linux-aarhus @Yochanan
Thank you both for your answers. So it is probably a git-related issue. In my case it was related to the zotero package (AUR (en) - zotero).
“paru --gendb” probably did the trick. It showed an older version than the one already installed. After reinstalling the up-to-date version again, paru stopped asking for a rebuild. So, problem solved. Thanks.

Ok, I declared it too early as solved. The issue is still there. And it is only concerning the zotero package. It is not flagged out of date.

@linux-aarhus How do I find out, if I am using an argument to rebuild AUR scripts as you suggested?

Technically you are the only one knowing which arguments you are providing to paru when paru is not working like expected.

paru takes a lot of arguments - which command are you using? And equally important, which one of the scripts are you targeting? That is not clear to me.

I have no experience with paru besides the script.

My previous comment should suggest that even paru may need a rebuild…

If paru doesn’t behave like you expect - you should really connect with the author(s) of paru - it may be a behaviour they are not expecting

But the behaviour would be expected if it is zotero-git script your are referring to.

If you are using paru for regular maintenance - you should split your sync into

  1. system sync (official repo)
  2. rebuilding AUR
  3. native flatpak or snap sync tool - if applicable
1 Like

I use “paru -Syu”

I am targetting the pure “zotero”, not the “-git” script.

Actually, I think I do so:

  1. Update via pacman
  2. Update via paru

Maybe it is a paru issue, the paru package itself is marked as outdated.

To only target AUR - use (I am guessing)

paru -Syua zotero
1 Like

My answer is still there, too. :wink: Let it “update” and Paru will clone the repo from the latest commit and update the submodules. Unfortunately, any VCS package with updated submodules will trigger an update with some AUR helpers.

1 Like

Thank you, that is a good point.

Thank you for your answer. Paru asks for an update although the AUR package ist not recently updated due to the maintainer’s update information from the AUR package page. Even if I let it update, paru asks for another update of the exact same version number of the package the next time I update via paru. Would you say that’s still in line with usual behaviour of the AUR helper?

I’ve already explained why Paru thinks there’s an update when there actually isn’t. When that happens to me, I just let it “update” or ignore it.

Here’s an example with vulkan-caps-viewer-x11. The only reason why Paru thinks there’s an update is due to the Vulkan-Headers submodule. Notice it pulled the upstream repos, however ended up reinstalling the same version since there was actually nothing to do.

1 devel/vulkan-caps-viewer-x11  1:3.32-1 -> latest-commit
:: Packages to exclude (eg: 1 2 3, 1-3):
:: Resolving dependencies...
:: Calculating conflicts...
:: Calculating inner conflicts...

Aur (1)                     Old Version  New Version    Make Only
aur/vulkan-caps-viewer-x11  1:3.32-1     latest-commit  No

:: Proceed with installation? [Y/n]: 

:: Downloading PKGBUILDs...
 PKGBUILDs up to date
fetching devel info...
==> Making package: vulkan-caps-viewer-x11 1:3.32-1 (Mon 20 Nov 2023 03:53:46 PM MST)
==> Retrieving sources...
  -> Updating VulkanCapsViewer git repo...
remote: Enumerating objects: 34, done.
remote: Counting objects: 100% (34/34), done.
remote: Compressing objects: 100% (18/18), done.
remote: Total 34 (delta 21), reused 26 (delta 16), pack-reused 0
Unpacking objects: 100% (34/34), 41.89 KiB | 337.00 KiB/s, done.
 * [new branch]      format_feature_flags_2 -> format_feature_flags_2
   485ed56..aa97589  master                 -> master
   485ed56..aa97589  refs/pull/113/head     -> refs/pull/113/head
 + 65e0611...de0c478 refs/pull/159/merge    -> refs/pull/159/merge  (forced update)
 + 6538043...09b5e21 refs/pull/191/merge    -> refs/pull/191/merge  (forced update)
  -> Updating Vulkan-Headers git repo...
remote: Enumerating objects: 11, done.
remote: Counting objects: 100% (11/11), done.
remote: Compressing objects: 100% (5/5), done.
Unpacking objects: 100% (11/11), 2.21 KiB | 205.00 KiB/s, done.
remote: Total 11 (delta 5), reused 10 (delta 4), pack-reused 0
   af4fb97..a32b2b4  main               -> main
 * [new ref]         refs/pull/457/head -> refs/pull/457/head
==> Validating source files with sha256sums...
    VulkanCapsViewer ... Skipped
    Vulkan-Headers ... Skipped
==> Making package: vulkan-caps-viewer-x11 1:3.32-1 (Mon 20 Nov 2023 03:53:49 PM MST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating VulkanCapsViewer git repo...
  -> Updating Vulkan-Headers git repo...
==> Validating source files with sha256sums...
    VulkanCapsViewer ... Skipped
    Vulkan-Headers ... Skipped
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Creating working copy of VulkanCapsViewer git repo...
Cloning into 'VulkanCapsViewer'...
Switched to a new branch 'makepkg'
  -> Creating working copy of Vulkan-Headers git repo...
Cloning into 'Vulkan-Headers'...
==> Starting prepare()...
Submodule 'Vulkan-Headers' ( registered for path 'Vulkan-Headers'
Cloning into '/home/yochanan/.cache/paru/clone/vulkan-caps-viewer-x11/src/VulkanCapsViewer/Vulkan-Headers'...
Submodule path 'Vulkan-Headers': checked out 'fff6d143cc4dccb5959db63c85c7b01406e0d333'
==> Starting pkgver()...
==> Sources are ready.
vulkan-caps-viewer-x11-1:3.32-1: parsing pkg list...
:: vulkan-caps-viewer-x11-1:3.32-1 is up to date -- skipping build
loading packages...
warning: vulkan-caps-viewer-x11-1:3.32-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Package (1)             Old Version  New Version  Net Change

vulkan-caps-viewer-x11  1:3.32-1     1:3.32-1       0.00 MiB

Total Installed Size:  1.43 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                            [------------------------------] 100%
(1/1) checking package integrity                          [------------------------------] 100%
(1/1) loading package files                               [------------------------------] 100%
(1/1) checking for file conflicts                         [------------------------------] 100%
(1/1) checking available disk space                       [------------------------------] 100%
:: Processing package changes...
(1/1) reinstalling vulkan-caps-viewer-x11                 [------------------------------] 100%
1 Like

Ok, now I got it. Thank you so much for your explanations and the example.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.