Partitioning - Manjaro XFCE

Go into your UEFI settings ─ you can enter those at boot time ─ and look under “Advanced Boot Options” or something similar. You should be able to delete the Windows entry from there.

Ok, I’mma reboot again, see what I got and update you.

Update: Under the “Boot” menu, there’s no delete option, only “Secure Boot” and “Boot priority order”. Nothing else. In the “Advanced” menu, only Intel VTX, Intel VTD, and SATA Configuration only. The boot menu is called “InsydeH20 Setup Untility”.

Under the Boot Priority Options, you should see a list of boot entries. One of those will be your Windows entry. Position the cursor on that and press Enter. It should pop up a menu with the option to delete it.

Then, when you’re done, exit the UEFI and save your changes.

I’m pressing enter on “Windows Boot Manager” but nothing happens, it just blinks, same on the other options, but nothing else.

Is there no text on the screen that tells you how to delete that entry?

Maybe try the Del key?

Pressing F1 to give me some help, it states that pressing enter should bring me to a submenu, but it doesn’t. Imma do some a bit of research about this.

So there’s nothing else. Pressing enter doesn’t give me a submenu to delete. I guess I’m stuck at this for now. Maybe I re-installing Manjaro? Would manually partitioning will fix this?
Also, booting up in my old Windows 10, my C: drive is still there, but my D: drive isn’t.

No, reinstalling or repartitioning won’t make any difference. I guess we’ll have to do it the hard way. I was trying to spare you from that, given that you’re a newbie. :wink:

Well, it’s not all that hard, really, but you’ll have to keep your eyes open. You’ll need to run two commands in a terminal window. The second one will require root privileges, so you’ll have to run that with sudo ─ I’ll show you below.

The first command you’ll have to run is this one… :arrow_down:


This will print out a list of the entries in your UEFI boot menu, each of which will have a four-digit number next to it. Take note of the number corresponding to your Windows Boot Manager.

Now enter the following command, whereby you substitute “<number_here>” for the four-digit number corresponding to your Windows Boot Manager. :arrow_down:

sudo efibootmgr --delete-bootnum  <number_here>

That should take care of it. :crossed_fingers:

Edit: I see you’ve just added this:arrow_down:

Didn’t you tell the installer to wipe Windows and use the whole disk? :astonished:

Entering the code “sudo efibootmgr --delete-bootnum 0001” (Sorry I’m also using my phone to reply) gives me this error: You must specify an entry to delete (see the -b option).
Uhm, Wat? I can’t remembe. After pressing next, it took me to personal info page. Is it the mistake I made? Sorry, my bad, yet again.

Sorry, my bad. It’s getting (very very) late over here. Try this… :arrow_down:

sudo efibootmgr -b 0001 --delete-bootnum


Oh dang, I’m deeply sorry for that.
Anyways, I did delete it, so I’m gonna try and reboot again and see what I got.
What I meant is after pressing next, it took me to the User page, where I need to enter my personal info like full name, login name, password, etc.

Pressing “next” on what? :confused:

After the partitioning page? I think that’s it
Anyways, Windows is still there :slightly_frowning_face:
You should take a rest now, I guess I’mma go and figure this one out on my own. Thank you, you had helped me alot so here’s a drink for you, my guy :beers:

Wait… Are you still in the installer? I thought you were booted up in the installed system. :confused:

Is the Windows boot entry gone from the UEFI menu now? It’ll probably still be in your GRUB boot loader menu, and the Windows partition is still there, but you can delete all of that.

It does take several extra steps, though, and considering that…

  1. It is very late here; and…
  2. You’re a newbie and you don’t have any data on that drive yet;…

I would propose that you reinstall, but that you would pick the KDE Plasma edition now, given that you’ve got problems with XFCE and have had problems with it in the past as well.

If you do decide on reinstalling (with Plasma), then do choose manual partitioning this time, and delete your Windows partition.

Do not delete the EFI system partition. Just delete the Windows partition and the existing Manjaro partition, and then create your Manjaro root filesystem ─ ext4 and mounted at / ─ and a swap partition of about 6 to 8 GiB.

The swap partition does not have a mountpoint. Your EFI system partition however should be mounted at /boot/efi.

I had already installed manjaro.
Windows Boot Manager in still on the list, and I can still boot to it.
Anyways, I’mma figure this one out if I can, so you can take a rest now. Thanks again.

Hi there! Thank you for cooperating here.
Yes that’s what I’m actually doing now. Booting into my flash drive and getting back into the installer, I’ve seen that I installed Manjaro on my 1TB HDD, not on my 128GB SDD. So it was indeed my own misunderstanding.
Also, can I delete/reformat my HDD after I install Manjaro on my SSD? Because it’s where I installed by Manjaro previously.

Hello :slight_smile: ,

Yes, you can do it at one go, with manual partitioning, but pay attention with the flags, how you assign them.

I would suggest that you make the HDD your home partition.

Hi there!
Sorry for the late reply. I’m currently experiencing tons of issues with Manjaro XFCE like being slow, unresponsive, delays, hanging, freezing, etc, and it’s very annoying. I thought XFCE is meant to be fast. Maybe I did something wrong throughout the installation?
Anyways, how can I manually partition it? What specific partitioning would you recommend to a 128 SDD + TB HDD laptop? (My laptop is Acer Aspire 3 A314-32 if you ask).

Having only 4 GiB isn’t going to turn your computer into a speed machine. But you did say that you had problems with XFCE before and not with KDE Plasma. So perhaps you should opt for Plasma instead. Its memory footprint is about the same as with XFCE.

  • SSD: 512 MiB /boot/efi (FAT32) + the rest for / (ext4)
  • HDD: 12 GiB swap partition + the rest as /home (ext4)

And now I am going to bed. :stuck_out_tongue:

Why are you still not asleep?
Anyways, thank you but I’mma try it and re-install later as I have other things to do this time around (It’s 6PM here in my place and night are kinfa busy)