Partition that I use for data won't automatically mount after reboot

I have multiple partition’s on my 1TB SSD that I dual boot with Manjaro and Mac Catalina. ~200GB is for Manjaro and ~200GB is for Data related to Manjaro, TB profile and Windows 10 VM. Oddly, the data partition, sda3 won’t automatically mount until I open it in other locations in the File Manager. Only then can I open Thunderbird. Otherwise if I try to open TB it will give me an error saying that it can’t find that profile.

Do you know the file /etc/fstab ?
if you list the partition with the correct options in this file it will automatically mount on boot.

it is just a plain textfile. and there should already be yout root partition and maybe more if you have for your System.

But be careful to list it correct, the System may not boot if the new line is incorrect, but you always can edit the file from an bootet system from an bootstick.

(i could not list a link here - maybe search for “fstab” and “archlinux”, you will find a archwiki article with much information. You can ofcourse use the Manpage for fstab :slight_smile: )

the nofail option may be a good thing to add in the option of a new entry :slight_smile:
you could also add noauto maybe for mobile data storages so that it will only mounted manually.

I also prefer the UUID of a partition so that the System is searching the Partition for itself and is not relying on the “/dev/sdxy” sheme that sometimes list the Filesystems in another order.

When you are using a separate partition for data e.g. your thunderbird data folder - use a mount unit to mount the partition at boot.

That’s quite a bit beyond my paygrade. Thank you but not knowing what I’m doing, if I try to follow and interpret those directions, I’m certain to screw something up. I’ll just stick to clicking the drive when I boot up to mount it, unless someone else has a more simple way to handle this.

See if this can help you. :arrow_down:

Note: This was written for a member with a FAT-based partition. If yours is NTFS, then see… :arrow_down:

man mount

… for the correct mount options.

Can you post /etc/fstab ?

Mine is formatted ext4

Do cat /etc/fstab and post the output here.
Then do lsblk -o NAME,FSTYPE,LABEL,UUID,SIZE and post it too.

1 Like
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=67E3-17ED                            /boot/efi      vfat    umask=0077 0 2
UUID=1a0cdc8f-e890-4409-976d-8726d7065b4c /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=250cf9c9-aa57-47bd-ac60-dd9b640bb298 none swap defaults 0 0


NAME   FSTYPE   LABEL              UUID                                   SIZE
loop0  squashfs                                                          55.5M
loop1  squashfs                                                            66M
loop2  squashfs                                                         162.9M
loop3  squashfs                                                          31.1M
loop4  squashfs                                                         134.4M
loop5  squashfs                                                           161M
loop6  squashfs                                                         137.2M
loop7  squashfs                                                          67.7M
loop8  squashfs                                                          64.8M
sda                                                                     931.5G
├─sda1 vfat     EFI                67E3-17ED                              200M
├─sda2 apfs                        bc56323f-9b8b-49e2-9762-4473b91ceee4 525.6G
├─sda3 ext4     Data               8e327484-4627-438f-ab31-44fcb1dfde8e 202.8G
├─sda4 ext4                        1a0cdc8f-e890-4409-976d-8726d7065b4c 186.1G
└─sda5 swap                        250cf9c9-aa57-47bd-ac60-dd9b640bb298  16.8G
sdb                                                                       7.3T
├─sdb1 vfat     EFI                67E3-17ED                              200M
├─sdb2 hfsplus  Seagate 8TB        900e39fb-e11f-391c-b3eb-e23951153d08   6.4T
└─sdb3 ext4                        6d0c0d36-e19f-495b-acf8-a7293e5cf3ca 933.7G
 sdc    iso9660  MANJARO_GNOME_2021 2021-01-03-11-22-21-00                59.2G
├─sdc1 iso9660  MANJARO_GNOME_2021 2021-01-03-11-22-21-00                 2.8G
└─sdc2 vfat     MISO_EFI           784C-16A2                                4M

Do echo 'UUID=8e327484-4627-438f-ab31-44fcb1dfde8e /media/sda3data ext4 defaults,noatime,users 0 1' | sudo tee -a /etc/fstab and then reboot or, if sda3 is not mounted now, do sudo mount -a and go check /media/sda3data folder for your files. Reboot anyway to see if sda3 is getting automounted now.

Well, as seems to be the case with Linux, fixing one thing breaks another. Yes, you have now automounted that drive on reboot, thank you. However, Thunderbird can no longer find that profile on the drive and I’ve tried thunderbird -P and chosen my default profile.

Well, you’re free to unmount that partition now (sudo umount /dev/sda3), just make sure no apps are using it (like Thunderbird you mentioned), temporarily blacklist the last entry in /etc/fstab with putting # in the beginning of it, then mount it as you usually did before (most likely using your file manager) and look at the resulting path (df | grep sda3). The output is what you need to use instead of /media/sda3data in your fstab.
To edit fstab, use sudo nano /etc/fstab. Ctrl+S saves, Ctrl+X closes the editor. Don’t forget to remove # from the last line when you finish adjusting the path.
I’ve marked my previous post as solution since it seems to be the most appropriate candidate for that role…

I opened Fstab as an admin from the file manager and added the “#” that way and rebooted. Then VirtualBox was able to find the Windows 10 VM and also Thundebird was able to open. So I then tried what you mentioned and it required some guess work on my part. I typed in df | grep sda3 and got:
df: /run/user/1000/doc: Operation not permitted
/dev/sda3 199G 167G 23G 89% /run/media/bryankarlan/Data
Not knowing if I should take /dev/sda3 or /run/media/bryankarlan/Data I took the latter and substituted that for /media/sda3data and it did work. I can now reboot and have immediate access to the Data partition and both the VM and Thunderbird profiles work fine.

I’m glad you got it sorted out finally. Be well.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.