Pamac "waiting for other package managers to quit issue"

Hello everyone, I have had an issue the last few updates, where pamac will refuse to start the update, claiming that other package managers are open when they are not. I was able to find this error.
** (pamac-manager:11915): CRITICAL **: 17:08:44.175: pamac_system_daemon_get_lock: assertion 'self != NULL' failed

Any idea what is causing this? The only way i've found how to fix this is restarting.

When it happens again print your processes. You could maybe use something like

ps -A | grep -E 'pamac|octopi|alpm|pacman'

It's also possible you have a leftover /var/lib/pacman/db.lck from a crashed or uncleanly-stopped process.

1 Like

It seems as though using the cancel button can cause this, or force quitting pamac. Lately, i've been having issues with updates taking forever to start on pamac gtk with KDE as well as this behavior when I try to restart the update.

@guinux may you check this one. Accounted it also lately.

I'm on it

I had a similar problem when a ghost process associated with pamac was running as root, could only find it when I used Htop, but as soon as I killed it everything went back to normal and no restart required. I would advice you to move on from Pamac to pacman, as a noob I was totally dependent on pamac but it takes the fun and gives you no idea about the true power of manjaro(arch) or pacman, so get your hands dirty, I assure you, you'll soon start to enjoy it.

3 Likes

Here's my attempt to document when this happens most often:

  1. Have Parallel Downloads enabled (the default is 4?)
  2. Have updates available
  3. Instead of downloading the updates immediately try to install new software
  4. Pamac will try to update before downloading/installing the new software
  5. After about the 4th-8th file, Pamac's download speed will slow to a halt
  6. Clicking cancel takes two attempts & freezes Pamac (also keeping the db.lck)

For the past two months, I've resorted to removing /var/lib/pacman/db.lck & updating via pacman. I run into this issue almost daily. I hope this is resolved soon & thank you for your work on Pamac!

Edit: The issue was caused by parallel downloads being enabled. Read more below.

If it's not the case, set parallel downloads to 0 in preferences and tell if you still have this problem

2 Likes

Thank you for the advice. The issue is definitely with Parallel Downloads; I wanted to be sure so I've been testing this the past few days with it disabled.

The problem no longer manifests.