Pamac updates problem

Hi, since system update from 2020-12-30 I have problem with pamac (version 10.0.4.-2) updates:

  1. updates are often not showing automatically
  2. I think that this is connected with problem, than also database is not download / update automatically
  3. I even tried to delete database manually, then load manually, which leads to show some updates
    3a. I didn’t made update and tried to restart pc
    3b. after restart again, no update - I have to load database manually to show them off
  4. of course, that everything is installed and setted up right way

So, do any have some idea, how to resolve this out please? Or it’s some bug in pamac?

Also, does anyone know if is pamac-qt ready to use as primary packages gui?

1 Like

2 things:

  1. If you have an update, you should update. If Pamac can not do it, use sudo pacman -Syu.
  2. Pamac-QT is not ready to be used as a primary package manager. Development has sort of halted for a while, as far as I know.

Saw this yesterday as well.

You also have the following options using the command-line:

“sudo pacman-mirrors -c all” followed by “sudo pacman -Syyu”

I know, but it does not solve problem with pamac.

This I’ve tried, but pamac still does not automatically find any new update :(.

Have you seen The Manjaro Wiki? Here’s a link, it may be of some help:

https://wiki.manjaro.org/index.php/Pacman-mirrors

Hi,

In my case, pacman -Syyuu (with 2 ‘u’ to allow downgrades) solved the problem.

Maybe not right now, but might do for the next update.

You can use pamac as a package manager if you like, this works just fine.
Only to install or delete stuff.

Updating with pamac is out of order, since a long time now.

Ok, but that’s bad news. Do you think that it will be repaired?

Have you tried pamac update --force-refresh to try and sort the issue with pamac?

I updated Chromium earlier on today via the Pamac GUI - it was indicated in red on the toolbar - and zero problems on my side…

I had the same problem too not too long ago with updates not showing in Pamac. I can suggest checking if you have Software Mode box checked. It is under the menu on the upper right corner of Pamac GUI. I had updates not showing until I refreshed my mirrors, checked the Software Mode box, refreshed the mirrors again and used the terminal as @Frenchy and @cjean suggested.

Hope this helps.

1 Like

No, sadly it’s not helped. I still have to refresh database every PC restart to get info about updates.

1 Like

Thank all for trying to help. But I think, that there is some misunderstanding. I can update system with pacman, also I can update system with pamac. Problem is, that pamac not finding updates automatically, I have to manually load database every time when I restart PC.

I’ve done some internet research and it seems that this is some bug in pamac (as @ Citroen wrote) which appears only in some systems - I think KDE related.

1 Like

Hum. I’m running KDE myself and this has happened in the past on some rare occasions. However, it hasn’t been a problem that has persisted… :thinking:

Have you tried this ?

“sudo pacman-mirrors --fasttrack 10 && sudo pacman -Syyu”

2 Likes

Hi, yes, but not helpfull. Pacman mirrors seems not issue. I think that its bug only in pamac.

1 Like

OK, no problem. I’ve just seen the link on the Pamac issue. And it does, as you’ve pointed out, seem to be specific to Pamac.

For my part, the bug seems to have ironed itself out, since my Chromium update came through yesterday. I shall definitely be watching this space though.

i get a notice about available updates but after restarting the PC they are gone and i have to refresh the database to get them to show.
i think it’s similar to what is said here.