Pamac Update on Manjaro Sway

I’m running Manjaro Sway

I’m getting the following while doing sudo pamac update.

Apply transaction ? [y/N] y
Download of manjaro-sway-settings (15.3.1-34) started                                                                 
Download of manjaro-sway-settings (15.3.1-34) finished                                                                
Download of wlsunset (0.3.0-1) started                                                                                
Download of wlsunset (0.3.0-1) finished                                                                               
Downloading manjaro-sway-settings (15.3.1-34)...                                                                      
Downloading wlsunset (0.3.0-1)...                                                                                     
Checking keyring...
Checking integrity...
Error: manjaro-sway-settings: 
    signature from "Jonas Strassel <info@jonas-strassel.de>" is unknown trust
Error: wlsunset: 
    signature from "Jonas Strassel <info@jonas-strassel.de>" is unknown trust

Removing invalid files and retrying...

Resolving dependencies...
Checking inter-conflicts...
Download of manjaro-sway-settings (15.3.1-34) started                                                                 
Download of manjaro-sway-settings (15.3.1-34) finished                                                                
Download of wlsunset (0.3.0-1) started                                                                                
Download of wlsunset (0.3.0-1) finished                                                                               
Downloading manjaro-sway-settings (15.3.1-34)...
Downloading wlsunset (0.3.0-1)...
Checking keyring...
Checking integrity...
Error: manjaro-sway-settings: 
    signature from "Jonas Strassel <info@jonas-strassel.de>" is unknown trust
Error: wlsunset: 
    signature from "Jonas Strassel <info@jonas-strassel.de>" is unknown trust
Error: Failed to commit transaction: invalid or corrupted package (PGP signature):

No sudo required.

Thx @cscs. I have been running the update with sudo for ages, don’t recall why though.
:+1:

pacman does require it for transactions, such as update:

sudo pacman -Syu

pamac on the other hand is all about convenience, so simple syntax is used and privileges are prompted.

…Maybe thats why? Anyhoo. Glad its all sorted. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.