Pamac Update "Authentication Failed" with no proc mount hardening

I ran into an issue with pamac after a game crash that killed X. When running pamac update as my regular login user I started getting the “Authentication Failed” error.

After searching through some of the pamac code, systemd stuff, and info about dbus and polkit I realized there error was related to this pamac code on github:


In particular, the authorization check for org.manjaro.pamac.commit but from there couldn’t figure out what was causing the error.

Later, on the manjaro forum, I found two posts that have been auto-closed:

Both refer to the users having a proc mounting entry in /etc/fstab with specific hardening settings. I do not have this in my fstab, however I noticed in the first of the two post that user “Whathe” mentioned adding his user to the proc group may be a solution.

I tested this out and it does indeed fix the issue.

My concern then was introducing an unnecessarily increased attack surface to the proc group. So I removed my user from the proc group and tested pamac update again in yet a new session. The update worked so I assume that this exercise removed some sort of confused state introduced during the crash I mentioned at the beginning of this post.

Wanted to log this here so that others that see the posts I mentioned, who also don’t have proc mounts in their fstab may find the solution more easily while not keeping their users added to the proc group.