Pamac sudo permission


Thanks for all the help. Yes that is correct, I downloaded the Manjaro distribution of WSL which works fine. As I said, This isn’t my main computer. My main computer is running only Manjaro KDE which I am enjoying. I wasn’t sure how to find out the sudo permission errors I was getting with pamac.
Thanks for all the help with pamac.

I believe I have a problem somehow with permissions and/or my sudo settings/setup. If I try to do a normal pamac upgrade command the following is outputted and then the terminal brakes and I can’t carry out any more commands. If I use sudo pamac then it sort of works but I don’t think that’s very good as it should be.

$ pamac upgrade

** (pamac:2337): WARNING **: 09:07:29.660: flatpak_plugin.vala:257: Permission denied

** (pamac:2337): WARNING **: 09:07:29.677: transaction_interface_daemon.vala:51: failed to
connect to dbus daemon: Could not connect: No such file or directory
Authorization not available. Check if polkit service is running or see debug message for mo
re information.

** (pamac:2337): CRITICAL **: 09:07:29.885: pamac_daemon_start_get_authorization: assertion
'self != NULL' failed

According to your user description, you are on KDE Plasma. Is that correct? Make sure you have
polkit-kde-agent installed, reboot after, in case you have to install it.
If you use other DE, let us know.


Thank you very much, very sorry for the delay in responding.

My main computer is indeed on KDE Plasma

This was on the laptop:

$ pamac upgrade
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)
Error: Authentication failed
$ pamac update
Error registering authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject (polkit-error-quark, 0)
Error: Authentication failed

It seems like a slightly different error message to what I was having before but maybe related?

sudoers file:

## User privilege specification
'$(whoami)' ALL=(ALL) ALL

## Uncomment to allow members of group wheel to execute any command
# %wheel ALL=(ALL) ALL

## Same thing without a password

## Uncomment to allow members of group sudo to execute any command
%sudo	ALL=(ALL) ALL

## Uncomment to allow any user to run sudo if they know the password
## of the user they are running the command as (root by default).
#Defaults targetpw  # Ask for the password of the target user
# ALL ALL=(ALL) ALL  # WARNING: only use this together with 'Defaults targetpw'

## Read drop-in files from /etc/sudoers.d
@includedir /etc/sudoers.d

cat /etc/sudoers.d/wheel
– %wheel ALL=(ALL) ALL

What is this? You add it yourself? Can you please point me to a documentation that explains it?

if this is uncommented then each time something requires authentication but runs trough polkit will fail, at least that is my understanding. On my end is commented.

Where did this file come from ?

When you run groups from terminal you should be part of at least this groups:

sys network power lp wheel yourname

And all the other files you mentioned should be default. If you want to run commands without password, then see this as example:
[SOLVED] Sudo run commands with no password - #10 by sng

Screenshot says Windows Subsystem for Linux.

I don’t think any polkit agent would be running in that case.

1 Like

Didn’t even noticed that (for some reason the image did not load for me first time).
We don’t deal with WSL, right?

Running Manjaro on WSL is unsupported as it is impossible to predict what happens in an emulated environment.

Microsoft does not support any of their systems running through wine.

As you would look to Wine for support - in this case you should look to Microsoft for support.

Also the issue of running using Weston - which uses Wayland - and this again creates issues with relation to how applications are allowed to interact with the system especially for altering the core system.

No - your main computer is on Windows - you documented this in your screenshot and as not even your kernel is Manjaro but -microsoft-standard-WSL2, this has nothing to do with Manjaro.


Lets for the sake of argument say this is a Manjaro issue then to reproduce the issue one would have to install Windows (at what servicepack / update level?) then enable developer mode and install WSL (again at what software level?) then install Manjaro KDE - just to troubleshoot why polkit is not working?

Now you understand why this topic is closed as off-topic - this is not a Manjaro issue and therefore not a matter of concern.

Have a nice day.

1 Like