Pamac sources update differences per machine


I two PC’s, both have Majaro 22 and AFAICT Pamac is configured the same on both.

I have an installed package on both, but one has and older version of the package.

Pamac claims both systems are up to date.

I have tried all the refresh settings I can find on the one that is behind. (At least I think I have.)

Is there a way to force it to update? Maybe I need to use Pacman?

How do I get the lagging machine to get the latest?

Do you use the same mirrorlist on both machines ?

…and the same branch :wink:

They are both set to worldwide and AUR is enabled.

I don’t see anything about a branch.

please check

pacman-mirrors -G

stable ? unstable ? please report

pacman-mirrors shows stable on both machines.

The actual package in question is an AUR git version.

so we are talking about packages you’ve installed from aur. with all the problems and discussions about manjaro/pamac/aur the only thing i would suggest is to switch to unstable, renew the pamac/pacman as described in the unstable thread and use this.
that’s my personal point of view, others might think different.

I’m happy to do that. But, I’m confused why one has updated and the other not, but both are set to stable?

Try on both devices

pamac update --force-refresh -a

and check again.

Have you checked to see if the mirror list is the same on both machines? I know @Keruskerfuerst asked but you haven’t answered yet.

Since I never changed the mirror list, I don’t think it’s different. But, thinking about it, the OS installs were done a few months apart. So, that might make them different.

But, Now I’m really confused because I removed the package in question on the machine that Pamac says has no updates. It reinstalled it and now it is at the same version as the one that updated on the other machine.

But, Pamac still say lists the old version…

The mirrors or the branch don’t matter for AUR updates.

Use pamac update --aur --devel to update *-git packages.

The mirrorlist has no implication for AUR packages - only their possible dependencies from the official repo.

But pamac does once a week on a timer

systemctl list-timers

In Pamac

  • Worldwide is the complete mirror pool
  • Global you get CDN77 mirror pool
  • Country you get mirrors from a named country

Pick one named mirror and set the same on both e.g. (the -U will be reverted when the mirrorlist is recreated).

sudo pacman-mirrors -aU

If you want to ensure your mirrorlist is never rewritten you should create a custom mirror pool with only one mirror e.g. - select the same mirror for both systems

sudo pacman-mirrors -c at -i

Then update from the official repo

sudo pacman -Syu

After a succecful update you can rebuild your AUR package(s)

pamac update --aur

I also get stuck with this problem from time to time, what I simply do is :

  1. Open “Pamac > Preferences > General” and click on “Refresh Mirrors” one or two times
  2. Click on Humber menu and select “Refresh databases” then restart Pamac.