Pamac | socket i/o timed out and unnacceptable tls certificate error

Initially when i was running sudo pamac upgrade i got the error socket i/o timed out
So I ran the following commands:

sudo pamac upgrade --enable-downgrade --force-refresh
sudo pacman-mirrors --fasttrack && sudo pacman -Syyu
sudo pacman-mirrors --interactive && sudo pacman -Syyu

After this I selected the mirrors called global and india only and proceeded.
After this I started getting the error unnacceptable tls certificate when i ran sudo pamac upgrade
So I ran the following:

sudo pacman-mirrors -f && sudo pacman -Syyu

The error still persists and idk what to do.

You are running into this: Pamac fails to synchronise due unacceptable TLS certificate

It is a server error in the AUR CDN. There is not much you can do, except wait. It only affects AUR, so you can use the repo mirrors normally and pacman-mirrors has no effect on the problem. Alternatively, you can try with yay to use AUR.

So the flatpak and pacman packages will be upgraded and installed normally right?

Yes, they would

how do i close this thread?

Mark a post as an answer.

pamac does not need sudo

Certificate error only affects AUR updates
To update Manjaro repository packages without AUR errors:

pamac update --no-aur

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.