Pamac-qt refuses to work with QT5 5.12.1-1.1

#1

I just updated my System to a newer QT5 version (v5.12.1-1.1) and pamac-qt refuses to launch since it considers the new version of QT5 “incompatible”.

QQmlApplicationEngine failed to load component
qrc:/src/qml/MainWindow.qml:-1 File was compiled ahead of time with an incompatible version of Qt and the original file cannot be found. Please recompile

It would be nice to update pamac-qt to work with this new QT5 version.

Some specs:
DE: KDE Plasma 5.14.5
Kernel: 4.20.7-1-MANJARO
Branch: Unstable

inxi -Fxxxz

System: Host: PHOTON Kernel: 4.20.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1
Desktop: KDE Plasma 5.14.5 tk: Qt 5.12.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Desktop System: Gigabyte product: Z390 AORUS MASTER v: N/A serial:
Mobo: Gigabyte model: Z390 AORUS MASTER-CF v: x.x serial: UEFI: American Megatrends
v: F8b date: 12/18/2018
CPU: Topology: 8-Core model: Intel Core i9-9900K bits: 64 type: MT MCP arch: Kaby Lake rev: C
L2 cache: 16.0 MiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 115232
Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800
6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 801 13: 800 14: 800 15: 800 16: 800
Graphics: Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: Micro-Star MSI driver: nvidia v: 415.27
bus ID: 01:00.0 chip ID: 10de:13c2
Display: x11 server: X.Org 1.20.3 driver: nvidia compositor: kwin_x11
resolution: 1920x1200~60Hz
OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 direct render: Yes
Audio: Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel v: kernel
bus ID: 00:1f.3 chip ID: 8086:a348
Device-2: NVIDIA GM204 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel bus ID: 01:00.1 chip ID: 10de:0fbb
Sound Server: ALSA v: k4.20.7-1-MANJARO
Network: Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel bus ID: 00:14.3
chip ID: 8086:a370
IF: wlo1 state: down mac:
Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: 3.2.6-k port: efa0
bus ID: 00:1f.6 chip ID: 8086:15bc
IF: eno2 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 1.36 TiB used: 90.50 GiB (6.5%)
ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB speed: 6.0 Gb/s
serial: rev: 2B6Q scheme: GPT
ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s
serial: rev: 3B6Q scheme: GPT
Partition: ID-1: / size: 250.00 GiB used: 28.85 GiB (11.5%) fs: btrfs dev: /dev/sdb2
ID-2: /home size: 669.32 GiB used: 61.65 GiB (9.2%) fs: ext4 dev: /dev/sdb3
Sensors: System Temperatures: cpu: 43.0 C mobo: N/A gpu: nvidia temp: 50 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info: Processes: 331 Uptime: 38m Memory: 15.60 GiB used: 2.73 GiB (17.5%) Init: systemd v: 241
Compilers: gcc: 8.2.1 alt: 7 Shell: bash v: 5.0.0 running in: konsole inxi: 3.0.30

File System: Home: ext4 Root: BtrFS

0 Likes

#2

Pamac-qt is still under heavy development and it is - to my knowledge - not stable for production environments.

0 Likes

#3

Yes, i know, just wanted to let you know so you can fix it :wink:
I use regular GTK+ pamac for production.

1 Like

#4

Did you reboot/relog after the QT update?

0 Likes

#5

confirm same error (after reboot :wink:) with archlinux qt5-base 5.12.1-1 pamac-qt 0.1.5-1


rebuild from last commit (with archlinux) and OK no error

0 Likes

#6

Was that a rebuild of pamac-qt against the new qt5-base?

0 Likes

#7

Did you reboot/relog after the QT update?

Yes, as @papajoke said, it does not help.
Rebuilding the app with the new QT5-base will help though.

0 Likes

#8

No doubt it will. So you should do that. :slight_smile:
Or wait until the packager does it.

0 Likes

#9

I thought I would give this new pamac-qt version a try. The same error as already reported is still occurring on my fully updated system (as of today). Just thought I’d mention this is still happening. Not a big deal as I realize this is really only for testing at this stage. Just thought I’d report it.

0 Likes

#10

I you rellay want to try it, download its PKGBUILD and rebuild it with makepkg, that will fix it.

0 Likes

#11

I’m not really too concerned about it. I just thought I’d mention it was still not starting. I was just curious at this point. I know it’s not exactly that ready yet.

Thank you for the information.

0 Likes

#12

new version/new build today (or tomorrow)

subject can be closed

2 Likes