Pamac Qt 0.2 Beta

I don't think it's a driver issue either. I have amd graphics on one computer and nvidia on another, same result.
I try pamac-qt when it gets updated. It always breaks, sadly. Not a little either, a lot. I won't use it for my regular stuff. But that's why I'm in testing, to test!

I think you may be right about our fearless pamac-qt dev being inundated beyond a persons ability to work. :frowning: but, what do I know? :wink:

Yeah, at the moment pamac-qt is the most unstable package that I have installed. It actually rarely works and most of times I launch it, it's broken. It gets fixed then after some time I test it, it's broken again.

I can understand why static and independent libraries as it is on windows or snaps or flatpacks are a developers wet dream. They may be obsolete, insecure but... will work with that bundled version.

Having constantly be on lookout of possible breakages on a rolling system sounds like a nightmare. On another hand, somehow other apps won't break so easily and so often, so I guess this project needs more work and... more experience that @LordTermor gets every time he fixes it, so it's a tough, but slow learning process.
We help as much as we can, as testers, but I'm afraid it will take long time till the software will be in mature enough phase to release it as a default app. Unless someone other will join in and takes care of some responsibilities like testing or introducing own experience and manpower to development.

That's why it's not considered bug-free or something. I'm experimenting a lot with internal structure since it's, well, not too easy to wrap an entire GObject library into a completely different Qt ecosystem especially with QML that has a lot of fundamental differences.
There are a lot of limitations and bugs in both of them. Also there is a lot of incompatibilities in GObject class system approach and C++ one.

I appreciate all of your help. I know about the much part of bugs. But I don't have much time to fix it and improve since it's not my main project. I hope we are understanding each other.

There was a lot (I mean a LOT) of silent work in a polishing branch so I'll release a fresh new version sooner than you may think.

offtopic UPD: "lot" is a little more junkier than I thought :grin:

1 Like

Yeah, we understand that this is not your main project or focus so we appreciate the time and enthusiasm. I'm not a developer so I can't even grasp all the hardships that come with it but I can imagine how time consuming it can be and how demanding Linux community can be :wink: . We all want things here and now and... since we do have access to many quality software, demand a lot.

I'm still in ave how @philm and the rest of the crew (not many of them) can run Manjaro so smoothly over the years. Sure, there were errors and falls but in overall, they manage to keep things working in a good quality and time. Since I am on testing and occasionally on unstable branch I could see how much of work goes to upkeep the distro. When they find time to sleep? I don't know but every day brings some issues and there is always someone there keeping the guard and ready to react if some alarming things happen. In a way, we got spoiled :wink: by their hard work.

Anyway, I can only imagine how it is for you and one person who has life, various responsibilities and goals, and a project that actually should be monitored every day. This isn't viable for a long run, you have to manage your time over other activities (also free time). That is why I said, some dev help would be needed on the long run. Or maybe with time it won't be so demanding? Who knows, again, I'm just guessing based on my observations.

3 Likes

It's not that bad. I just didn't announce anything but I've adapted pamac-qt to libpamac changes in a two or three days after it's release.

0.2.1 Beta is here.
I don't have any time to make some kind of announce but there is a lot of updates as stated above.
Some things got much improvements and fixes and some others were completely rewritten. You can check out a git commit log.


Also I think there are some regressions so feel free to test it one more time.

@philm it's needed to update a PKGBUILD since the build system was changed to CMake.

5 Likes

@LordTermor: we need to work on the PKGBUILD! Install routine is missing.

1 Like

New to linux and Manjaro. I followed the instructions to build from source. However, I don't know how to launch the application. I am already using pamac-gtk.

Here are the terminal commands I used

git clone https://gitlab.manjaro.org/applications/pamac-qt.git
cd pamac-qt
mkdir build
cmake ..
make

Here's the output from my terminal after 'make'

Scanning dependencies of target libqpamac_autogen
[  3%] Automatic MOC for target libqpamac
AutoMoc: /home/victor/pamac-qt/libqpamac/include/Transaction.h:54: Warning: Property declaration requestCommit has no READ accessor function or associated MEMBER variable. The property will be invalid.
/home/victor/pamac-qt/libqpamac/include/Transaction.h:55: Warning: Property declaration requestImportKey has no READ accessor function or associated MEMBER variable. The property will be invalid.
/home/victor/pamac-qt/libqpamac/include/Transaction.h:56: Warning: Property declaration requestChooseProvider has no READ accessor function or associated MEMBER variable. The property will be invalid.
/home/victor/pamac-qt/libqpamac/include/Transaction.h:57: Warning: Property declaration requestOptDepends has no READ accessor function or associated MEMBER variable. The property will be invalid.
[  3%] Built target libqpamac_autogen
Scanning dependencies of target libqpamac
[  7%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/libqpamac_autogen/mocs_compilation.cpp.o
[ 11%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/src/AsyncHelpers.cpp.o
[ 15%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/src/AurPackageModel.cpp.o
[ 19%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/src/Database.cpp.o
[ 23%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/src/HistoryItemModel.cpp.o
[ 26%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/src/LibQPamacModule.cpp.o
[ 30%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/src/PackageModel.cpp.o
[ 34%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/src/QmlTableModel.cpp.o
[ 38%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/src/Transaction.cpp.o
[ 42%] Building CXX object libqpamac/CMakeFiles/libqpamac.dir/src/Utils.cpp.o
[ 46%] Linking CXX shared library libqpamac.so
[ 46%] Built target libqpamac
Scanning dependencies of target qtnotificationservice_autogen
[ 50%] Automatic MOC for target qtnotificationservice
AutoMoc: /home/victor/pamac-qt/notificationservice/include/UnityProgressNotifier.h:16: Warning: Class UnityProgressNotifier implements the interface AbstractNotifier but does not list it in Q_INTERFACES. qobject_cast to AbstractNotifier will not work!
AutoMoc: /home/victor/pamac-qt/notificationservice/include/NotificationService.h:11: Warning: Property declaration progress has no READ accessor function or associated MEMBER variable. The property will be invalid.
[ 50%] Built target qtnotificationservice_autogen
Scanning dependencies of target qtnotificationservice
[ 53%] Building CXX object notificationservice/CMakeFiles/qtnotificationservice.dir/qtnotificationservice_autogen/mocs_compilation.cpp.o
[ 57%] Building CXX object notificationservice/CMakeFiles/qtnotificationservice.dir/src/NotificationService.cpp.o
[ 61%] Building CXX object notificationservice/CMakeFiles/qtnotificationservice.dir/src/TrayIconNotifier.cpp.o
[ 65%] Building CXX object notificationservice/CMakeFiles/qtnotificationservice.dir/src/UnityProgressNotifier.cpp.o
[ 69%] Linking CXX static library libqtnotificationservice.a
[ 69%] Built target qtnotificationservice
Scanning dependencies of target pamac-qt-app_autogen
[ 73%] Automatic MOC for target pamac-qt-app
[ 73%] Built target pamac-qt-app_autogen
[ 76%] Generating qrc_qml.cpp
Scanning dependencies of target pamac-qt-app
[ 80%] Building CXX object app/CMakeFiles/pamac-qt-app.dir/pamac-qt-app_autogen/mocs_compilation.cpp.o
[ 84%] Building CXX object app/CMakeFiles/pamac-qt-app.dir/src/cpp/src/QmlDialogRunner.cpp.o
[ 88%] Building CXX object app/CMakeFiles/pamac-qt-app.dir/src/cpp/src/XDGIconProvider.cpp.o
[ 92%] Building CXX object app/CMakeFiles/pamac-qt-app.dir/src/cpp/src/main.cpp.o
[ 96%] Building CXX object app/CMakeFiles/pamac-qt-app.dir/qrc_qml.cpp.o
[100%] Linking CXX executable pamac-qt-app

make install

I'll update a PKGBUILD tomorrow.

Well, current PKGBUILD doesn't produce any working version:

pacman -Ql pamac-qt
pamac-qt /usr/
pamac-qt /usr/local/
pamac-qt /usr/local/bin/
pamac-qt /usr/local/bin/pamac-qt-app
pamac-qt /usr/local/lib/
pamac-qt /usr/local/lib/libqpamac.so
pamac-qt /usr/local/lib/libqtnotificationservice.a

We get this:

pamac-qt-app: error while loading shared libraries: libqpamac.so: cannot open shared object file: No such file or directory

It's because of CMAKE_INSTALL_PREFIX is set to /usr/local by default and Manjaro doesn't look for libraries in /usr/local/lib.

It looks like pamac-cli is no longer required for pamac-qt?
Instead, pamac-common is required?

$ pacman -Qdt
pamac-cli 8.0.3-4

$ pacman -Qi pamac-qt
Name            : pamac-qt
Version         : 0.2.1-1
Description     : A QT5 frontend for libalpm - early preview version
Architecture    : x86_64
URL             : https://gitlab.manjaro.org/applications/pamac-qt
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : pamac-common>=8.0.0  qt5-base>=5.12.3  qt5-quickcontrols2  qt5-quickcontrols  qt5-graphicaleffects  qqc2-desktop-style  breeze-icons
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 615.00 KiB
Packager        : Philip Mueller <philm@manjaro.org>
Build Date      : Sun 21 Jul 2019 01:59:27 AM EDT
Install Date    : Sun 21 Jul 2019 07:06:28 AM EDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

$ pacman -Qi pamac-common
Name            : pamac-common
Version         : 8.0.3-4
Description     : A Package Manager based on libalpm with AUR and Appstream support
Architecture    : x86_64
URL             : https://gitlab.manjaro.org/applications/pamac
Licenses        : GPL3
Groups          : None
Provides        : pamac-common=8.0.3
Depends On      : glib2>=2.42  json-glib  libsoup  dbus-glib  polkit  libnotify  desktop-file-utils  pacman>=5.1  pacman<5.2
                  archlinux-appstream-data  pacman-mirrors>=4.9.1  git
Optional Deps   : None
Required By     : pamac-cli  pamac-qt
Optional For    : None
Conflicts With  : pamac<=7.3.4-2  pamac-aur  pamac-common
Replaces        : None
Installed Size  : 2.65 MiB
Packager        : Philip Mueller <philm@manjaro.org>
Build Date      : Sat 20 Jul 2019 04:20:29 AM EDT
Install Date    : Sat 20 Jul 2019 07:37:45 AM EDT
Install Reason  : Installed as a dependency for another package
Install Script  : Yes
Validated By    : Signature

Help and suggestions please :slight_smile:
So I installed it using pamac-manager. Everything seemed to go well on the install BUT it crashes right away.

The program starts, the popup for my root password pops up for a split second and closes. I ran it in the terminal with this output:
$ pamac-qt
QML debugging is enabled. Only use this in a safe environment.
Both point size and pixel size set. Using pixel size.
Segmentation fault (core dumped)

Yeah, we know. That is why it is still a beta software.

Oh I get it, just didn't know if someone would suggest a debugging flag to toss on the command to get more info out to the effort.

Didn't mean to sound bitchy or like I was expecting it to just work, sorry

@mparillo Technically pamac-cli was never required by pamac-qt since it relies on libpamac and not the pamac command line tool

@mrmike_me Please show your pamac-qt package version. It's strange that you are facing this issue.

@LordTermor the latest version produces segfaults after completing a transaction on XFCE. We have to see.

I'll look into it. Thank you

Forum kindly sponsored by Bytemark