Pamac-manager starts only with long delay

Hi folks, I have the strange “problem” that the pamac-manager (the pamac-gui) whether started from the menu a .desktop link or the terminal takes approximately 15 to 20 seconds to load.

The terminal ourput says something about mime.types [i.e. says: (process:11991): GLib-GIO-WARNING **: 14:48:54.048: /etc/xdg/kde-mimeapps.list contains a [Added Associations] group, but it is not permitted here. Only the non-desktop-specific mimeapps.list file may add or remove associations)]. I doubt that the problem lies in the mimetypes file.

I also searched the forum and uninstalled the flatpak plugin (sudo pacman -R pamac-flatpak-plugin), but the strange behaviour prevails. This started two stable updates before.

The pacman -Q1 pamac output is below. I am running KDE Plasma. If you deem further info necessary, let me know.

[manjamin@manjamin-pc ~]$ pacman -Qi pamac
Name                     : pamac-gtk
Version                  : 10.0.4-2
Beschreibung             : A Package Manager based on libalpm with AUR and
                           Appstream support
Architektur              : x86_64
URL                      :
Lizenzen                 : GPL3
Gruppen                  : Nichts
Stellt bereit            : pamac=10.0.4-2  pamac-gtk=10.0.4-2
Hängt ab von             : pamac-cli=10.0.4-2  gtk3>=3.22
Optionale Abhängigkeiten : pamac-gnome-integration
Benötigt von             : pamac-tray-icon-plasma
Optional für             : Nichts
In Konflikt mit          : pamac  pamac-aur  pamac-gtk-dev
Ersetzt                  : pamac
Installationsgröße       : 3,01 MiB
Packer                   : Philip Mueller <>
Erstellt am              : So 10 Jan 2021 21:11:32 CET
Installiert am           : So 10 Jan 2021 23:45:10 CET
Installationsgrund       : Ausdrücklich installiert
Installations-Skript     : Ja
Verifiziert durch        : Signatur

I had the same problem with Package Manager (pamac) and with a few of other apps (Lutris and Telegram, for exemple). They started with long delay.
As I did not found any answer to your post, I continued my search.
In my case, the problem was not in Pamac nor in Lutris nor in Telegram… The problem was in /etc/pipewire/pipewire.conf.
I found this solution that worked for me:
"I noticed, that there was a pipewire.conf.pacnew indicating a changed pipewire default configuration. Applying the new configuration totally fixed this issue:
sudo mv /etc/pipewire/pipewire.conf{.pacnew,} "
If you have /etc/pipewire/pipewire.conf and also /etc/pipewire/pipewire.conf.pacnew, try the above command.
Hope it works. :slightly_smiling_face:

1 Like

Thank you very much for your answer! You’re right it does not only affect the package manager here, also gscan2pdf is affected. However, the new pipewire.conf does not solve the issue here.

I found an old thread though saying that this command

dbus-launch --exit-with-session pamac-manager

works for letting pamac-manager start fast (and this works). So this may be a pointer to the problem.

I found another thread
saying to manually start “/usr/lib/xdg-desktop-portal-kde”. Looks like all gtk3 applications require “org.freedesktop.portal.Desktop” to be present on dbus."

So I added /usr/lib/xdg-desktop-portal-kde to the autostart of KDE/Plasma and this appears to be still not working.

Response to self: this did not work any more after reboot. Also the xdg-desktop-portal-kde thing does not work any more (errs out with:
xdp-kde: Failed to register org.freedesktop.impl.portal.desktop.kde service

Running: dbus-update-activation-environment --systemd DBUS_SESSION_BUS_ADDRESS DISPLAY XAUTHORITY does the trick in this session … [to be updated after reboot]

Besides that /etc/pipewire/pipewire.conf.pacnew, I found some more pacnew files in /etc folder and sub-folders.
I spent some time analysing all of them, looking for differences in content and date. I replaced most of the current files with the pacnew ones after carefully analysing each of them. This fixed some other glitches.
Please take a look at these posts about pacnew files (I cant include links in my post):
Manjaro Linux Forum »Technical Issues and Assistance »Newbie Corner »explanation of pacnew files
Pacman/Pacnew_and_Pacsave at archlinux wiki
Also, there may be other causes for the problems you are founding. I tried some other things (dont remember all of them) before addressing the pacnew issue.

1 Like

Thanks. I took the pacnew chaser for providing a complete pacnew picture of my system.

There is one additional thing that I changed here: I let the GTK programs choose whatever they want as style (that is, I don’t force a style on them in the KDE Plasma Controlcentre by setting GTK Design: Default). Now everything looks more or less ugly, but everything starts swiftly :slight_smile: .