Pamac is not launching

I am unable to launch pamac gui, i also tried reinstalling pamac-flatpak-plugin.I also teried the pamac CLI the output of pamac-manager in terminal:

** Message: 09:34:52.882: flatpak_plugin.vala:125: last flathub appstream ref
resh is older than 6
** Message: 09:34:52.883: flatpak_plugin.vala:126: refreshing flathub appstre
am data

(process:11180): GLib-GIO-WARNING **: 09:34:53.245: /etc/xdg/kde-mimeapps.lis
t contains a [Added Associations] group, but it is not permitted here. Only
the non-desktop-specific mimeapps.list file may add or remove associations.

(pamac-manager:11180): GLib-GIO-CRITICAL **: 09:34:53.246: g_application_run:
assertion ‘acquired_context’ failed

This may mean you are out of dat as this should be fixed.

Whatever the case … the issue is from pamac-flatpak-plugin if removed pamac can open.

thank you that worked

I think something is out of sync. A recent update I did instead new pamac packages but now I get these nessages when I check for updates.

warning: pamac-cli: local (10.0.0-1) is newer than extra (9.5.12-1)
warning: pamac-common: local (10.0.0-1) is newer than extra (9.5.12-2)
warning: pamac-gtk: local (10.0.0-1) is newer than extra (9.5.12-1)

I’m considering removing the packages as I don’t use pamac no offense but wanted to mention that nonetheless.

Running a command-line update fixed it for me (pacman -Syu). Pamac & the flatpak plugin were updated.

Agreed. it worked as soon as the flatpak plugin update for me also.

Please ignore my post above. The issue has been fixed in the repos since then. So as @Moilleadoir said running a pacman update will work fine now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.