Pamac icons are not correct visible

Hello together,

I have the problem, that the icons in pamac for select / unselect not correct visible. I tried many themes, but without solution.

look at that:

can you help me?

System:    Kernel: 5.13.8-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.22.4 Distro: Manjaro Linux 
Machine:   Type: Laptop System: TUXEDO product: TUXEDO Pulse 15 Gen1 v: Standard serial: <filter> 
           Mobo: TUXEDO s model: PULSE1501 v: Standard serial: <filter> UEFI: American Megatrends v: N.1.07.A02 
           date: 12/08/2020 
Battery:   ID-1: BAT0 charge: 88.9 Wh (97.1%) condition: 91.6/91.6 Wh (100.0%) 
CPU:       Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP cache: L2: 4 MiB 
           Speed: 1397 MHz min/max: 1400/2900 MHz Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 
           8: 1397 9: 1397 10: 1397 11: 1397 12: 1395 13: 1397 14: 1396 15: 1391 16: 1374 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir driver: amdgpu v: kernel 
           Device-2: Chicony HD Webcam type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.8-1-MANJARO LLVM 12.0.1) v: 4.6 Mesa 21.1.6 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.13.8-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 15.0 running: yes 
           Sound Server-3: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi 
           IF: wlp1s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: eno1 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb 
           Report: rfkill ID: hci0 state: up address: see --recommends 
Drives:    Local Storage: total: 232.89 GiB used: 36.8 GiB (15.8%) 
           ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M8250G size: 232.89 GiB 
Partition: ID-1: / size: 219.86 GiB used: 36.8 GiB (16.7%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 511 MiB used: 304 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 34.4 C mobo: 33.0 C gpu: amdgpu temp: 33.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 332 Uptime: 9m Memory: 7.19 GiB used: 1.4 GiB (19.5%) Shell: Bash inxi: 3.3.06


It must be theme dependent. Works well for me with Arc GTK theme and Papirus icon theme.

Hello @archisman

I tried all the available themes without a solution :thinking:


Pamac is a GTK application … is not using QT themes.
Go to Settings > Appearance > Application Style
and down the bottom there is the GTK button theme.

I have not used Pamac with the themes in your screenshot. You can give Arc theme a try.
Open a terminal and the command

sudo pacman -S arc-gtk-theme

And change the GTK theme to Arc theme.

System Settings → Appearance → Application Style → Configure GNOME/GTK application style

I did it and selected in the application style, but it dosen´t work …


Just to clarify, does the theme in Pamac not change after you apply changes in GTK theme?

where can I check it ?!?

The appearance of Pamac would change when you change the GTK theme.

Yes, you are right. The themes are changed, but the icons are not correct.
look to this:

by the way thanks for your support @archisman :grinning:


Try the Papirus Icon theme. It works for me.

sudo pacman -S papirus-icon-theme

And apply it in system settings.

I tried it. It changes the icons in the task-bar for example but not the selection icons in pamac.

I have not used KDE for some time, and cannot remember if the icon theme for GTK apps had to be configured separately. Maybe someone else can confirm it.

1 Like

OK, you are right. It is not nice, but not a very important problem for me. If it is possible, I use pacman in the console too.
But it is a “nice to have”, if the icons works :upside_down_face:

So I remember my thank you very much for your patience and support to me @archisman .


1 Like

@caho You can try creating a new user to see if the icons are there. :slightly_smiling_face:

Hello, @Shirshendu ,

I have several different users with their own accounts on my computer. There are the same visible problem with pamac.