Pamac icon no longer showing up in system tray

Please check your
The Content must

[Desktop Entry]
Name=Update Notifier Tray Icon

What is the output from this;

systemctl --user status "app-pamac\x2dtray\x2dplasma@autostart.service"

Checked /etc/xdg/autostart/pamac-tray-plasma.desktop its content is exactly as you suggested. As for systemctl --user status "app-pamac\x2dtray\x2dplasma@autostart.service" my output is:

● app-pamac\x2dtray\x2dplasma@autostart.service - Update Notifier Tray Icon
     Loaded: loaded (/etc/xdg/autostart/pamac-tray-plasma.desktop; generated)
     Active: active (running) since Thu 2023-07-20 18:06:26 EEST; 4 days ago
       Docs: man:systemd-xdg-autostart-generator(8)
    Process: 1809 ExecCondition=/usr/lib/systemd/systemd-xdg-autostart-condition KDE  (code=exited, status=0/SUCCESS)
   Main PID: 1838 (pamac-tray-plas)
      Tasks: 11 (limit: 38389)
     Memory: 56.8M
        CPU: 24.334s
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/app-pamac\x2dtray\x2dplasma@autostart.service
             └─1838 /usr/bin/pamac-tray-plasma

Jul 25 04:17:15 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:71: check updates
Jul 25 04:17:15 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:101: 0 updates found
Jul 25 04:18:21 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:71: check updates
Jul 25 04:18:21 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:101: 0 updates found
Jul 25 04:48:32 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:71: check updates
Jul 25 04:48:32 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:101: 0 updates found
Jul 25 15:24:55 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:71: check updates
Jul 25 15:24:56 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:101: 0 updates found
Jul 25 16:24:56 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:71: check updates
Jul 25 16:24:56 linux-qz0r pamac-tray-plas[1838]: updates_checker.vala:101: 0 updates found

Ok, it is running so it must be hidden somehow.

In System Tray Settings → Entries (click on “Configure System Tray…” in the top-right of the Status and Notifications panel) are Settings Manager, News, and Package Manager all set to “Shown when relevant”?

Also on that page try ticking “Always show all entries” → Apply and see if they appear.

That’s the thing: The icon is nowhere to be found even in the system tray settings. This is everything I have listed within that menu:

Post output of cat ~/.config/plasma-org.kde.plasma.desktop-appletsrc | grep extraItems


I only have one extraItems line.

Try backing up and then deleting that file. Then logout/login. Doing that will reset your desktop layout. If the notifier icons then all appear correctly you can either;

  • Keep the new file and setup your desktop again (if you haven’t made many changes)
  • Copy the new file somewhere, put the old one back, and then try to work out by diffing the files which part is causing the icons to be hidden.

Oh: I’m familiar with messing around with ~/.config/plasma-org.kde.plasma.desktop-appletsrc just didn’t think to look there in this case. No need to log out I just use pkill plasmashell;kstart5 plasmashell to do a restart of Plasma. The issue persists even if I move that file to get a fresh desktop configuration, looked in the tray settings too and the icon isn’t listed there even then. I’m very curious what bug this will turn out to be as it equally baffles me.

I’m out of ideas then. Could try creating a new user and see if it works there, which would at least confirm if it’s a user configuration or a system problem.

What I can say so far is that it’s definitely related to an update induced bug. I just pulled out my laptop which I haven’t updated in a few months: Boot it up on the latest Manjaro / Plasma packages of the time, I see the icon just fine. I do sudo pacman -Syu to update everything including the kernels then restart. Now the Pamac and Firewall icons are both gone from the system tray on it as well.

Reminder: I’m on the Wayland session of Plasma not X11. Could this have something to do with it? If anyone else uses KDE over Wayland can you confirm my problem?

Did you try this yet?
Because what you describe could easily be configuration related.
A new user would help rule out user configurations such as theme, widgets, etc.

Just tried with a new user: Restarted, logged in on it, same problem… even when logging in as root the icons are missing. In all cases I also checked the system tray settings to ensure the icon isn’t hidden there, it’s not listed at all. This is clearly broken in Manjaro by an update.

I also logged in on X11 Plasma after a restart: No effect and the issue persists, it isn’t Wayland specific either and also occurs on X session. I now get it on two devices independently including a laptop I update rarely on which I could see the distro update introducing this problem.

Possibly, but for most Manjaro KDE Plasma users, including myself, it is not broken. Otherwise there would be a lot more posts here about it.

I noticed in the original screenshot that you have some theme applied which is why I suggested to to try a new user. Themes can sometimes cause problems with KDE updates. But if it’s the same on a new user with clean default KDE settings then I have no idea what is wrong, sorry.

It’s okay. But I hope someone can think of anything else I can try. I’ll be waiting for more suggestions.

Something worth mentioning: On my mother’s desktop instead, which also has Manjaro running on Plasma Wayland session, it does not occur even on the latest Manjaro packages. I have no idea what I could possibly be doing different there! Could some package I have installed only on my own desktop and laptop be interfering? Only thing I can think of but I cannot begin to imagine what it may be.

I am so confused: Due to an unrelated issue I tried to kill kwin_wayland which broke my session so I had to preform a restart. After that I now have all the missing icons back in the system tray on my desktop, which seems to stick even after a second normal restart! I tried to reproduce the solution on my laptop in various forms, but on it this will not work and the icons remain missing.

Only other thing I did was uninstalling the packages wayvnc neatvnc aml (the second two being dependencies of the first) before the restart: I installed and removed them on my laptop as well but that didn’t bring the icons back either in its case.

Please just install plasma-pa.
I had the same problem here for many months…