Pamac gui software center - reset to "factory defaults"

Trying to fix some problems with pamac it seems I made them worse. I had some error messages (when refreshing databases) regarding missing or invalid pgp keys, when they went away the new error message is

unexpected system error
Failed to synchronize databases

I had an idea that reinstalling would be of help, so I did sudo pacman -R pamac-manager which resulted in:

  1. the error message persists,
  2. software icons are now missing in pamac’s listing

Now I’d like to reset pamac to “factory defaults” (the way it’s set up after a fresh install of Manjaro).
What is the correct way of achieving this?

There is no pamac-manager in the repos.
Your command should have had no effect.

??? I must have hallucinated. I can find sudo pacman -R pamac too in my command history, though. So at least I think I reinstalled it…

My question remains, however: how to properly reset pamac to “factory defaults”?

These are the available packages in full:


(you wouldnt necessarily have all of those … but thats whats in the mirrors)

Anyhoo heres what should probably remove all the things, including your configuration in HOME…

sudo pacman -Rns libpamac pamac-cli pamac-gtk 
rm -r ~/.config/pamac
sudo pacman -Syu pamac-gtk


checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libpamac breaks dependency 'libpamac' required by libpamac-flatpak-plugin
:: removing libpamac breaks dependency 'libpamac>=11' required by manjaro-application-utility
:: removing pamac-cli breaks dependency 'pamac-cli' required by manjaro-application-utility
:: removing pamac-gtk breaks dependency 'pamac-gtk' required by manjaro-application-utility
:: removing pamac-gtk breaks dependency 'pamac-gtk' required by pamac-tray-icon-plasma
:: removing libpamac breaks dependency 'libpamac' required by python-manjaro-sdk

I’m worried I’d get into a long list of manual removals and installs, so I tried removing just the config file first rm -r ~/.config/pamac, and after restarting I’m back to my initial error:

invalid or corrupted database (PGP signature)

I’ll see if this guide helps and report back here.

Thanks a lot for your help!

The extra dependencies to include are self-explanatory.
But sure, it may be you were just after the config directory.

There is no pamac-manager in the repos

File /usr/bin/pamac-manager is provided by pamac-gtk (or pamac-gtk3) to launch Pamac GUI

I ran that script 3 times now, but each time it just hangs after the following lines:

gpg: error retrieving '' via WKD: No data
gpg: error reading key: No data
gpg: refreshing 1 key from hkps://
gpg: key 279E7CF5D8D56EC8: "Manjaro Build Server <>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

The script warns “it may take time”, but being stuck for hours seems a bit too much. Any suggestions?

Hello @al_F :wink:

Hijacking other topics is against the forum rules. Please avoid it in the future. I moved your post to this thread because it has the common topic.

Refreshing keys from a Key-Server may take time and can stuck due to the server load. It can just reject or throttle your request. It is purely optional, not entirely necessary, as I wrote :wink: you can just say no and skip the step. Try the aggressive method :wink:

Sorry about that, I thought since I was trying to achieve something a bit different from the thread title here it was more appropriate to ask about that script in that other thread. No intention of hijacking! Thanks for moving my post.

That finished in a reasonable time, thanks! And after rm -r ~/.config/pamac and starting again, software icons are back and refreshing databases from the pamac gui returns the “good old”

unexpected system error

So I went back to this “recipe”:

Completely removed pamac and reinstalled. The unexpected system error persists.

Being rather convinced pamac is now at “factory default”, should I open a new thread for the system error, or continue investigating the issue here?

Maybe try it on the terminal and possibly there you get better hint of the problem:

pamac upgrade --force-refresh

Why do I keep forgetting that always return more info?

Warning: multilib.files: lock file missing /var/tmp/pamac/dbs/db.lck
unexpected system error

How is the lock file supposed to look?

Edit: my system doesn’t seem to contain any file at all with the extension .lck

I get the same warning, no idea what that acually means here. False positive? But the unexpected system error seems not to be related to that.

Is your system updated? Is pamac installed from the official repo?

A `.lck is created during database updates. It should prevent that another program, or the same, write in parallel into it.

1 Like

The system is up to date, with one exception: I held sane to version 1.1.1-2 because the newer version broke scanning from my HP AiO. But of course there are many tweaks.

I do use AUR for some packages, trying to follow this advice. The script probably was updated after I copied it.

Also, I did some adjustments for audio, following a guide from the user “ElizabethHarmon” (the link is now dead, I find).

Others have noticed something similar, possibly related to owner and permission problems with certain files and directories.

As in the above thread, you could run the following commands to check if there are any unexpected owners and/or permissions.

ls -ld /var{,/tmp{,/pamac{,/dbs{,/sync}}}}
ls -lh /var/tmp/pamac/dbs/sync
1 Like

Interesting thread which seems to be the same problem. I’m not sure which ownership / permission those files are supposed to have?

After removing and reinstalling pamac (albeit not touching any files in /var), ls -ld /var{,/tmp{,/pamac{,/dbs{,/sync}}}} returned

drwxr-xr-x 12 root root 4096 juli  27 11:26 /var
drwxrwxrwt 10 root root 4096 juli  27 19:41 /var/tmp
drwxrwxrwx  4 user user 4096 juli  27 12:48 /var/tmp/pamac
drwxrwxrwx  3 root root 4096 juli  27 22:26 /var/tmp/pamac/dbs
drwxrwxrwx  2 root root 4096 juli  27 22:26 /var/tmp/pamac/dbs/sync

Like in the other thread I tried to set me as owner (sudo chown -R user:user /var/tmp/pamac/dbs), but running pamac upgrade --force-refresh reverts ownership to root. It shouldn’t matter, though, since the permissions are “access for all” (drwxrwxrwx)?

But the upgrade does return errors:

Synchronizing package databases...
Refreshing core.db...                                                                                                                                                                                                          
Refreshing extra.db...                                                                                                                                                                                                         
Refreshing community.db...                                                                                                                                                                                                     
Refreshing multilib.db...                                                                                                                                                                                                      
Error: multilib.db: GPGME error: No data                                                                                                                                                                                       
Error: multilib.db: GPGME error: No data
Error: multilib.db: GPGME error: No data
Error: multilib.db: GPGME error: No data
Refreshing core.files...                                                                                                                                                                                                       
Refreshing extra.files...                                                                                                                                                                                                      
Refreshing community.files...                                                                                                                                                                                                  
Refreshing multilib.files...                                                                                                                                                                                                   
Error: multilib.files: GPGME error: No data                                                                                                                                                                                    
Error: multilib.files: GPGME error: No data
Error: multilib.files: GPGME error: No data
Error: multilib.files: GPGME error: No data
invalid or corrupted database (PGP signature)
Warning: sane: ignoring package upgrade (1.1.1-2 => 1.2.1-4)

Seems I’ve returned to start…

Searching forums for multilib.db: GPGME error: No data led me to a guide on how to fix.

I was a bit sceptical since it talks only about pacman and not pamac but tried it anyway. Problem solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.