Pamac GUI & Pacman CLI Failed to Update and Eats All RAM

Maybe the title says it all, but here’s the chronology:

  1. Pamac notified me about 1 update available, so i tried to update it using the GUI application.
  2. The update took so long, my laptop is freezing, and i can’t operate it, so i force to shutdown my laptop and boot it up again.
  3. I tried to update it again for the second time, now Pamac says that there’s 3 updates available, the updates took so long again, and then i decided to open System Monitor and it says that Pamac using all of my RAM, and also almost half of the swap memory.
  4. I tried to update my system again, for the third time, now i’m using Pacman with pacman -Syu command.
  5. Again, it failed to update and eats all my RAM.
  6. After that i decided not to update my system for a while.
  7. Suddenly, Pamac is run on the background, and again eats all my RAM, without anything changed, it run over 3 times in certain period.

I’m currently on Linux 5.8.18-1-MANJARO x86_64 20.2 Nibia GNOME edition.

Any relevant output of the two programs you named but failed to provide anything from?

  1. Pamac GUI only show that the program is not responding, and prompt an option to wait or kill the process.
  2. Pacman CLI show something like this, and at the end it tells that there’s nothing to do.

Try to update using pacman first:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

Also, Kernel 5.8 is EOL. Consider switching to 5.9 or an LTS kernel.

1 Like

Thank! Worked flawlessly. But the Pacman CLI still says that there’s nothing to do. Using the Pamac GUI to updates and it worked as usual.

Pacman doesn’t manage external packages like AUR, and so on. It only manages the official packages provided by Manjaro.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.