Pamac-gtk ibus issue

I’m having issues with pamac-manager. When I try typing in the the search bar, every character I type is entered twice. e.g. a = ‘aa’. Oddly enough if I try searching pamac’s history, it works fine.

If I close down ibus, it works like normal. Any way to fix this issue? version 9.5.12 works perfectly fine. It only started with version 10.


Since no one else is having this problem, is it possible to continue just using version 9.5.12 and not bother updating or will it eventually stop working?

Either that or is it possible for the pamac-tray when opening up pamac-manager unset the environment variable GTK_IM_MODULE. “env --unset=GTK_IM_MODULE pamac-manager” works fine in the terminal.

same issue for me.
i use fcitx4

use pacman -S downgrade
switch to root
downgrade pamac-gtk

you need to do this for all pamac packages, use pacman -Qs pamac to get the list

Good to hear I’m not the only person having this issue. Hopefully it’s an actual bug and can be fixed soon.

I’ve already downloaded the packages and downgraded manually, as well as placed the packages in the ignorepkg list. I’m perfectly happy to stay on 9.5.12, but simply worried that it may stop working for some reason, e.g. if it needs signatures or something to be routinely updated, etc.

Please open an issue here as our developers most likely don’t read the forums.

Just realized that I was using xim for GTK_IM_MODULE due to firejail previously not working with ibus. setting it to ibus makes it work.