Pamac fails to synchronise due unacceptable TLS certificate

I had that the other day on stable, I solved it by running sudo pacman -Syyu and then pamac upgrade -a

This specific error is only an issue when you have the option for checking AUR script updates in Pamac.

It does not matter what your branch is - the aur database is the same.

Avoid the issue all-together by disabling the Pamac AUR check

image

It is well known that combining the system update with an AUR rebuild may and likely will cause serious headaches. Just search the forum - there is countless issues on this.

Use a helper script like [root tip] [HowTo] Check if your AUR build scripts have been updated

The intro to that post has had me confused for a long time, I’m not a programmer, I only know what I have learned through my way, but I interpret this as if you are on stable branch you should never use aur. Or am I missing something here??

if [[ $(pacman-mirrors -G) == 'stable' ]]; then echo 'AUR is a no-go'; else echo 'OK - go ahead'; fi

AUR is package recipies - in fact they are shell scripts with certain assumptions with relation to the system on which the recipe is executed.

And it is well known that Manjaro stable does not match Arch stable - which is why the recommendation from many experienced members is this:

If you want to use AUR switch to unstable branch - otherwise watchout - there be :dragon_face: :dragon_face: :dragon_face:

If you want to sail around Tierra del Fuego - in a manner of speaking - unstable branch is the only fit for using AUR.

2 Likes

LMAO! <3

I don’t know if this will work for everyone, but I had exactly the same issue:

$ pamac upgrade
Preparing...
Synchronizing package databases...
https://aur.manjaro.org/packages-meta-ext-v1.json.gz: Unacceptable TLS certificate
Failed to synchronize AUR database

and updating all the keys fixed it:

$ sudo pacman-key --init
$ sudo pacman-key --populate archlinux manjaro
$ sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring
$ sudo pacman-key --refresh-keys
$ sudo pacman -Syu

No, that’s wrong and was a coincidence. There is no connection between pacman and the AUR.

it’s a random error (depends on the server’s availability)

as a test, I made a script that uses the same library as pamac and sometimes errors, sometimes ok :sob:
For me, out of 10 attempts, it’s okay 7 to 8 times.

1 Like

The error https://aur.manjaro.org/packages-meta-ext-v1.json.gz: Unacceptable TLS certificate happened to me today 06-25-23 and I could fix it by running sudo pacman -S ca-certificates as you suggested.

Thank you for your help!

That’s not a solution, it’s a coincidence.

The error is server-side. Can we delete these false solutions?

1 Like

Ever heard of the placebo effect?

After that incident, where that link comes from, I started using the scipt suggested earlier (link below) instead, and it works. Got informed by it the other day that Spotify needed to be updated so I ran:

pamac upgrade && pamac build $(check-aur.sh)

I only run pamac upgrade now. or sudo pacman -Syu unless informed by the script.
Pretty great and no more weird pamac errors.

Yes, you’re right, it was just a coincidence :sob:
Sorry!

I got TLS error today with pamac -aur. I used yay to rebuild as per instructions in the other 2 similar topics.

yay -Sua

Each time I use Pamac I get:

https://aur.manjaro.org/packages-meta-ext-v1.json.gz: Unacceptable TLS certificate

Is using the search engine THAT hard? There are 39 topics about that problem. At least 2-3 of them give workaround. Including this one, with solution directly above your post.
Turn off aur updates in pamac, update from repos normally. Install yay. Use the linus-arhus shell script or just

yay -Quaq

To check for aur updates. If there are any, update with

yay -Sua

No one will trust a random script posted by an unknown person on a discussion forum. It’s frustrating to reinstall the whole system and reconfigure it again, that’s why I only trust solutions in posts from official persons like @philm

I wouldn’t call @linux-aarhus random person :grinning: but the good thing in linux and esp. shell scripting is that anyone can check the code… Check-aur.sh only automates yay -Quaq…which you could have known if you read the tutorial.

https://forum.manjaro.org/t/root-tip-howto-check-if-your-aur-build-scripts-have-been-updated/

I would save you the next post and tell you this tutorial is only half the solution in your case, the other half is in other tutorial/how-tos. Or in my post above. Reading is your friend. Or Ubuntu or maybe Windows. That at least crashes without any explanation and there is nothing you can do except staring at the rolling circle, but you certainly don’t have to read much.

And you are quite right - you shold exercise due dilligence - do your research and validate the code for malicious intent.

:grin:

Scroll to the bottom of Manjaro Team see if you recognize my name - perhaps compare to my profile

2 Likes

I thought he was speaking about another comment, I know you are one of Manjaro team (it’s clearly mentioned beside your name) :joy_cat:

and philm is not another good source in this topic ? these gitlab comments are clear