Pamac eats all RAM

Something weird happens when pamac is ran.
pamac update caused the RAM usage go 5.3 and soon the swap converged with ram. The poor laptop was freezed so couldn’t take screenshot. Downgraded to Stable release, yet the problem persists. Currently the system is up to date with Testing repo. It probably happened a few times today. Other times the system monitor was not open so couldn’t catch the culprit.

➜  ~ inxi -SMI
System:    Host: ts Kernel: 5.8.15-2-MANJARO x86_64 bits: 64 Desktop: Xfce Distro: Manjaro Linux 
Machine:   Type: Desktop System: LENOVO product: 30CY006WGE v: ThinkStation P330 serial: <superuser/root required> 
           Mobo: LENOVO model: 314F v: SDK0T08861 WIN 3305275981957 serial: <superuser/root required> UEFI: LENOVO v: M1VKT57A 
           date: 05/27/2020 
Info:      Processes: 307 Uptime: 3h 14m Memory: 62.50 GiB used: 35.22 GiB (56.4%) Shell: Zsh inxi: 3.1.05 

Just tested - on my system pamac uses 800M when running the update process from terminal.

$ pamac update

I don’t know if this is the usual pattern as I have never had any issues.

You have not provided any information - one way of making sure it is pamac is to run htop in a separate window and filter to show only pamac process.


I did an update with pacman , got some new update and then tried pamac update and it worked fine. But yet I cannot understand such behavior because today my laptop frozen at least 5 times beyond recovery the processor overheated and there was constant hw i/o (according to led) and couldn’t even reach the tty and everything was frozen. And I could not believe my eyes when the RAM usage soared that high. Why on the earth pamac would require 10+ GiB of memory. I think the problem no longer persists.