Pamac eating all the RAM

Hi, just checking in to add that I had the same behavior after a failed pacman -Syu update.
Both PamacGUI and pamac update or pamac upgrade did freeze the machine after eating the whole RAM in 10 seconds or so.
Also, I had pamac checkupdates already fired just after the session login, so the PC started to freeze over after 4/5 seconds or so after logging in. To remove it I just went to Pamac settings ( “Add/Remove software” → “Settings” → Unticked “Check for updates”).

Here’s an image I’ve take with my phone:

As for pamac update/upgrade the process got stuck at Synchronizing package databases... : after that I terminated it before the machine froze again.

As I mentioned, this happened after a failed attempt to update. I can not replicate the error I had but I can remember multiple lines of

error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)

While this happened, pacman worked perfectly fine:

[nicola@nicola-desktop ~]$ sudo pacman -Syu
[sudo] password for nicola: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do
[nicola@nicola-desktop ~]$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                                                   150,4 KiB  1419 KiB/s 00:00 [################################################] 100%
 extra                                                    8,7 MiB  10,5 MiB/s 00:01 [################################################] 100%
 community                                               29,0   B  1705   B/s 00:00 [################################################] 100%
 multilib                                               143,9 KiB  3,80 MiB/s 00:00 [################################################] 100%
:: Starting full system upgrade...
 there is nothing to do
[nicola@nicola-desktop ~]$ 

I’m writing as past tense here because, as I’m tinkering, the problem seem to have disappeared by itself! :man_shrugging:

Hi everyone,

I’m just writing to resume and signal a problem (bug?) already signaled (I looked over the forum to post to already opened threads but I could not find one open).
The problem is that when trying to update from Pamac GUI or pamac update the process starts to eat up all the ram. Then after 30 seconds or so it goes back to normal as the pamac process crashes (I think it crashes, at least). Then again after 10 minutes the process repeats.

Here’s a photo (I had to take a picture with my phone because the os was completely stuck):

Also, while trying pamac update from terminal it stucks on Synchronizing package databases..., like this:

[nicola@nicola-desktop ~]$ pamac update
Synchronizing package databases...

(I stopped it before my machine would freeze again). While this happens with pamac, pacman seems to work fine:

[nicola@nicola-desktop ~]$ sudo pacman -Syu
[sudo] password for nicola: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

I had this behavior for the first time after a failed update: my internet connection got lost and pacman -Syu got stuck. After closing the process and running the command again I got multiple errors like this:

error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)
error: could not read db 'extra' (Damaged tar archive)

Hi @NicolaM94,

Try removing the database files:

sudo rm /var/lib/pacman/sync/extra.db
sudo rm /var/tmp/pamac/dbs/sync/extra.db

And then trying again:

sudo pacman -Sy
pamac checkupdates

Hope this helps!

1 Like

I’ll just add that these issues are possibly a result of not maintaining your system adequately. This isn’t a random comment without merit: The community repository has not existed since mid-late 2023 (several months) – and yet, it hasn’t been removed from your configuration.

It’s a simple fix (a manual edit), but that’s not the point. It indicates a broader problem with not observing the manual intervention notes as they appear in the Stable Update Announcements - and there have been many in recent months; especially .pacnew file instances that should have been merged (by you) with respective configuration files in your system.

Please see Check and manage pacnew files for a brief introduction to these needed modifications, and perform some additional research when possible.

This is important. Cheers.


I really thank you for your suggestion. I apologize if my system may look not well maintained, but I never had the chance to dive deep into this kind of concepts. So when a problem comes up, like the one you are raising above, I may not even have recognized it as a problem, considering that the system still worked perfectly until yesterday.

Anyway, I’ll make sure to pay more attention in the future and read along the sources you linked asap.
Thank you again for letting me notice this!

Attention is one thing; more important is to forge a regular habit of checking for issues. Manjaro is a rolling release and as such we are expected to monitor the status of updates as they are announced. When each update is ready (usually two or three per month) the Update Announcement is released.

A good recommendation is to wait a few days (or a week) when this happens and see what problems (and fixes) are discovered and listed under the announcement. This gives a certain advantage, rather than blindly running sudo pacman -Syu with your fingers crossed; at the mercy of dumb luck. :wink:

Not everyone has the aptitude, the time or the patience to maintain Linux on a rolling release cycle; as all Arch based distributions are. Manjaro is a great OS, but you really must take care of it. For those who prefer less frequent updates and generally more stability, for longer periods of time, we often recommend moving to a distribution with a point based release cycle.

Don’t let this deter you, though;
Manjaro just takes some determination.


1 Like

Theres nothing blind or lucky about it.
You passed specific arguments to a specific tool that should commit certain actions.
Once entered you will then be asked for admin password and presented with the proposed changes.

You would have to be literally physically blind for this to ‘blind’.

Also of note is that this advice of ‘waiting’, intentionally or otherwise, skirts the issue of security.

We have a pretty salient example from yesterday with xz.
Depending on the current sync status of a system, following said advice could result in a prolonged period of vulnerability.

No there isn’t. Except if you don’t know what the commands do or will do. As I can personally testify.

However, I think @soundofthunder meant was to trust the effects of it to luck. Hoping nothing goes wrong, instead of being proactive against things.

Some people do seem to consistently struggle with nuances of forum commentary. However, @Mirdarthos has again captured the essence of the intended meaning, through interpretation; and I therefore award him the unofficial be-bop emoji. :saxophone:

Blindly performing an update without having made certain there are no outstanding issues that might prevent its completion, is not recommended.

Without taking that ounce of prevention into consideration before an upgrade, error-free completion can only be attributed to dumb luck.

If you want to fundamentally change some meanings, and include self-defeating statements, I guess I will accept that as the intention of your statement.

Still … in this example, at best we have then equating ‘waiting’ with being ‘not blind’.

Which, I would hope is self-evident enough, but in case it is not … how does an otherwise ignorant user who cant/wont inspect or understand the package changes become any more informed simply by waiting a few days?

Ah well … semantics again maybe?

I would suggest folks become familiar enough with the system they are administering to not be blind.

… waiting a few days …

Context is important. :slight_smile:

Right, so, the ‘not blind’ user is someone who is continually ignorant but waits a few days seeing what bubbles in the release announcement?

I think I disagree. And its rather poor advice in the context of, for example, critical security patches.

But alas maybe there is nuance again and of course I should have understood that waiting a few days in fact does not mean waiting a few days if there are security concerns … beep boop, none of this is any longer pertinent to the thread either.


I’m trying to resolve a system instability. Whenever pamac checkupdates runs, it quickly uses all of my RAM and swap and then the whole Manjaro operating system freezes and has to be hard reset at the desktop.

I’ve recently become aware of the closing of the community repository through stable update 2023-07-10 which needs to be addressed.

And I’ve tried the command line fixes from the second post of the following forum post with no fixing it.

running pamac checkupdates results in more errors than I can show.

How do I fix this?

$ inxi -v8azy
  Kernel: 6.8.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.8-x86_64
    root=UUID=7361f228-1102-406f-93c9-8c30f3d4372e rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3 nvidia_drm.modeset=1
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: light-locker vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: Z170-A v: Rev 1.xx
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI-[Legacy]: American Megatrends v: 3802 date: 03/15/2018
  Message: No system battery data found. Is one present?
  System RAM: total: 16 GiB available: 15.56 GiB used: 3.36 GiB (21.6%)
  Message: For most reliable report, use superuser + dmidecode.
  Array-1: capacity: 64 GiB slots: 4 modules: 2 EC: None
    max-module-size: 16 GiB note: est.
  Device-1: ChannelA-DIMM1 type: DDR4 detail: synchronous size: 8 GiB
    speed: 2667 MT/s volts: curr: 1 width (bits): data: 64 total: 64
    manufacturer: Kingston part-no: KHX2666C15D4/8G serial: <filter>
  Device-2: ChannelA-DIMM2 type: no module installed
  Device-3: ChannelB-DIMM1 type: DDR4 detail: synchronous size: 8 GiB
    speed: 2667 MT/s volts: curr: 1 width (bits): data: 64 total: 64
    manufacturer: Kingston part-no: KHX2666C15D4/8G serial: <filter>
  Device-4: ChannelB-DIMM2 type: no module installed
PCI Slots:
  Permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x5E (94) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 800 min/max: 800/4200 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 64026
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr
    mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge
    pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep
    smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic
    xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: gather_data_sampling status: Vulnerable: No microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS; IBPB: conditional; STIBP: conditional;
    RSB filling; PBRSB-eIBRS: Not affected; BHI: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ASUSTeK driver: nvidia
    v: 550.67 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
    (as of 2024-04; EOL~2026-12-xx) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-2019 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: none off: DVI-I-1 empty: DP-1,DVI-D-1,HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 10de:13c2 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.12 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia,nvidia-nvswitch display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: DVI-I-1 note: disabled model: Asus PB278 serial: <filter>
    built: 2015 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2 chroma: red: x: 0.667
    y: 0.329 green: x: 0.310 y: 0.631 blue: x: 0.149 y: 0.039 white: x: 0.314
    y: 0.329 size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9
    modes: 2560x1440, 1920x1080, 1680x1050, 1280x1024, 1440x900, 1280x960,
    1280x800, 1152x864, 1280x720, 1024x768, 800x600, 640x480
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.67 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GTX 970/PCIe/SSE2
    memory: 3.91 GiB
  API: Vulkan v: 1.3.279 layers: 5 device: 0 type: discrete-gpu
    name: NVIDIA GeForce GTX 970 driver: nvidia v: 550.67 device-ID: 10de:13c2
    surfaces: xcb,xlib
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:a170 class-ID: 0403
  Device-2: NVIDIA GM204 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
  API: ALSA v: k6.8.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: off tools: pw-cli
  Server-3: PulseAudio v: 17.0 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl,pavucontrol
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 06:00.0
    chip-ID: 168c:002e class-ID: 0280
  IF: wlp6s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 3.64 TiB used: 723.23 GiB (19.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Sabrent model: Rocket Q
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: RKT30Q.1 temp: 25.9 C
    scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1ER164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC25 scheme: MBR
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH24NSC0 rev: LK00
    dev-links: cdrom
  Features: speed: 12 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 723.23 GiB (39.5%)
    fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 7361f228-1102-406f-93c9-8c30f3d4372e
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 4 GiB used: 92.5 MiB (2.3%) priority: -2
    file: /swapfile
  ID-1: /dev/sda1 maj-min: 8:1 size: 1.82 TiB fs: ntfs label: MM-storage
    uuid: 7DC123C74498A0AD
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-9:2 info: ASUSTek ROG GLADIUS III type: HID,mouse
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 100mA chip-ID: 0b05:197b class-ID: 0300
  Device-2: 1-10:3 info: HP HyperX Alloy Core RGB type: keyboard,HID
    driver: hid-generic,usbhid interfaces: 4 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 500mA chip-ID: 03f0:0391 class-ID: 0300
  Hub-2: 2-0:1 info: super-speed hub ports: 10 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-4: 4-0:1 info: super-speed hub ports: 2 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 22.0 C mobo: N/A gpu: nvidia temp: 53 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 9%
  Packages: 1401 pm: pacman pkgs: 1393 libs: 490 tools: pamac pm: flatpak
    pkgs: 8
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
  CPU top: 5 of 264
  1: cpu: 16.3% command: firefox pid: 1652 mem: 621.6 MiB (3.9%)
  2: cpu: 6.9% command: xfce4-terminal pid: 4352 mem: 56.0 MiB (0.3%)
  3: cpu: 6.6% command: Xorg pid: 851 mem: 78.6 MiB (0.4%)
  4: cpu: 5.5% command: firefox pid: 2026 mem: 486.8 MiB (3.0%)
  5: cpu: 4.1% command: xfce4-taskmanager pid: 1958 mem: 46.8 MiB (0.2%)
  Memory top: 5 of 264
  1: mem: 621.6 MiB (3.9%) command: firefox pid: 1652 cpu: 16.3%
  2: mem: 568.5 MiB (3.5%) command: thunderbird pid: 1512 cpu: 0.7%
  3: mem: 486.8 MiB (3.0%) command: firefox pid: 2026 cpu: 5.5%
  4: mem: 282.5 MiB (1.7%) command: firefox pid: 1896 cpu: 1.4%
  5: mem: 228.2 MiB (1.4%) command: firefox pid: 2022 cpu: 1.5%
  Processes: 264 Power: uptime: 27m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.21 GiB services: upowerd,xfce4-power-manager
    Init: systemd v: 255 default: graphical tool: systemctl
  Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.26
    running-in: xfce4-terminal inxi: 3.3.34

Moderator edit: Removed useless photo

pamac clean -b 
sudo pacman -Scc
sudo pacman-mirrors -f && sudo pacman -Syu
pamac update --force-refresh