Pamac downgrade due to libcurl-openssl-1.0?

Just tried to update my XFCE stable branch, but i get the message pamac has to be downgrade because of libcurl-openssl-1.0. that should be updated.

What should i do?

Downgrade and then try to upgrade pamac … is that possible?

Please post the terminal output you may have on your update process.

[manjaro cron.hourly]# pamac update
Warnung: Erstelle Pakete als Root
Warnung: Konfiguriere Build-Verzeichnis /var/cache/pamac
Überprüfe libcurl-openssl-1.0 Abhängigkeiten...
Synchronisiere Paketdatenbanken...
Warnung: pamac-cli: Downgrade von Version 10.1.2-0.1 zu Version 10.0.6-2
Warnung: pamac-common: Downgrade von Version 10.1.2-0.1 zu Version 10.0.6-2
Warnung: pamac-gtk: Downgrade von Version 10.1.2-0.1 zu Version 10.0.6-2
Warnung: libcurl-openssl-1.0-7.76.0-1 ist aktuell -- Reinstalliere
Abhängigkeiten werden aufgelöst...
Interne Konflikte werden überprüft...

Zu erstellen (1):
  libcurl-openssl-1.0  7.76.0-1                AUR
Wird zurückgestuft (3):
  pamac-common         10.0.6-2  (10.1.2-0.1)  extra  2,0 MB
  pamac-cli            10.0.6-2  (10.1.2-0.1)  extra  328,7 kB
  pamac-gtk            10.0.6-2  (10.1.2-0.1)  extra  770,9 kB

Download-Größe gesamt: 3,1 MB
Gesamtgröße installiert: -156,5 kB

Build-Dateien bearbeiten : [e] 
Transaktion anwenden ? [e/j/N]

``[manjaro cron.hourly]# inxi -F
System:    Host: manjaro Kernel: 5.10.34-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.16.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81RS v: Lenovo Yoga S740-14IIL serial: PF1WPMZJ 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: PF1WPMZJ UEFI: LENOVO v: BYCN35WW date: 05/19/2020 
Battery:   ID-1: BAT0 charge: 61.7 Wh (94.5%) condition: 65.3/62.0 Wh (105.3%) 
CPU:       Info: Quad Core model: Intel Core i7-1065G7 bits: 64 type: MT MCP cache: L2: 8 MiB 
           Speed: 1237 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 1237 2: 1201 3: 1200 4: 1200 5: 1201 6: 1201 7: 1201 
           8: 1201 
Graphics:  Device-1: Intel Iris Plus Graphics G7 driver: i915 v: kernel 
           Device-2: NVIDIA GP108M [GeForce MX250] driver: nvidia v: 460.73.01 
           Device-3: Chicony Integrated Camera type: USB driver: uvcvideo 
           Display: server: X.Org 1.20.11 driver: loaded: modesetting,nvidia unloaded: intel,nouveau resolution: 
           1: 1920x1080~60Hz 2: 1920x1080~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Smart Sound Audio driver: sof-audio-pci 
           Sound Server-1: ALSA v: k5.10.34-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
Network:   Device-1: Intel Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter driver: iwlwifi 
           IF: wlp0s20f3 state: up mac: 04:33:c2:02:de:51 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
           IF: enp0s13f0u1u4 state: up speed: 1000 Mbps duplex: full mac: 4c:e1:73:42:1f:6b 
           IF-ID-1: pan1 state: down mac: ae:70:cd:8d:12:df 
Bluetooth: Device-1: Intel type: USB driver: btusb 
           Report: rfkill ID: hci0 state: up address: see --recommends 
Drives:    Local Storage: total: 1.86 TiB used: 413.08 GiB (21.7%) 
           ID-1: /dev/nvme0n1 vendor: Micron model: MTFDHBA1T0TCK size: 953.87 GiB 
           ID-2: /dev/sda type: USB vendor: Western Digital model: WD10EARX-00N0YB0 size: 931.51 GiB 
           ID-3: /dev/sdb type: USB vendor: Kingston model: DataTraveler 2.0 size: 14.54 GiB 
Partition: ID-1: / size: 57.9 GiB used: 34.45 GiB (59.5%) fs: ext4 dev: /dev/nvme0n1p8 
           ID-2: /boot/efi size: 259.5 MiB used: 86.6 MiB (33.4%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 16.67 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p9 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 259 Uptime: 2h 01m Memory: 15.2 GiB used: 1.72 GiB (11.3%) Shell: Bash inxi: 3.3.04 


The update of the libcurl-openssl-1.0 AUR package has nothing to do with the downgrade of pamac-* packages - these just happened at the same update/moment.

Btw, you shoud heed this warning

and not build AUR packages as root.


A) I was logged in in root-terminal just to copy the messages from pamac philm asked me for.

B) I could have checked dependencies of pamac to see that this library is NOT the reason to downgrade pamac … tricky :slight_smile:

C) Did the pamac downgrade … seems to have worked so far.

D) Thanks!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.