Pamac Demon is inactive

Pamac Demon is loaded but inactive at startup, does this mean that ‘Update the system at shutdown’ will not work? Perhaps if updates arrive?

Surely the pamac-daemon service should be inactive until it’s time to update…

pamac-daemon.service - Pamac Daemon
     Loaded: loaded (/usr/lib/systemd/system/pamac-daemon.service; static)
     Active: inactive (dead)

So do you think it only starts if updates arrive?
Have to wait for an update to see if its started
For your info opening and closing pamac from the system tray icon starts the daemon

I can’t open Pamac from the system tray icon because it’s hidden until it’s relevant.

It appears when there are updates automatically (I set it to check updates daily).

unhide it then and try you can always re hide it after.

No need - it always appears when it’s got updates, I don’t need it there to activate pamac.
2023-11-25 18:56:43

It will activate and check every 6 hours.

It appears only if there are updates, then I open terminal and do updates.

If you set it to ‘Upgrade the system at shutdown’ then I guess it’ll delay the shutdown - I didn’t choose that because I like to supervise them.

That works and its quick but not sure if it starts the damon or that’s started by the updates?

Systemd will manage the timing.


I don’t use update on shutdown so I do not know how or if it functions
but it should be enabled in pamac-offline-upgrade.service

$ systemctl status pamac-offline-upgrade.service
○ pamac-offline-upgrade.service - Offline System Upgrade using Pamac
     Loaded: loaded (/usr/lib/systemd/system/pamac-offline-upgrade.service; enabled; preset: disabled)
     Active: inactive (dead)

to check the service configuration

cat /usr/lib/systemd/system/pamac-offline-upgrade.service

pamac-daemon.service has nothing to do with running updates at shutdown. It is a way for pamac to connect to dbus. It is loaded into memory and simply waits for pamac-related events.

pamac-offline-upgrade.service is what takes care of updating the system on shutdown — or at least, if enabled.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.

systemctl status pamac-offline-upgrade.service

has this

To make things a bit more robust we recommend hooking the update script into via a .wants/ symlink in the distribution package, rather than depending on systemctl enable in the postinst scriptlets of your package. More specifically, for your update script create a .service file, without [Install] section, and then add a symlink like /usr/lib/systemd/system/ → …/foobar.service to your package.

Make sure to remove the /system-update and /etc/system-update symlinks as early as possible in the update script to avoid reboot loops in case the update fails.

Use FailureAction=reboot in the service file for your update script to ensure that a reboot is automatically triggered if the update fails. FailureAction= makes sure that the specified unit is activated if your script exits uncleanly (by non-zero error code, or signal/coredump). If your script succeeds you should trigger the reboot in your own code, for example by invoking logind’s Reboot() call or calling systemctl reboot. See org.freedesktop.login1(5) for details about the logind D-Bus API.

The update service should declare DefaultDependencies=no,,,, and explicitly pull in any other services it requires.

It may be desirable to always run an auxiliary unit when booting into offline-updates mode, which itself does not install updates. To do this create a .service file with and and add a symlink to that file under /usr/lib/systemd/ .

Could someone tell me if this is needed and if so what does it mean?
The only reason I ask is on a restart for updates the service sometimes crashes and no updates are installed.