Pamac can't install AUR packages

It is for a while that pamac can’t install AUR packages. I can search and find them but when I try to build, I get this message for gruvbox-material-gtk-theme-git for example:

Checking gruvbox-material-gtk-theme-git dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building gruvbox-material-theme-git...
Cloning gruvbox-material-theme-git build files...
Failed to build gruvbox-material-theme-git

I can use terminal and git command to clone and build AUR packages.

Welcome here, @oktay_y2003,

Have you enabled AUR support?

1 Like

Hi. Yes! It is enabled. It was working fine, after some updates I think this happened.

Maybe you are affected by what is mentioned here:

I tried installing some AUR packages using pamac terminal command. It woked fine! Then I tried pamac GUI and it worked! Everything is ok for now!

I’m not even able to find this ‘Preferences’ image (see above) any longer (showing General. AUR tab etc.) What has gone wrong? Do I need to re-install Manjaro … again? I’m finding Manjaro becoming more and more frustrating to the point I’m about to give up on it.

Pamac UI was updated in the last update. AUR option is still in the settings but maybe the window is a little different.

In the main Pamac window, click on the “hamburger” menu (the 3 lines) and select preferences. After you provide your credentials, a new window opens with some tabs. One of the tabs is “Third party”. There you can enable AUR.

You can also enable AUR editing the file /etc/pamac.conf. There, uncomment (remove the #) from the EnableAUR line.

PS: There is hardly any case where is necessary to reinstall the whole system. You have to mess up real bad the system for that. This applies probably for the majority of Linux distros.