pamac AUR error "can't lock database"

today pamac tried to update spotify (AUR) but it stopped with error message "can't lock database" -> german: kann datenbank nicht sperren"

So i opened a
terminal and:

rm /var/lib/pacman/db.lck

yay -S spotify

No probs!!!

That happened often last weeks!

So i think something gone wrong with new pamac?!!

May PC:
System: Host: manjaro Kernel: 5.2.1-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.13.5 Distro: Manjaro Linux
Machine: Type: Desktop System: LENOVO product: 90FB006AGE v: ideacentre 710-25ISH serial:
Mobo: LENOVO model: 3642 v: SDK0J40700 WIN 3258069255609 serial: UEFI: LENOVO v: FWKT95A
date: 09/04/2018
CPU: Topology: Quad Core model: Intel Core i5-6400 bits: 64 type: MCP L2 cache: 6144 KiB
Speed: 800 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
Graphics: Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 430.26
Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26
Audio: Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.2.1-1-MANJARO
Network: Device-1: Intel Ethernet I219-LM driver: e1000e
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 4c:cc:6a:a3:3b:dd
Device-2: Intel Wireless 8260 driver: iwlwifi
IF: wlp2s0 state: down mac: f6:e8:29:12:a8:0e
IF-ID-1: pan1 state: down mac: 3a:8d:de:74:07:4c
Drives: Local Storage: total: 3.18 TiB used: 417.30 GiB (12.8%)
ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
ID-2: /dev/sdb vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB
ID-3: /dev/sdd type: USB vendor: Western Digital model: WD10EARX-00N0YB0 size: 931.51 GiB
Partition: ID-1: / size: 57.90 GiB used: 27.87 GiB (48.1%) fs: ext4 dev: /dev/sda8
ID-2: swap-1 size: 16.67 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda9
Sensors: System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 37 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 29%
Info: Processes: 222 Uptime: 12h 40m Memory: 15.61 GiB used: 2.08 GiB (13.3%) Shell: bash inxi: 3.0.34

pamac log:

.. true to error there are no lines regarding spotify from today??!!

.. and pamac still shows it want to update spotify, even if i update databeses!

Looks like a bug.
Seems the Devs are aware.

You can put an Issue in here.


May be a valid workaround for now


... done


my solution:

change build directory to ~/tmp

Set rights to rw for EVERYBODY

Remove existing spotify, reinstall spotify ... that worked :slight_smile:

Pamac is a show-stopper now??!!

Thanks for your tipp!!

I really hate this modern Web-design: light grey font on wite background ... I DON'T see anything ... but thats modern look, AGGRR :frowning:

Dark Reader is the answer.
Also, you can change the theme here.... somewhere. Preferences perhaps? Not sure, I just use Dark Reader. :slight_smile:


Thanks, but i still hate this modern ■■■■ :slight_smile:

And i hate that " s h i t " is overwritten, are we amricans that allways say peep instead of SCHEISSSSE!!!

Perhaps you like to look at completely black screens with white texts on which it is hard to see any text at all, I like my screens light with black text. As long as we can change the theme all is well. Don't immediately complain when things are not as you want them to be. There is always a reason for it. We have choice, a lot of choice, sometimes maybe even too much choice. Change it to what you like and be happy with it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by