Pamac 11.0.1-2 - refresh databases throws error but using pacman is fine

I was trying to do an update and pamac kept throwing an error about an unavailable package. So I assumed the databases may need to be updated. So I did that “refresh databases” and it seems to be doing that fine but at the end it reports a “failed to synchronize databases” error.

So I punted and did sudo pacman -Syu and the databases sync’d and that packages needed updating were and all seemed fine. Restarting pamac it reported no packages to update (which is should). But now “refresh databases” always throws that error. I went into the settings and tried “refresh mirrors” but the error persists.

Does pamac not use the same pacman-mirrors as pacman?

This is a newish error. Must have started after a recent update of pamac (now I am at 11.0.2-2.)

Not the end of the world at this point as I can always use pacman but it’s looking like if databases get stale pamac is not able to sync them before doing an update and eventually some package won’t be found (like was my case).


pacman-mirrors is a Manjaro utility to maintain the mirrorlist.

pamac uses the same mirrorlist but not the same metadata (database)

But pamac is - kind of - dysfunctional right now - please search the forum - the viable alternative is to use pacman - and for your aur scripts use yay or paru.

I had the same issue, I can’t say this will help, but I completely disabled the AUR, refreshed the databases and re-enabled the AUR, error went away.

This is assuming you have the AUR on.

You could try the terminal:

Update your mirrors, just in case you’re using an outdated one:

sudo pacman-mirrors --geoip

Then, use pamac to update:

pamac update --force-refresh

And then paste the error here if have one.

1 Like

doing the cli pamac update worked.

Then launching the pamac UI the error is gone and manual refresh doesn’t throw the error either. Since it keeps it’s own database maybe it got corrupted and the force refresh fixed it (which isn’t available in the UI). Thx @mithrial

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.