PAM issue: ~/.pam_environment not being read on login

I just updated Manjaro a few days ago, and suddenly my ~/.pam_environment file is not being read on login. The environment variables set in it are not seen in bash, or using gvim :echo.

It seems that pam_env.so is required in both /etc/pam.d/system-login, as well as several others. system-login is included from /etc/pam.d/kde, if that’s what’s used on GUI login.

Not sure why this is suddenly not enabled.

https://bbs.archlinux.org/viewtopic.php?id=278651

2 Likes

Not really sudden, as it has been known to will happen for a while, but this was just the update that actually removed the functionality.

Thank you very much! Unfortunately I have no idea where to look for such information, so it was definitely sudden to me.

I followed the instructions at that link, and they did not work.

I added a file ~/.config/environment.d/path.conf with the sole contents PATH=$PATH:~/.local/bin, and restarted my laptop, logged in, and PATH did not include ~/.local/bin. Clearly I’m missing something somewhere. Where is the thing I’m missing?

This is setting systemd user env vars - it should work for systemd user units.

systemctl --user show-environment

For shells you’ll have to use some other means, eg. .bash_profile or .zprofile or any of other 3000 files I don’t remember. :smiley:

Also see:
https://wiki.archlinux.org/title/environment_variables