Pad tapping doesn't work under LXQT [SOLVED]


#1

I’m not sure if I’m posting this in right place, because my LXQT is self installed so I’m not using LXQT edition. I just used sudo pacman -S lxqt meta-package to get it.

In all other DEs I have (plasma, gnome) tapping works but for some reason not in LXQT. Not sure if it’s related but in SDDM tapping also won’t work.

Do I miss some package or must reconfigure? Drivers should be fine if tapping works in other DEs, or maybe driver is not properly launched or set?


#2

Could it be an openbox issue?


#3

In LXQT my default compositor is kwin and it still doesn’t work. Checked openbox session and it has the same problem - no tapping detected.

My guess is: it’s not compositor/WM dependent - tapping from some reason doesn’t work in SDDM and DEs like LXQT and openbox don’t run driver or something extra to make it work like in other DEs. If I made tapping work in SDDM, probably it would also start to work in LXQT and openbox sessions.

Tried to solve my my DM issues with no tapping detected but so far didn’t find anything useful on google.


#4

mainstream DE-s have some sort of settings daemon to handle touchpad abilities. Not so much on a display manager, or a minimal DE/WM.

Start here https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Configuration


#5

Thanks @badbodh
I followed the suggestion but with no luck. Here is what I’ve done:

I checked my /usr/share/X11/xorg.conf.d/50-synaptics.conf and nothing out of the ordinary, tapping should work. Installed gpointing-device-settings and it shows as if tapping was enabled…

Then on the page you gave me, I stumbled on this:
https://wiki.archlinux.org/index.php/Touchpad_Synaptics#The_touchpad_is_not_working.2C_Xorg.0.log_shows_.22Query_no_Synaptics:_6003C8.22

Then it hit me. During Gnome 3.20 update they moved from synaptic drivers to libinput so I installed it but didn’t get rid of synaptic drivers. Can this be the cause? I tried the solution from arch wiki and added MatchDevicePath “/dev/input/event*” to my /etc/X11/xorg.conf.d/50-synaptics.conf file. No change :frowning:

So I decided to remove synaptic xf86-input-synaptics. Rebooted and… no change… Pad is working, two finger scrolling is working but no tapping is detected.
At the moment I’m out of ideas.


#6

Found SOLUTION!

I started thinking, if I run libinput now I should check it’s settings. It’s conf was pretty barren so I checked arch wiki and found this:
https://wiki.archlinux.org/index.php/Libinput#Touchpad_configuration
I added this /etc/X11/xorg.conf.d/30-touchpad.conf file as suggested on the site and rebooted and IT’S WORKING! :slight_smile:
Also in SDDM tapping works!

P.S. Is there a proper way to mark topics as solved other then editing topic’s name?


#7

Between the actions buttons (like, link, flag) there is one with 3 dots. Press and it shows more. One of them is “Solution found in this post” Checkbox.


#8

next to the like and flag button is also a button for “this reply solved my problem” button. it might only be available to higher level members, though. i am not sure about that.

i just pressed this button for you…


#9

Nice job fella. Now we can link your solution to other folks who may need it. Bookmark.


#10

'LLo,

Imho, with just adding Option “Tapping” “on” in the above file, it will works too…
& don’t forget synclient -l in terminal to find out/test what options are available :wink:


#11

Thanks :slight_smile: , didn’t notice it. However it only marks an answer, not the whole thread. It would be nice to have an option to change topic name as solved automatically, but still it’s nice that topic can be changed later manually anyway.


#12

it add a marks (on left) on the title to show it solved in the topic list. but not visible if you’re reading the topic beside in the post.

.


#13

Ah, the marked box icon on the left of the topic? Great, thanks :slight_smile:


#14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.