PacUI: Bash script providing advanced Pacman and Yay/Pikaur/Aurman/Pakku/Trizen/Pacaur functionality in a simple UI

cli
pacui
aur
pacman
yay

#423

wow, this sounds strange.

the only commands in “maintain system”, which might influence other packages on your system are the following:

  • sudo pacdiff , but only, if you used it to change your config files. if your problem persists without editing config files, this command cannot be the cause of your problems.

  • when you removed old AUR files after a warning like "The following packages are neither in your package repository nor the AUR. " appeared, it can explain the change of behavior. if you did not remove packages with “maintain system”, it cannot be the cause.

  • sudo find -xtype l is used to find symlinks. if you removed symlinks, it can influence other packages.

  • sudo pacman -Rsn $(pacman -Qqdt)is used to remove orphaned packages. if you removed orphaned packages, it can influence other packages.

  • sudo rm -r /tmp/* removing all files from temp directory can influence the behavior of other programs, IF they save files there and use/require those files for normal operation. please check, what kind of files are located in your /tmp/ directory (when keyboard shortcuts work on your system).

does any of the above mentioned commands can explain your problem? have you done any of the things i have described above?


#424

well i was just giving a heads-up just in case you come across this from anyone else, im busy atm with my own projects but what i will do when i get a little time is to break down the Maintain System function into it constituent parts and try them individually until i find which part specifically is causing the problem.

Will let you know, cheers.


#425

so i thought id just quickly try your commands and found its the tmp directory thats causing the problem. I checked my shortcut keys were working and then I executed

sudo rm -r /tmp/*

After that the shortcuts dont work.

Here is my tmp before the rm

❰greg❙~❱✘≻ sudo ls -al /tmp/*
[sudo] password for greg:
-rw-r–r-- 1 greg greg 23 Apr 27 19:03 /tmp/latte-dock.greg.lock
-rw-r----- 1 greg greg 0 Apr 27 19:03 /tmp/qipc_sharedmemory_MSMNotifierforPlasmad7cd3d9ed002d00038761dcd548b1461629c9f02
-rw-r----- 1 greg greg 0 Apr 27 19:03 /tmp/qipc_systemsem_MSMNotifierforPlasmad7cd3d9ed002d00038761dcd548b1461629c9f02
srwxr-xr-x 1 root root 0 Apr 27 19:03 /tmp/sddm-auth56ef6490-5ec5-4dc9-969a-00203876e839
-rw------- 1 greg greg 52 Apr 27 19:03 /tmp/xauth-1000-_0

/tmp/systemd-private-ecc0a835911e47eab7c049fcfd3da37a-colord.service-mfACdJ:
total 0
drwx------ 3 root root 60 Apr 27 19:03 .
drwxrwxrwt 12 root root 360 Apr 27 19:05 …
drwxrwxrwt 2 root root 40 Apr 27 19:03 tmp

/tmp/systemd-private-ecc0a835911e47eab7c049fcfd3da37a-ModemManager.service-Qcuqd0:
total 0
drwx------ 3 root root 60 Apr 27 19:02 .
drwxrwxrwt 12 root root 360 Apr 27 19:05 …
drwxrwxrwt 2 root root 40 Apr 27 19:02 tmp

/tmp/systemd-private-ecc0a835911e47eab7c049fcfd3da37a-ntpd.service-5hpKDL:
total 0
drwx------ 3 root root 60 Apr 27 19:04 .
drwxrwxrwt 12 root root 360 Apr 27 19:05 …
drwxrwxrwt 2 root root 40 Apr 27 19:04 tmp

/tmp/thunderbird_greg:
total 0
drwx------ 2 greg greg 60 Apr 27 19:04 .
drwxrwxrwt 12 root root 360 Apr 27 19:05 …
-rw-r–r-- 1 greg greg 0 Apr 27 19:04 .parentlock
❰greg❙~❱:heavy_check_mark:


#426

thanks for testing!

i will limit the deletions in the /tmp/ directory to files created by pacui.
this should solve your problem. i will PM you as soon as i am done, so you can test it.


#427

P.S. it also broke my user log-off (SDDM) because i tried to test if i could get my shortcuts working again by just logging out and in but it got stuck trying to load the SDDM, had to hard shutdown.

All ok now though after a reboot.


#428

@JackDinn: i have just changed pacui to only remove its own files from /tmp during “maintain system” and “fix pacman errors” in this commit: https://github.com/excalibur1234/pacui/commit/cd4442882628b6159513d00a248915f7084ad28d

it works as intended on my system. feel free to reinstall pacui-git and test it yourself.
thanks again for the bug report!

the /tmp directory gets deleted during every reboot. therefore, rebooting your system ALWAYS solves this problem.
this is the reason why i put all temporary files of pacui there: after a reboot, everything is cleaned up again without any need for manually deleting all that stuff.


#429

Yep thats got it, works fine now. Thank you for the support & work :smile:


#430

After i have used the maintain system option of pacui (on Plasma testing branch) , i am not able to start anything anymore , also on logout i get a black screen and can only login by hitting ctrl+Alt+F2.


#431

after this bug report, i did some testing myself and noticed that double clicking the “dolphin” icon did no longer open dolphin, but starting dolphin from the terminal worked.
however, my system never crashed or gave me a black screen after boot.

the solution to your problem is simple: install and use pacui-git, which contains the fix.
maybe, it is time to do another bugfix release…


#432

Well installed the pacui-git , but the problem persists , only when using the terminal i could start anything. btw no problem (re) booting just when loggin out i get a black screen with the cursor on it where a login screen should be.


#433

This sounds like a release worthy bug fix


#434

only a reboot recreates the files in your /tmp directory…

did you reboot?

by “reboot”, i mean you started a new session. in your kde settings, you can check “start with an empty session” instead of “restore previous session”.


#435

It seems to be working fine now (after a reboot) thanks.


#436

i have just released version 1.10.2 of pacui: https://github.com/excalibur1234/pacui/releases/tag/1.10.2


#437

Suggestions/Questions:

  • Would be nice to have an option to check updates similar to checkupdates, but be able to scroll through them to view package info.

  • There doesn’t seem to be any indicators for whether you have a package installed or not while browsing through PacUI, such as in Install Packages or List Package Files.

  • Currently, when you go to Install Packages, all of the AUR and official repo files are mixed in. Maybe it’d be able to choose between Official, AUR, or Official + AUR to list?

  • Left & right arrow keys to skip to next “page” in the list of packages? So that I don’t have to keep scrolling down each individual package in the list. As in make it the same function as Page Up & Page Down buttons.

  • I noticed that links in the package infos gets underlined when moused over… is it supposed to do something when you click on it? Because it doesn’t for me. It’d be useful since I’d be able to click on the AUR link to read the AUR comments before installing.

  • Fix the screenshots in the opening post, as it doesn’t have any showing currently :stuck_out_tongue:


#438

This would also boost performance for the info window.

Consider filtering out or marking installed packages from the install function?

Another idea:
Add a dekstop file to start pacui from gui menus.


#439

That is something you can easily do yourself if you want it.


#440

Pacui is a potentially dangerous program in disguise of an easy to use program. It might be better to hide it a bit and not to present in the applications menu.
A casual user: “Oh, Option 2 Maintain System. Sounds like a good idea!”


#441

when you use pikaur as AUR helper and do “update system”, you can choose “p” to show package details before updating.

you are right.

depending on the AUR helper you use, you see which packages are installed because the info text differs and in some cases even shows you the installation method, package maintainer, etc.

for example, i could add an “i” in front of all already installed packages. this means i need to query the entire list of packages. i have thought about doing this long term anyway and adding infos such as “this package is from system repository”, “this package is from the AUR”, “this package is a flatpack”, “this package is a snap”, … but there are no “snap” or “flatpack” helpers for arch linux which i can start to use. maybe, i have to do a little more research and testing on this subject…

i agree with Chrysostomus’ argument. but besides that, i cannot really see a use case for an install option, which is limited to official packages only.

i hope you are able to easily spot the difference between AUR and non-AUR packages in the package list: AUR packages do not have any package description.

if you are distracted by the amount of AUR packages in your search results, you can start to filter your search. e.g. searching for firefox package is easy, if you type (without " symbols): “^firefox”

can you tell me an use case for an install option, which is limited to official packages only?

there was once a case started to manually scroll through the list of packages and then complained about it being so much work to install anything.
i hope you know that you can start to type in order to filter the displayed list of packages?

for the display of lists, pacui uses fzf. you can assign keyboard shortcuts in fzf.
this means i am probably able to do this. let me test this a little bit…

i have not noticed this yet, but you are right. this happens in my terminal and shell, too.
i have to take a look at fzf, whether i am able to set fzf to open links or not.

in any way, you could use “rxvt-unicode” as your terminal with the “url-select” perl extension, which makes you able to open ALL URLs in your terminal with the push of a (customizable) keyboard shortcut.

edit: i just found out, that yakuake/konsole have a setting in their profile to underline files/URLs and open them with a left mouse click. but i think (most of) these settings are disabled by default.

edit2: it also works in the “termite” terminal as mentioned below by @deadguy : PacUI: A simple Bash Frontend for Pacman and Yaourt/Pacaur

done.

i usually just copy and paste the github homepage to the OP of this topic. i try to keep everything up to date on github, but not really in this topic…


#442

How about not listing AUR packages if no AUR helper is present? I think that might be useful