PacUI: Bash script providing advanced Pacman and Yay/Pikaur/Aurman/Pakku/Trizen/Pacaur functionality in a simple UI

cli
pacui
aur
pacman
yay

#401

it seems that some people have problems downloading (and using) the list of AUR packages. this is done in the beginning of the “install packages” option.

internally, this command gets used currently (in version 1.9.2):

wget -P "/tmp/aur/" "https://aur.archlinux.org/packages.gz" &>/dev/null && gunzip -f "/tmp/aur/packages.gz" && cat /tmp/aur/packages

i have recently adjusted this command, because the old command stopped working. the old command i have used was:

wget -P "/tmp/aur/" "https://aur.archlinux.org/packages.gz" &>/dev/null && cat /tmp/aur/packages.gz

i have tested both commands and on my systems (manjaro with bash/zsh and arch linux in VM) only the upper command is working.

if your experience is different, we have to find the cause of your problem.


when doing some tests, it might be worth to delete the aur folder in your tempfile directory before running each command listed above.

sudo tm -r /tmp/aur/


[Testing Update x32] 2018-02-01 - Kernels, pacman-mirrors, manjaro-architect
#402

because of an report on github, i have just added support for narrow terminal windows.

by default, pacui will now show its preview windows (with package information) on the right side, if terminal width is 120 columns or more. in case the terminal is narrower, the preview window is shown on the bottom.

if terminal width is below 66 columns, pacui’s UI is not correctly displayed anymore. in this case, i recommend to use “pacui h” instead of “pacui”. “pacui h” shows a short help menu, which includes ALL pacui options (including hidden options).

this change should make pacui more usable on (uncommon) tiny screens/resolutions and tiling WMs.


#403

I noticed recently that pacui clears the screen before fzf operations. Could this be disabled for tmux, or alternate fzf-tmux not be used? It kinda defeats the purpose of using fzf-tmux, and the TTY garpling issue is not present inside tmux.

If using the whole terminal, there is more room for previews and such. So I would not mind that option either.


#404

fixed. now, the screen is only cleared in tty.

i have also fixed an “unbound variable” error and upgraded the hidden ‘downgrade’ option.


#407

on the matter of AUR helpers, have you looked at pikaur? it seems like it could be an interesting option too.
I plan on trying it out in the coming days, keeping trizen as backup


#408

trizen is my current winner for all the reasons. I’ll probably make an alias for it though, as ‘trizen’ is cumbersome and non-intuitive.
As to pikaur - seems to be only a month old on github and has 1 vote on aur. Would be interesting to find out how well it does with split-packages and whether it uses a clean build environment, etc.
A bit young for my tastes, but a nice find. Let us know how it works out.


#409

no.
but please let me know what you think about it after testing it for a while.

it look like the guy, who develops pikaur has been quite active on github. this means that development should be quite rapid.

i really like the promises of pikaur. they hit exactly the pain points of trizen:

  • checking PKGBUILDS (and hopefully .install files) all at once. i also hope that PKGBUILDS only have to be checked once and you only have to check diffs in the future. this was one of my favorite features of pacaur.
  • installing all packages without user intervention. this was also a great feature of pacaur.

let’s see how it develops :smiley:


#410

i want to bring a little attention to a recent development in pacui:

@nowakf had an idea for improving pacui for narrow terminals here:
https://github.com/excalibur1234/pacui/issues/30#issuecomment-364401100
i have tested and implemented his idea, after some minor changes.

pacui should now be usable on terminals/ttys with 16 lines of height and 66 columns of width (when using the UI).
if you want to use pacui on even smaller terminals, you should use pacui without UI: simply use “pacui h” to start a list of all (even hidden) pacui commands.

there are hardly any screens with such low resolution nowadays. but these changes are hopefully beneficial for tiling WMs!


p.s.: pikaur is still being developed at a crazy rate. i keep checking its progress…


#411

Nice to hear!

btw, should you perhaps drop the tmux integration? Currently the when fzf-tmux launches, a new pane is opened, but (unlike before) the contents of the original pane are hidden. It defeats the purpose of fzf-tmux, and the price is still Gavin half-sized fzf window (not great with previews)


#412

done.

i have never (seriously) tested fzf’s tmux integration myself. when you say it is bad, i believe you.


#413

i have just implemented support for pikaur in pacui-git.

i am testing it. it looks promising, but i have already found some weak behavior:
when you try to install 0ad-git (from the AUR), it needed half an hour to check dependencies (maybe longer, but i have cancelled the installation after that time span).

feel free to install pikaur and test it with pacui. attention: when you want to use pikaur, you have to remove trizen, yay, and yaourt from your system (but can keep pacaur).


#414

I also found some problems with yay. If the aur package has unsatisfiable dependencies, it doesn’t let you fix it by editing the PKGBUILD, but just bails out. Fortunately you can get the PKGBUILD with yay -G, fix it and makepkg -sric.


#415

Trizen still winning :slight_smile:


#416

i have just added a huge commit to pacui-git:
https://github.com/excalibur1234/pacui/commit/bd6da528fa65e30eca952a4ad7c98d0a818e70d1
it contains about 350 new lines of code.

there is now a new ‘flag’ option for pacui. the content of ‘flag’ will be passed directly to your AUR helper and/or pacman. this flag can be used with these options (and it does not have any effect on other options):

  • update
  • install
  • remove
  • roll back
  • edit config files
  • force update aur
  • downgrade

examples of usage:

  • using it in a bash standard compatible way:
    pacui -i --flag="--noconfirm"
    pacui --i 0ad --flag "--noconfirm"

  • using it pacui style (i.e. however you like):
    pacui u flag --noconfirm
    pacui flag=--noconfirm i 0ad
    pacui --I --bash --FLAG --asdeps

this ‘flag’ option is meant for better scriptability using pacui, either in other scripts or with a simple bash alias.

i could not test this with all AUR helpers (and without any AUR helpers) with every pacui option it works for. please test this and report back, if you find bugs.


#417

May I ask you, when will the new pacui version arrive on stable?

I’ve also a problem with pacui and I don’t want to install the -git version.

After using this menu item:

11 Edit Config Files

Then I get this error message:
XDG_CONFIG_DIRS ist nicht gesetzt

Thanks in advance


#418

you are right. i know about this bug, because i have fixed it a couple of days after the release of the last version.

if no serious bugs appear in pacui-git during my testing or are reported, expect the next version this week.


#419

sorry for the delay.

i have just released version 1.10 of pacui.
changelog is available on github: https://github.com/excalibur1234/pacui/releases/tag/1.10


#420

i have just found an article about pacui: https://itsfoss.com/arch-pacli-pacui/

it is not entirely accurate, but gives a nice overview of pacui (and pacli).
it is always interesting to read what other people think about pacui!


#421

because of some misunderstanding, version 1.10 was not available in the manjaro repositories until now.
version 1.10 was available in the AUR since its release, tough.


version 1.10.1 has been released.
it mostly fixes bugs, which i have noticed before the 1.10 release:

https://github.com/excalibur1234/pacui/releases/tag/1.10.1


#422

Im noticing a problem that i just wanted to mention.

Its after running the “Maintain System” , it runs through everything fine but after its finished a lot of odd things start happening with some of my shortcuts. My Ctrl-Esc stops working, my print-screen button stops working intermittently and all my python script shortcuts also stop working.

It took me a while to figure why my shortcuts were not working but i found it was pacui Maintain System. I have double checked that is is definitely causing this problem.

checking the logs i get this error when pressing the shortcut keys, which i was not getting before i run pacui Maintain System.

Apr 27 02:38:16 greg-pc python3[14635]: qt.qpa.screen: QXcbConnection: Could not connect to display :0
Apr 27 02:38:16 greg-pc python3[14635]: Could not connect to any X display.


Custom shortcuts not working any more?