PacUI: Bash script providing advanced Pacman and Yay/Pikaur/Aurman/Pakku/Trizen/Pacaur functionality in a simple UI

cli
pacui
aur
pacman
yay

#261

here is a paragraph about the search syntax in pacui’s lists (a.k.a. fzf):

in essence, it is just a couple of examples for regular expressions. but those can be really useful, especially for the “search package files” option.

despite knowing some of that syntax by heart, i still enjoyed reading about them again.


#262

I get “editor variable not set” error the previews


#263

Maybe you need to set export VISUAL=/usr/bin/vim or similar?


#264

I’ll test it. It wasn’t at least editor or EDITOR that was needed.


#265

i have set these variables:

export EDITOR="/usr/bin/nano"
export VISUAL="/usr/bin/nano"

in the “install package” option is no editor needed (at least not explicitly in the bash syntax).

do you get the same error in “install packages”, “remove packages”?
do you get the error message on the right side (where the package information should be? or do you get as normal terminal output?
do you get the same error message for packages, from the AUR, the manjaro repositories and package groups?


#266

I have the same variables set. New information: the problem occurs only inside tmux.

The exact message is editor variable unset


#267

strange.

tmux works for me:

but seeing the error message made me think: pacaur’s error messages start with a double colon.
does

pacaur -Qi chromium

work for you (in tmux)?

i have no experience with tmux at all, but are you sure that your EDITOR and VISUAL variables are read and used by tmux?

p.s., i just found these. it is definitely a problem of pacaur (in your tmux):





#268

Could you post your tmux.conf? I would like to compare to see if the fault lies there. Oddly enough, pacaur -Qi and Si work without problems. If I install vi, then the pacaurs fallback mode catches the issue and it works. But the actual values of EDITOR and VISUAL are not used, even if I export them again.


#269

Fixed with

    echo "editor=$EDITOR" >> $XDG_CONFIG_HOME/pacaur/config

I suggest adding to the script

if [[ -e /usr/bin/pacaur ]] && ! [[ -e $XDG_CONFIG_HOME/pacaur/config ]] && ! [[ -z $EDITOR ]]; then
    mkdir -p $XDG_CONFIG_HOME/pacaur/
    echo "editor=$EDITOR" >> $XDG_CONFIG_HOME/pacaur/config
fi

This creates pacaur configuration using the chosen $EDITOR if it is set and there is not a configuration file already. This remedies the situation.

Alternatively, make vi a dependency for pacui.


#270

I have a guess as to why why it doesn’t work with tmux by default: the new tmux window is a separate shell and doesn’t source ~/.profile (which is weird). That’s why it doesn’t matter if EDITOR is set in the shell.


#271

pacui-git looks nice (but there is a glitch), but it doesn’t install anything - “target not found”, while pacman works. Screenshot from Sterminal, fresh bspwm install with m-a.


#272

ah yes.

i assume you did some work with pacui / the old pacui-git and now installed the new pacui-git. the error will go away after a reboot (please tell me, if this is NOT the case).

alternatively, you can do this to fix your problem on a running system:

sudo rm -r /tmp/

(the problem here is efficiency: pacui will create lists in /tmp/ directory of all packages in the AUR and manjaro repository. this means you do not have to download the package lists every time you execute “pacui i”.
but the format of that package list has changed. the new pacui does not understand the format of the old list.)


#273

besides a lot of small changes, i have added a check for EOL packages to the “clean system” option.

yesterday and today, @thefallenrat was busy with adding arch linux support to pacui (only the “clean system” and “fix pacman errors” option needed that anyway). thank you very much for that!
he has also found a new method to install important packages on a system with broken keyrings. this new method simplifies the code quite a lot and makes it more robust (and it works in both manjaro and arch linux).

i have not thoroughly tested pacui on arch linux yet, but i will do that in the following days. feel free to do the same and report any issues or possible improvements. i am especially interested, whether the following command sets acceptable mirror servers worldwide:
sudo reflector -f 5 --sort age --save /etc/pacman.d/mirrorlist && sleep 20 && sudo pacman -Syy
if there are no serious complaints or problems, i will release a new version of pacui in about a week.


#274

I will try it on my archlinux32 install, maybe on atrix, too.
And will also report what happened after the reboot with pacui-git. Edit: A reboot resolved the issue with pacui-git.


#275

My first successful pull request! Thanks @excalibur1234 !


#276

i have just released version 1.6 of pacui.
thanks to all the testers and contributors to the latest release of pacui!

the release announcement and changelog is available on github:
https://github.com/excalibur1234/pacui/releases/tag/1.6


#277

Yay! I get to out it on a screenshot for bspwm edition release!


#278

because of a couple of serious bugs in pacui 1.6, i have just released version 1.6.1, which should fix these bugs.


#279

I’ve ran PacUI, just to see how it does the job.

Pamac doesn’t give me any updates, PacUI gives warnings and errors.

Look:


#280

i have no clue about the second screenshot your posted, but the first is easy to explain:

you have used the testing/unstable branch until recently and have switched back to the stable/testing branch. alternatively, you have not synced your package database with the mirror server you use.

in any case, you should run the “clean system” option in pacui. if the errors are still present (and you want to downgrade your packages to fit your mirror server), i recommend to follow the instructions here:
https://wiki.manjaro.org/index.php?title=Access_the_Unstable_Repositories#Reverting_Back_to_the_Stable_Repositories