Pacman warnings - local is newer than core

i just laubched update manager abd selected update datebases and was presented with the below error messages. have no idea on how to fix these.

Warning: lib32-systemd: local (244.1-1) is newer than multilib (242.153-2)
Warning: systemd: local (244.1-1.1) is newer than core (242.153-2)
Warning: systemd-libs: local (244.1-1) is newer than core (242.153-2)
Warning: systemd-sysvcompat: local (244.1-1) is newer than core (242.153-2)

They are not error messages. Just warnings.

They simply inform you that you have packages installed locally, that are newer than the ones found in the repo.
in your case, it's systemd.
You can either:

  1. Ignore them, if your system works without issues.
  2. Downgrade to the packages from the repo with sudo pacman -Syuu.
5 Likes

o.k. so i have the newer? then i just missread. thanks

Follow the testing announcements, see here for example:

2 Likes

must not of gotten that cause i just went into that section of my settings and added that and announcements prior to updating databases. thanks for the info.

FYI: Changed title and marked @Strit's post as solution.

Hello,

I have the same here.

I know that I can safely ignore those warnings, but unfortunately, they are stopping the upgrade via Pamac, as Pamac waits for a confirmation.
As it is annoying to have to confirm these warnings at each Pamac run, is there a way to suppress them?
I don't want to downgrade, so pacman -Syyuu is not an option for me.
Or do I only have the choice not to use Pamac for installing updates?

Kind regards.

Forum kindly sponsored by