pacman update warning lib32 mesa is newer as multilib

Hallo,

I have got a warning message on my last pacman update:
sudo pacman -Syu

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: lib32-libva-mesa-driver: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: lib32-mesa: local (19.0.1+really+18.3.5-1) is newer than multilib (19.0.1-1)
warning: libva-mesa-driver: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
 there is nothing to do

Last update was on Saturday 06.04.2019! Should i roll back these packages?
Best regards,
Volker Voß

1 Like

This 'downgrade' is not really a downgrade but an upgrade, as version 19.0.1+really+18.3.5-1 is in fact 18.3.5-1, whereas in the repositories the current version is at 19.0.1-2. It is strongly recommended to use e.g. pacman -Syyuu to sync with the repositories and 'downgrade' to 19.0.1-2.
For further information see the wiki post of the stable update (section "warning: mesa: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)", what should I do?):

4 Likes

Thanks for the quick solution.

Best regards,
Volker voß

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark