Pacman reporting corrupted pgp again


#1

My topic was closed so I have to continue here.
No matter what I do, pacman just keep giving me some dumb errors.
Live usb or a fresh system, Trust All set in pacman.conf, imported all the needed keyrings, still the same.
Its not the first time I got beef with pacman but it was never so hard, I’d like to know how exactly this pgp checking works because I have noatime in fstab and Im travelling a bit so it might be some issue with time/ntp, or maybe pacman is just a garbage app and it should be renamed to crapman :smile:


#2

From what I can see and the little I understand the working of gpg/pgp - the signatures don’t pan out when it checks the servers (assumed of course).

In general, I don’t think its a Pacman issue you are having but a valid key that is trying to be imported and or verified.

This looks very similar to what happens with Debian when the keys get jacked up when using synatpic and apt.

When I ran Debian, there was a process I used to get by that but it escapes me and I wouldn’t advise trying that on Arch. I was moving away from Synaptic for apt. Once I used apt, the issues went away.

So in short, I don’t believe its a pacman issue but rather something that gpg does not like when trying to verify/validate the keys/signatures.

Does that make some sense?


#3

And as a follow up - look at the dates the keys were created. While it is true one can put an unlimited (or never expire) time on the keys, most folks cycle them about every year.

It very well could be that due to the age of the keys, they simply expired - this will cause the errors you are seeing.


#4

This issue can happen for three reasons, sorted by descending likelihood:

  1. your pacman keyring is old and you need to refresh pacman keys. This happens especially on old live isos and installations made with them. That is why there is an option to refresh the keyring in the preparation section of manjaro-architect.
  2. one or more package maintainers forgot to renew their pacman keys in time.
  3. some package is actually corrupted.

Anyway, these are issues with repos, not with pacman. Issues 2 & 3 are fixed by waiting and possibly updating the mirrorlist, issue 1 is fixed by refreshing pacman keys. I would start with 1. If your live iso is not very new, you can also just download a newer release.


#5
sudo pacman-key --refresh-keys
sudo pacman -Syyu

#6

If you do not wish to repeatedly have your threads closed, perhaps quit with your continual ignorant and denigrating comments…

You could try this:

sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo pacman -Syyu

Post all output.


#7

I posted this before, I’ll post it again in the hope you’ll read it:


#8

You should make sure you time is correct or verification of keys will fail. That may also happen for websites.


#9

If you are travelling you must adjust your time zone, and set your time to be updated. An old battery on on your motherboard can also result in your time getting out of sync. Dual booting with Windows can also cause time misalignment on Linux.


#10

Ay.I’have set ntp deamon to autosync on startup but from what I see its not working as I intented, ext4 journals says that some nodes was last accessed in the future, so its most likely the dying battery case, and I cant do nothing without new CMOS battery, so this can be pain in the *** if you have ie warranty-void-stickers.There should be at least some poweruser-option on pacman to force install any package ignoring any errors, at user responsibility.It would certainly save my day(s).Thx for help anyways.

Cheers folks, take care!


#11

LOL, what a ridiculous statement.

Pacman doing exactly what it should security wise, just so happens the person using it seems pretty clueless, so blames the [wrong] tool instead. LOL.

:roll_eyes:

Update your arch and manjaro keyrings.

If this occurs on an AUR package install you’ll have to import the specific AUR key manually. There are threads on this exact issue.


closed #13

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.