pacman/pamac time based command + package install question

Hello everyone,

Short version of issue:

1 - How can I uninstall (automatic, without dependency issues) all the packages I installed in the last 36h? Do I need to check manually and do one by one?
2 - I need a piece of software that either exists as binary somewhere on provider webpage (with source code also but that's a whole differente league) or exists in AUR. In a lot of posts admins alert for the dangers of installing through AUR (I'm noob on the issue) but also problematic to install manually (issues for updating, for removing, for listing manually installed packages, etc). Any generic/general criteria to decide which method to use? Consider for such that in AUR the packages have popularity in the rage [2.0, 4] and aur wiki does not mention weird behaviours or comments.
3 - upon doing pacman -Syu I get lots of warnings refering that local packages are newer than repo. I just need to run pacman -Syyuu? I just don't want to crash the system and get an answer like "we said it would happen" or something aahah


Longer version:
1 - So, I have an external gpu (mantiz venus dock + amd rx card) with thunderbot 3. I had everything working perfectly but some time ago out of nowhere I couldn't boot my laptop, always with error unkwown filesystem etc (tried all tutorials on the forum, dozens of tries but no luck) So I did a fresh install of manjaro (last edition wouldn't work either and only by using an older edition I managed to proceed with instalation). Yesterday I tried to setup my egpu again (using the same commands and same install guides as on first time, even the one I wrote based on first successful install). However, performance dropped (like loading webpages on browsing), the software I use everyday stopped working (Lutris would not even launch, on terminal it would immediately return an error concerning opengl, gfw or similar error). Then I thought I could be missing packages specific for the amd gpu and to the errors so I installed a bunch of stuff that could be related. It still didn't work and upon disconnecting the egpu the laptop would not shutdown (black screen with processes being terminated related to thunderbolt 3 but at some point, like 4minutes, it was on a loop and would have to force shutdown on power button). I'm kinda scared of trying it again to find a solution after many attempts and after a force shutdown not being able to start the system again.... I'll take this issue to egpu.io


Disclaimer: this linux distro has been the best experience ever in my time on full linux. I'll start contributing (still student so, kinda modestly :frowning: )
A big thank you to all the people that make this happen.

Go through the pacman logs and make a list of the packages you have installed and remove them all at once. If you try to remove them one at a time you will have dependency issues.

If you know what packages you explicitly installed it is easier, but if you don't you can just go through the logs.

It will almost always be easier to use AUR than manually install a binary from somewhere. The keys to safely using AUR is to review the PKGBUILD and the comments on the AUR page before installing. AUR is not less safe than most other distros community maintained repos, arch/manjaro users are just more conservative than some of the more mainstream distros.

It depends which packages they are, can you provide the output?

In order to help with this we will probably need some additional specifics like some of the errors you are receiving and a description of what you did.

WOW. Super fast, thank you so much!!!!!

1&2) regarding this i'll proceed on doing that from now on! I would mess up since I was ready to go one by one ahah.

  1. regarding this the output of sudo pacman -Syu is the following:
:: Synchronising package databases...
 core is up to date
 extra                   1830,3 KiB  6,62M/s 00:00 [######################] 100%
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: libva-mesa-driver: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: mesa-vdpau: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-intel: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
warning: vulkan-radeon: local (19.0.1+really+18.3.5-1) is newer than extra (19.0.1-2)
resolving dependencies...
looking for conflicting packages...

Packages (3) libwbclient-4.10.2-0  samba-4.10.2-0  smbclient-4.10.2-0

Total Download Size:   12,26 MiB
Total Installed Size:  75,29 MiB
Net Upgrade Size:      -0,04 MiB

:: Proceed with installation? [Y/n] 

Regarding the long version I'll update the thread tomorrow as soon as I get home, some of the output I need to take a picture at (about shutdown, all others I get from terminal).

A big thank you :)))

Take a look here about Mesa:

I think it i read right..you should downgrade :thinking:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark